LINUX.ORG.RU
ФорумAdmin

Подключение к домашнему VPN серверу.


0

1

Добрый день. Тут такое дело. Есть VPN сервер на linux mint 13. Демон pptpd запущен. Прослушка на порту есть. Все просто. Сервер и клиент в одной сети за роутером. Клиенты windows подключаются без проблем. Линуксовый клиент коннектится только на пару секунд и тут-же отваливается.

В syslog сервера нашел: GRE read(fd=8,buffer=8058520,len=8260) from network failed: status = -1 error = Protocol not available

После этой записи начинается свистопляска со словами falled и.т.п

Фаер выключен на обоих машинах.

Подключаться необходимо через Network Manager (собственно ради чего все и затевалось)

Есть идеи? Может кто сталкивался?....


А на сервере, случаем, нет ipsec?

dbzer0 ()

Такая штука обычно бывает, когда на рутере не включено что-то вида «PPTP Passthrough». Если рутер на Линуксе, то разрешить gre проходить. Магическим образом вендовые клиенты могут работать, хотя тоже не всегда, а вот линуксовые обламываются.

Mr_Alone ★★★★★ ()
Ответ на: комментарий от mky

Пытался поднимать соединение NM Не вышло. Сейчас пытаюсь без онного.... И по этому те (старые) логи выложить не могу.

Клиент и сервер в одной сети за роутером. Проблемы роутером(маршрутизатором ) отпадают.

Сейчас ситуация такая.: На сервере собирается вот такая солянка: /var/log/pptpd.log require-mschap-v2 # (from /etc/ppp/pptpd-options)
refuse-pap # (from /etc/ppp/pptpd-options)
refuse-chap # (from /etc/ppp/pptpd-options)
refuse-mschap # (from /etc/ppp/pptpd-options)
name pptpd # (from /etc/ppp/pptpd-options)
remotenumber 192.168.1.20 # (from command line)
pptpd-original-ip 192.168.1.20 # (from command line)
115200 # (from command line)
lock # (from /etc/ppp/pptpd-options)
crtscts # (from /etc/ppp/options)
local # (from command line)
asyncmap 0 # (from /etc/ppp/options)
mru 1300 # (from /etc/ppp/pptpd-options)
mtu 1300 # (from /etc/ppp/pptpd-options)
lcp-echo-failure 4 # (from /etc/ppp/options)
lcp-echo-interval 30 # (from /etc/ppp/options)
hide-password # (from /etc/ppp/options)
ipparam 192.168.1.20 # (from command line)
ms-dns xxx # [don't know how to print value] # (from /etc/ppp/pptpd-options)
nodefaultroute # (from /etc/ppp/pptpd-options)
192.168.1.20:192.168.1.101 # (from command line)
nobsdcomp # (from /etc/ppp/pptpd-options)
nodeflate # (from /etc/ppp/pptpd-options)
require-mppe-128 # (from /etc/ppp/pptpd-options)
noipx # (from /etc/ppp/options)

sCat ()
Ответ на: комментарий от sCat

Ну выложите новые логи. Просто, желательно засинхронизировать время клиента и сервера и смотреть по логам, кто прервый начинает ругатся и закрывать соединение. Возможно, что дело не в сервере, а в клиенте.

mky ★★★★★ ()
Ответ на: комментарий от mky

Уряяяяя!!! Заработало.

Дело наверно в том, что выключенный фаервол и ваервол с пустым списком правил - это разные понятия.

Ну откуда было знать простым смертным.........

Подключился без NM. Пока так.

sCat ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.