LINUX.ORG.RU
ФорумAdmin

Poptop или ppp


0

0

RH 9, poptop 1.1.4-b4, ppp-2.4.2+ppp-2.4.2-mppe-mppc-1.0.patch.gz
ядро патчил kernelmod`ом.

При конекте по vpn в логах пишет:
GRE: read(fd=5,buffer=804dc00,len=8196) from PTY failed: status = -1 error = Input/output error

pptpd.conf
lock
mru 1490
mtu 1490
lcp-echo-interval 30
lcp-echo-failure 5
debug
proxyarp
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
require-mppe-40
require-mppe-128
mppe-stateful
cp-max-configure 100

Запускал pptpd -f жалуется на все что связано с mppe.

/usr/sbin/pppd: In file /etc/ppp/options.pptpd: unrecognized option require-mppe-40
+mppe-40 та же беда.
Подскажите в чем проблема ppp или pptpd?

И еще вопросик.
Как поменять путь на запуск pppd. Судя по логу берет его из /usr/sbin/pppd, надо /usr/local/sbin/pppd.

anonymous

Re: Poptop или ppp

ppp должен поддерживать mppe шифрование

anonymous ()

Re: Poptop или ppp

> /usr/sbin/pppd: In file /etc/ppp/options.pptpd: unrecognized option require-mppe-40
> +mppe-40 та же беда.
> Подскажите в чем проблема ppp или pptpd?
Патч откуда брал?
http://www.polbox.com/h/hs001/
там пример, как настраивать.
И никаких require-mppe-40 там нет.

> Как поменять путь на запуск pppd. Судя по логу берет его из /usr/sbin/pppd,
> надо /usr/local/sbin/pppd.
а pptpd -h не судьба посмотреть? :)
# pptpd -h
Poptop v1.2.1
...
[-e] [--ppp file]         Use alternate pppd binary, default /usr/sbin/pppd.
...

Deleted ()
Ответ на: Re: Poptop или ppp от anonymous

Re: Poptop или ppp

$ man pppd
...
require-mppe-40
Require the use of MPPE, with 40-bit encryption.
...
$ dpkg -l ppp
ppp 2.4.3-20041231 Point-to-Point Protocol (PPP) daemon

anonymous ()
Ответ на: Re: Poptop или ppp от anonymous

Re: Poptop или ppp

Спасибо все заработало.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.