LINUX.ORG.RU
ФорумAdmin

Настройка VPN! Что за ошибка?


0

0

Помогите окончательно перелесть в Linux... Надоела винда! =)

Linux SL 3.03
Установил ppp-2.4.b3 + pptp-linux-1.3.1-1

В /etc/ppp/options:
local
lock
nodetach

mtu 1512
mru 1512

require-mppe 40
require-mppe 128
require-mppe

lcp-echo-interval 30
lcp-echo-failure 5

require-pap
refuse-mschap-v2
refuse-chap
refuse-mschap
refuse-eap

defaultroute

user mrak
noauth


Делаю:
pptp Server

И получаю в логах:

Feb 23 17:34:16 linuxz pppd[4286]: pppd 2.4.2b3 started by root, uid 0
Feb 23 17:34:16 linuxz /etc/hotplug/net.agent: assuming ppp0 is already up
Feb 23 17:34:16 linuxz pppd[4286]: Using interface ppp0
Feb 23 17:34:16 linuxz pppd[4286]: Connect: ppp0 <--> /dev/pts/0
Feb 23 17:34:16 linuxz pptp[4289]: anon log[pptp_dispatch_ctrl_packet:pptp_ctrl.c:759]: Outgoing call established (call ID 0, peer's call ID 55808).
Feb 23 17:34:18 linuxz pptp[4298]: anon log[decaps_hdlc:pptp_gre.c:217]: PPP mode seems to be Asynchronous.
Feb 23 17:34:18 linuxz pppd[4286]: PAP authentication succeeded
Feb 23 17:34:18 linuxz pppd[4286]: MPPE required, but MS-CHAP[v2] auth not performed.
Feb 23 17:34:18 linuxz pppd[4286]: Connection terminated.
Feb 23 17:34:18 linuxz /etc/hotplug/net.agent: NET unregister event not supported
Feb 23 17:34:18 linuxz pppd[4286]: Exit.

Задача авторизоватьться под pap без всякого шифрования!
Я не могу понять надо патчить ядро на предмет MPPE или ч чем то другом проблема?

★★★

Re: Настройка VPN! Что за ошибка?

MPPE - шифрование. Если нужно, то патчить ядро. Но ты пишешь, что тебе оно не надо, так убери его нафиг из конфига тогда

Chumka ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.