LINUX.ORG.RU
ФорумAdmin

Bacula, исключение каталогов из резервного копирования

 ,


0

1

Настроил себе на дебиане систему bacula (версии 5.0.2) для резервного копирования домашних каталогов юзеров. Раз в месяц полный бекап и ежедневно - инкрементный.

Изначально файлсет был такой:

FileSet {
  Name = blah-blah-blah-fs
  Include {
    Options {
      signature = MD5
    }
    File = /home
  }
  Exclude {
  }
}

Запустил, сделал полный бекап, все ок.

Затем в секцию Exclude дописал немнго строк. Стало вот так:

FileSet {
  Name = blah-blah-blah-fs
  Include {
    Options {
      signature = MD5
    }
    File = /home
  }
  Exclude {
    File = /home/httpd-logs/
    File = /home/lost+found/
    File = /home/mysql/
    File = /home/nginx-logs/

  }
}

но указанные каталоги все равно бекапятся, и занимают они немало места

Почему так происходит и что делать?

FileSet {
  Name = "dns"
  Include {
    Options {
      signature = MD5
      Wildfile = "*.log*"
      Exclude = yes
    }
    File = /etc/named.conf
    File = /var/named/
  }
}

А теперь иди, читай документацию, успокойся и удали ненормативную лексику из тегов. И больше не выставляй себя идиотом.

sin_a ★★★★★ ()
Ответ на: комментарий от sin_a

Простите, исправил.

Документацию читал. Вот же пример файлсета из официальной:

FileSet {
  Name = "Full Set"
  Include {
    Options {
      Compression=GZIP
      signature=SHA1
      Sparse = yes
    }
    @/etc/backup.list
  }
  Include {
     Options {
        wildfile = "*.o"
        wildfile = "*.exe"
        Exclude = yes
     }
     File = /root/myfile
     File = /usr/lib/another_file
  }
  Exclude {
     File = /tmp
  }
}

А это - комментарий к нему:

Let's say that you now want to exclude the directory /tmp. The simplest way to do so is to add an exclude directive that lists /tmp.

freefox ()
Ответ на: комментарий от freefox

С исключением я разбирался не очень долго, приведён пример из работающей конфигурации (немного сокращённый). После получения которого уже не возвращался к вопросу.

Возможно просто где то закралась ошибка в конфигурации, а может быть стоит внимательнее прочитать описание примера, возможно там есть неоднозначность.

sin_a ★★★★★ ()
Ответ на: комментарий от freefox

Да, после внесения секции Exclude, директора не забыл перезапустить?

sin_a ★★★★★ ()
Ответ на: комментарий от freefox

А вообще, сделай тестовое задание на пяток каталогов и файлов и погоняй его изменяя конфигурацию.

sin_a ★★★★★ ()
Exlude = no

Затем перезапуск директора.

blackst0ne ★★★★★ ()
Последнее исправление: blackst0ne (всего исправлений: 1)

Затем в секцию Exclude дописал немнго строк. Стало вот так

Забыли директор рестартовать, а написано правильно.

zgen ★★★★★ ()
Ответ на: комментарий от zgen

нет, рестарт директора был, но на результат это не повлияло

Сейчас несколько изменил файлсет:

FileSet {
  Name = blah-blah-blah-fs
  Include {
    Options {
      signature = MD5
    }
    Options {
        wild = /home/httpd-logs/
        wild = /home/lost+found/
        wild = /home/mysql/
        wild = /home/nginx-logs/
	exclude = yes
    }
    File = /home
  }
  Exclude {
  }
}

и тоже безрезультатно - каталог /home бэкапится полностью

freefox ()
9 сентября 2012 г.
Ответ на: комментарий от freefox

Сейчас столкнулся с той же проблемой. Попробуйте заключить имя исключаемой директории в звездочки: «*tmp*». Так же есть параметр wilddir, попробуйте его. Exclude должно быть yes.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.