LINUX.ORG.RU
ФорумAdmin

Доступ к samba


0

0

Мне надо на сервере обеспечить доступ к некоторой папке для всех пользователей, причем они имеют права только на чтение. Для одного человек доступ должен быть не только на читение но и на запись. Вот мой файл конфигурации, что-то не получается. Может какую опцию забыл...

[global] workgroup = XXX server string = XXX netbios name = Mp3 Server dos charset = CP866 unix charset = KOI8-R interfaces = 192.168.1.3/23 security = user map to guest = Bad User null passwords = Yes obey pam restrictions = Yes passwd program = /usr/bin/passwd %u passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully* username map = /usr/local/samba/private/smbusers log level = 1 smb passwd file = /usr/local/samba/private/smbpasswd syslog only = Yes log file = /var/log/samba/%m.log max log size = 0 socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192 load printers = No local master = No dns proxy = No wins server = 192.168.1.1 invalid users = root

[Mp3 Archive] path = /mnt/mp3 valid users = nobody guest ok = Yes writable = no [admin] path = /mnt/mp3/uplaod browseable = no force user = omikron read only = no admin users = omikron public = no

При попытке зайти на ресурс пишет, что у вас нет соответствующих прав, хотя пользователь omikron создан в системе, и smb пароль добавлен для него.

Re: Доступ к samba

Подобные вещи я обычно делаю симлинком из домашнего каталога пользователя для которого разрешена запись ну и права у него должны быть соответсвующие.

anonymous ()
Ответ на: Re: Доступ к samba от Tezzz

Re: Доступ к samba

Вот короче мой конфиг...
[global]
workgroup = XXX
server string = XXX
netbios name = Mp3 Server
dos charset = CP866
unix charset = KOI8-R
interfaces = 192.168.1.3/23
security = user
map to guest = Bad User
null passwords = Yes
obey pam restrictions = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
username map = /usr/local/samba/private/smbusers
log level = 1
smb passwd file = /usr/local/samba/private/smbpasswd
syslog only = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
load printers = No
local master = No
dns proxy = No
wins server = 192.168.1.1
invalid users = root

[Mp3 Archive]
path = /mnt/mp3
valid users = nobody
guest ok = Yes
writable = no
[admin]
path = /mnt/mp3/uplaod
browseable = no
force user = omikron
read only = no
admin users = omikron
public = no

У меня коннект идет с XP. lanman auth и ntlm auth по дефолту вроде yes... Я просто не доезжаю, что я не так делаю. Пробую поставить N в секции account flags в smbpasswd для омикрон и та же картина...
Выдает ошибку и пишет что возможно у меня нет прав доступа на этот ресурс. Множественное подключение к ресурсам одного пользователя с использованием более одного имени запрещено... Вот так.

Omikron ()
Ответ на: Re: Доступ к samba от Omikron

Re: Доступ к samba

Посмотри права на файлы в шаре. Права на доступ к файлам в шаре должен иметь пользователь, которого ты допускаешь к этой шаре в smb.conf. Т.е. если ты пишешь в smb.conf valid users = nobody, то юзер nobody должен иметь доступ к шаре в файловой системе.

zenith ★★★ ()
Ответ на: Re: Доступ к samba от zenith

Re: Доступ к samba

Права доступа установлены 0777. Так что не в этом дело, тем более что зайти под гостем сюда можно,проблема с авторизацией...

Omikron ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.