LINUX.ORG.RU
ФорумAdmin

Проблема с загрузкой с HostRAID диска после обновления ядра на CentOS 5.8 до 2.6.39.1 версии


0

1

Есть сервер (http://www.supermicro.com/products/motherboard/Xeon1333/5000P/X7DBR-8.cfm) на который не могу поставить CentOS 6.2 вываливается kernel panic и все. На этот сервер ставиться CentOS 5.8 (i386) без каких либо проблем.
На материнке есть HostRAID Adaptec AIC-7902(b) и два диска сконфигурены в зеркало - устройство asr_raid1.
Изначально мне нужно более новое ядро. По инструкции http://www.ul-tech.ru/bsd-linux/linux-systems/sborka-yader-s-kernel-org-v-cen... все проходит хорошо. Но при загрузке нового ядра ошибка

loading dm-snapshot ...
waiting for driver initialization
failed to stat() /dev/mapper/asr_raid1_1
Creating root device
Mounting root filesystem
mount: coild not find filesystem `/dev/root`
...
и.д.
в итоге kernel panic + Call Trace

уйти от HostRAID совсем - установить CentOS на диск (без какого либо конфигурирования HostRAIDа) или что то еще попробовать?

PS
эту версию ядра я попробовал поставить на пробу так сказать, возможно будет более свежая версия ядра.

★★★

дети я над вами ху...ю, на кой х... в таких пакетных дистрибутивах как центос и дебиан собирать ванильное ядро, используйте последнее доступное из реп, оно уже специально под ваш дистрибутив пропатчено или тогда юзайте генту и не занимайтесь херней

anonymous ()
Ответ на: комментарий от anonymous

в каком репозитории искать и какая версия ядра там?

Vlad-76 ★★★ ()

А ядро вы как сконфигурировали? Оно вобще контроллер/диски видит? Поддержку dmraid включили?

mky ★★★★★ ()
Ответ на: комментарий от mky

я скопировал конфиг от ядра 2.6.18-308 которое идет с CentOS 5.8, по всей видимости я думаю поддержка должна быть включена если оно грузится... новое ядро контроллер видит и диски по отдельности видит

Vlad-76 ★★★ ()
Ответ на: комментарий от Vlad-76

Я точно не уверен, но возможно у вас слишком старый dmraid для этой версии ядра. А может ещё что. Я бы рекомендовал взять отдельный диск, попробовать поставить на него какой-либо дистрибутив Линукса с подходящей версией ядра и добится, чтобы там заработал ваш HostRaid (если он вам нужен, конечно). А потом уже перетаскивать это ядро и какие потребуются утилиты.

А может лучше не делать Франкенштейна, а просто перейти на другой дистрибутив. ЛОР, допустим, работает на Федоре и ничего.

mky ★★★★★ ()
Ответ на: комментарий от Vlad-76

RHEL это ынтырпрайз. Если RHEL 5 имеет 2.6.18 ядро, то оно и будет до конца поддержки ветки, если RHEL 6 имеет 2.6.32 - то до выхода RHEL 7 ядро не обновят, туда только бекпортируют новые драйверы. Поставь Ubuntu серверную или Fedora.

xpahos ★★★★★ ()
Ответ на: комментарий от xpahos

вообще с чего все началось. Мне нужен сервер на котором обязательно должен быть ipt_netflow, но и хотелось бы чтобы ядро было попроизводительнее. Может быть и достаточно будет 2.6.18 но почитав nag.ru там вовсю используют ядро 3.1 хотя непонятно вместе с модулем ipt_netflow или нет. Думаю определяющим фактором ветки ядра будет для меня требования для адра модуля ipt_netflow. Жаль CentOS6.2 на сервер не встает.

Vlad-76 ★★★ ()
Ответ на: комментарий от Vlad-76

в документации на модуль ipt_netflow типа пишут что * ipt_NETFLOW.c: compile compatibility with 2.6.37 (ipt_*)

Vlad-76 ★★★ ()
Ответ на: комментарий от xpahos

и да, выкинь адаптек - это унылейшие контроллеры.

ставь promise! )))

zgen ★★★★★ ()
Ответ на: комментарий от Vlad-76

В 6.2 почему-то очень сильно поломали драйверы. Обновлял некоторые некритичные серверы - были проблемы с драйверами sata контроллеров и сетевых карт. Я бы попробовал ставить 6.0 или 6.1.

fjoe ()

Натыкался на похожее, тоже с Adaptec'ом, не помню каким, с такой же фигнёй - система ставится, но не грузится. Выяснил, что имеющийся в центоси драйвер умеет работать с этим контроллером, но его PCI ID в список поддерживаемых ещё не воткнули. Пришлось расковырять initram и воткнуть там что-то типа «echo бла-бла-бла > /sys/module/бла-бла-бла», тогда всё поднялось. Понятно, что апдейтные ядра придётся проверять и, если надо, делать так же.

berrywizard ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.