LINUX.ORG.RU
решено ФорумAdmin

Debian - Samba. Кодировка (знаки ??) на Windows \ Ubuntu linux


0

1

Всем доброго времени суток. Довольно странная проблема, не обнаружилась пока не подключил самбу шару к ubuntu. И так, схема:

  • 1 комп с Debian 6.0.2 на борту (здесь настроен самба-сервер)
  • 2 комп с Windows на борту (подключена самба шара)
  • 3 комп с Ubuntu 10.04.3 на борту (подключена самба шара)

Конфиг самбы на 1 компьютере с Debian:

; Глобальные настройки сервера
[global]
; General server settings
; Имя компа, как будет видно в сетевом окружении
netbios name = gudronserv
server string =
; Рабочая группа клиентов
workgroup = WORKGROUP
announce version = 5.0
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
security = user
null passwords = true
; Файл для альясов имен юзеров
username map = /etc/samba/smbusers
name resolve order = hosts wins bcast
wins support = yes

dos charset = UTF8
unix charset = UTF8
display charset = UTF8

character set = UTF8
client code page = 866

; Поддержка принтеров
printing = CUPS
printcap name = CUPS
; Логи
log file = /var/log/samba/log.%m
syslog = 0
syslog only = no
; Настройка привязки к интерфейсам, на каких слушать, если не указано слушает на все интерфейсах
; interfaces = lo, eth0
; bind interfaces only = true
;

[data]
path = /home/data/
browseable = yes
read only = no
guest ok = yes
create mask = 0777
directory mask = 0777

И так к проблеме, суть в том чо заходя на шару из под Windows имена файлов\папок содержащих русские символы отображаются нормально. Если же заходить на шару из под Ubuntu то заместо русских символов видим лишь символы - ???.

Если из под ubuntu создавать на шаре файлы\папки с кириллицей, то в ubuntu эти файлы\папки отображаются нормально, но появляется проблема в Windows, где кирилица заменяется на непонятные символы квадратиков и прочего... монтирую в fstab шару как:

//192.168.0.101/data /mnt/data cifs username=gudron,password=****** 0 0

гуглил достаточно долго, куча всего перепробовал, и результат тотже, знающие люди подскажите где проблема. Раньше десятки раз настраивал самбу, такого не появлялось.

Заранее спасибо.

Сори за беспокойство, сам разобрался.

Сори за беспокойство, сам разобрался. Забыл установить пакет smbfs.

и примонтировал самба-шару

//192.168.0.101/data /mnt/data cifs username=gudron,password=*****,iocharset=utf8,codepage=cp866,noperm,rwo 0 0

gudron ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.