LINUX.ORG.RU
ФорумAdmin

Catalyst 2960 не пропуcкает VLAN


0

1

Есть Cisco Catalyst 2960 (#1) и 2960g (#2), подключенные по гигабитному порту.

За первой Cisco есть оборудование в VLAN 123. Команда

#sh mac address-table vlan 123

выводит несколько mac-ов c разных портов (кроме того что смотрит на #2).

Порт, который смотрит на #2 выглядит так:

#sh run int Gi0/2
Building configuration...

Current configuration : 157 bytes
!
interface GigabitEthernet0/2
 description trunk to n2_c2960g
 switchport mode trunk
 switchport nonegotiate
 media-type sfp
 flowcontrol receive on
end

За 2-ой Cisco также полно оборудования в том VLAN, но команда

#sh mac address-table vlan 123 | inc Gi0/22 

(Gi0/22 - порт, который смотрит на #1). выводит только один мак:

123    001c.b1ca.c19a    DYNAMIC     Gi0/22

этого мака нет в списке из вывода 1-го.

Порт который смотрит на #1 выгдяит так:

#sh run int Gi0/22
Building configuration...

Current configuration : 493 bytes
!
interface GigabitEthernet0/22
 description Trunk to n1_c2960
 switchport trunk allowed vlan 100,101,102....123....
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 spanning-tree bpdufilter enable
 spanning-tree bpduguard enable
end

Помимо 123 между коммутаторами ходит еще куча VLAN-ов, но с ними вроде проблем нет.

Куда смотреть?

★★★★★

Ответ на: комментарий от hizel

>и switchport trunk allowed vlan 123 тоже надо

насколько я знаю, конструкция

switchport mode trunk

пропускает все vlan-ы, это подтверждается тем, что остальные vlan-ы между этими коммутаторами работают


Turbid ★★★★★
() автор топика
Ответ на: комментарий от Turbid

У обоих этих коммутаторов

VTP Operating Mode : Client

Turbid ★★★★★
() автор топика
Ответ на: комментарий от hizel

на 1-ом:

#sh int gi0/2 switchport
Name: Gi0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

на 2-ом:

#sh int gi0/22 switchport
Name: Gi0/22
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 100,101,102....123....
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
Turbid ★★★★★
() автор топика
Ответ на: комментарий от hizel
 #sh spanning-tree vlan 123 

 VLAN0452
 Spanning tree enabled protocol rstp
 Root ID Priority 25028
 Address 001c.b1ca.c180
 This bridge is the root
 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

 Bridge ID Priority 25028 (priority 24576 sys-id-ext 452)
 Address 001c.b1ca.c180
 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
 Aging Time 300

 Interface Role Sts Cost Prio.Nbr Type
 ------------------- ---- --- --------- -------- --------------------------------
 Fa0/7 Desg FWD 19 128.7 P2p 
 Fa0/14 Desg FWD 19 128.14 P2p 
 Gi0/2 Desg BKN*4 128.26 P2p Peer(STP) *PVID_Inc 
 
Turbid ★★★★★
() автор топика
Ответ на: комментарий от hizel

Точно, заблокирован.

#sh spanning-tree blockedports

Name                 Blocked Interfaces List
-------------------- ------------------------------------
VLAN0123             Gi0/2

Number of blocked ports (segments) in the system : 1

А как теперь снять блокировку?

Turbid ★★★★★
() автор топика
Ответ на: комментарий от Turbid

я не особый спец по spanning tree, но
[code]
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
[/code]
меня смусчают, обычно такие штуки внедряют в специальных случаях

hizel ★★★★★
()

> spanning-tree bpdufilter enable

spanning-tree bpduguard enable

Добавь вот это на том порту, где не видишь маков. Вообще что нужно это включать — это плохо. Где-то что-то не правильно, и такие неправильности чреваты кольцами.

redixin ★★★★
()
Ответ на: комментарий от hizel

> меня смусчают, обычно такие штуки внедряют в специальных случаях

Похоже что это и есть специальный случай)

redixin ★★★★
()
Ответ на: комментарий от hizel

я это включал с на 2-ой cisco по другому совету уже в процессе эксперементирования.

похоже что была петля в этом vlan'е.

В любом случае спасибо что помогли найти затык. Пойду почитаю доки и буду дальше разбираться

Turbid ★★★★★
() автор топика
Ответ на: комментарий от redixin


spanning-tree bpdufilter enable


spanning-tree bpduguard enable


ну вот по подобному собвету я их и включил с той стороны, но не помогло (порту shutdown делал).

Turbid ★★★★★
() автор топика
Ответ на: комментарий от Turbid

на сайте cisco есть отличные мануалы по железкам так и по конкретным технологиям с примерами, и да, у вас похоже pvst-rstp, лучше сразу использовать mstp, 2960 поддерживает по моему ~16 stp instance, тоесть pvst прожует ~16 vlan-ов :-(

hizel ★★★★★
()
Ответ на: комментарий от hizel

>в первый раз такое слышу, хотя, может вы vtp какое используете?

таки switchport mode trunk пропускает все вланы по дефолту

ventilator ★★★
()
Ответ на: комментарий от ventilator

да я уж разобрался. два наших клиента устроили петлю в транзитных vlan-ах.

Turbid ★★★★★
() автор топика
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.