LINUX.ORG.RU
ФорумAdmin

Не запускается lacp под Ubuntu

 , ,


0

2

Доброго времени! В наличии имеем сервер на Ubuntu 14.10 (предыдущие не вкорячиваются - raid туговатый) с i350-T4 и встроенной сетевой на e1000e. Имеем также Cisco 3650 и D-Link DGS-3627G. Задача: по LACP два порта i350 из сервера подключить в Cisco и два порта i350 из сервера подключить к D-Link. D-Link заработал сразу без проблем. Cisco настроена в активе lacp. ругается так:

Feb 18 05:51:17: %EC-5-L3DONTBNDL2: Gi0/4 suspended: LACP currently not enabled on the remote port.
Feb 18 05:51:18: %EC-5-L3DONTBNDL2: Gi0/3 suspended: LACP currently not enabled on the remote port.

Сервер же в свою очередь выдаёт такие перлы:

#cat /proc/net/bonding/bond6
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: layer2 (0)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

802.3ad info
LACP rate: fast
Min links: 0
Aggregator selection policy (ad_select): stable
Active Aggregator Info:
	Aggregator ID: 1
	Number of ports: 1
	Actor Key: 17
	Partner Key: 1
	Partner Mac Address: 00:00:00:00:00:00

Slave Interface: eth7
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: a0:36:9f:44:55:36
Aggregator ID: 1
Slave queue ID: 0

Slave Interface: eth6
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: a0:36:9f:44:55:37
Aggregator ID: 2
Slave queue ID: 0

При втыкании Cisco во встроенные сетевые e1000 с настроенным LACP всё радостно загорается и работает (Aggregator ID становится одинаковым на оба порта, получает Partner Mac Address как положено). С igb же не работает даже по одному порту. Ядро 3.16.0-29-generic, igb пробовал обновить до 5.2.15 - бесполезно. Cisco:

interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2000
 switchport trunk allowed vlan 2000
 switchport mode trunk
Ubuntu:
auto eth6
    iface eth6 inet manual
    bond-master bond6

auto eth7
    iface eth7 inet manual
    bond-master bond6

auto bond6
    iface bond6 inet static
    address 217.150.54.85
    netmask 255.255.255.252
    gateway 217.150.54.86
    bond-mode 802.3ad
    bond-miimon 100
    bond-lacp-rate 1
    bond-slaves eth6 eth7

Буду рад услышать любые идеи :-)

Ответ на: комментарий от Demacr

уже есть. рабочий LACP с Dlink имеет кучу рабочих vlan, ну и как говорил - делаю bond на циску с двумя встроенными сетевушками e1000 - все пашет, переписываю на две с igb - нет. Тут какая-то загвоздка в igb и lacp кажется, но вот в упор не вижу где...

KarpONE ()
Ответ на: комментарий от KarpONE

Поснифай ваяшарком. Может заметишь чего интересного.

Demacr ()

balance-xor работает, как не удивительно, но только ведь больше гигабита я не получу в связке

маршрутизатор LACP     <->     LACP- cisco -src-dst-mac     <->     balance-xor -маршрутизатор
ведь MAC будет всё время один dst и src насколько я понимаю, или я не то курил)?

KarpONE ()
Ответ на: комментарий от stels
interface GigabitEthernet0/3
 switchport access vlan 2000
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2000
 switchport trunk allowed vlan 2000
 switchport mode trunk
 channel-group 2 mode active
end

это естественно было с LACP так.

KarpONE ()
Последнее исправление: KarpONE (всего исправлений: 1)
Ответ на: комментарий от KarpONE

У меня какие то лаги были с лацпом меж циской и длинком 3120 и помню что решались изменением с channel-group 2 mode active на passive или наоборот, за давностью уже не помню.

stels ★★★ ()

Сейчас есть рабочий лацп меж линуксом и dgs 3610 которая вся из себя цисколайк. У меня в настройках ифейса указано

bond-mode 4

stels ★★★ ()
Ответ на: комментарий от stels

bond-mode 4 - просто другое написание 802.3ad) смены active-passive не спасли. Пока решил методом статической аггрегации

mode on
port-channel load-balance src-dst-ip

и на bond интерфейсе ubuntu balance-xor'ом

bond-mode 2
bond-xmit-hash-policy layer2+3

вроде как работает, и балансирует.

KarpONE ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.