LINUX.ORG.RU
решено ФорумAdmin

apache2 + virtual hosts


0

1

Доброго времени суток, лор. У меня вот такая проблема: Стоит Debian lenny и apache2. Привязал к айпишнику 10.10.0.1 домен example.com, создаю в sites-enabled файл example.com

<VirtualHost *:80>

ServerAdmin admin@example.com

ServerName www.example.com

ServerAlias example.com

DocumentRoot /var/www/exam/

</VirtualHost>

Но когда пытаюсь браузером зайти на example.com меня автоматически редиректит на http://10.10.01/exam.

Содержимое отображается нужное, но почему он в строке адреса заменяет домен айпишником?

Создавать нужно в sites-available и включать-отключать через a2[en|dis]site.

NameVirtualHost *:80 попробуй перед вирт.хостом дописать.

madgnu ★★★★★ ()
Ответ на: комментарий от madgnu

про создание - все так и делаю, просто решил опустить лишние детали.

NameVirtualHost *:80 - добавил, но изменений это не дало.

Кстати, проделывал все руководствуясь вот этой инструкцией: http://www.debian-administration.org/articles/412

strange_walker ()
Ответ на: комментарий от strange_walker

Инструкция вполне нормальная.

А домен реально существующий (т.е., он резолвится через DNS, а не запись в /etc/hosts)?

madgnu ★★★★★ ()
Ответ на: комментарий от madgnu

Да, домен вполне существующий. Зайти я пытаюсь из дому, так что в его работоспособности сомневаться причин нет.

strange_walker ()
Ответ на: комментарий от madgnu

Вообще у меня складывается впечатление, что оно обрабатывается не по созданному мной файлу example.com, а по стандартному 000-default. Но, при этом, редиректит же оно в каталог, указанный корневым именно в файле example.com.

Кстати, если удалить файл example.com, то при обращению к домену оно выдает дефолтную страницу, при этом не заменяя адрес. В строке браузера так и остается example.com.

strange_walker ()
Ответ на: комментарий от strange_walker

Может в /var/www/exam/ лежит какой нибудь .htaccess c rewrite правилами? Если apache2 все же разруливает в правильный документ рут, то искать нужно именно там. На всякий случай удали из sites-enabled/ все кроме example.com - сделай /etc/init.d/apache2 reload

BigAlex ★★★ ()
Ответ на: комментарий от BigAlex

Вы гений! Действительно, привязал к домену другую папку exam2, в которой .htaccess нет вообще - все заработало как часы. С утра первым делом руки нашим прогерам повыдергаю и вставлю в нужное место.

Благодарю еще раз! :)

strange_walker ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.