LINUX.ORG.RU
ФорумAdmin

proftp1.3.3 не видит locale


0

0

Поставил из тестового репозитория debian lenny, получилось следующие:

Compile-time Settings:

Version: 1.3.3a (maint)

Platform: LINUX [Linux 2.6.26-2-686 i686]

Built: Mon Jul 5 2010 08:48:09 UTC

Built With:

configure '--prefix=/usr' '--with-includes=/usr/include/postgresql:/usr/include/mysql' '--mandir=/usr/share/man' '--sysconfdir=/etc/proftpd' '--localstatedir=/var/run' '--libexecdir=/usr/lib/proftpd' '--enable-sendfile' '--enable-facl' '--enable-dso' '--enable-autoshadow' '--enable-ctrls' '--with-modules=mod_readme' '--enable-ipv6' '--enable-nls' '--build' 'i486-linux-gnu' '--with-shared=mod_unique_id:mod_site_misc:mod_load:mod_ban:mod_quotatab:mod_sql:mod_sql_mysql:mod_sql_postgres:mod_sql_sqlite:mod_sql_odbc:mod_dynmasq:mod_quotatab_sql:mod_ldap:mod_quotatab_ldap:mod_ratio:mod_tls:mod_rewrite:mod_radius:mod_wrap:mod_wrap2:mod_wrap2_file:mod_wrap2_sql:mod_quotatab_file:mod_quotatab_radius:mod_facl:mod_ctrls_admin:mod_vroot:mod_exec:mod_sftp:mod_sftp_pam:mod_sftp_sql:mod_shaper:mod_sql_passwd:mod_ifsession' 'build_alias=i486-linux-gnu' 'CFLAGS=-O2 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_OPENSSL -DUSE_LDAP_TLS ' 'LDFLAGS=' 'CPPFLAGS='

CFLAGS: -O2 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_OPENSSL -DUSE_LDAP_TLS -Wall LDFLAGS: -L$(top_srcdir)/lib LIBS: -lacl -lssl -lcrypto -lcap -lpam -lsupp -lcrypt -ldl -ldl -lz

Files: Configuration File: /etc/proftpd/proftpd.conf

Pid File: /var/run/proftpd.pid

Scoreboard File: /var/run/proftpd.scoreboard

Header Directory: /usr/include/proftpd

Shared Module Directory: /usr/lib/proftpd

Features:

+ Autoshadow support

+ Controls support

+ curses support

- Developer support

+ DSO support

+ IPv6 support

+ Largefile support

- Lastlog support

+ ncurses support

+ NLS support

+ OpenSSL support

+ POSIX ACL support

+ Shadow file support

+ Sendfile support

+ Trace support

Вот конфиг(не полный):

# Includes DSO modules Include /etc/proftpd/modules.conf

# Set off to disable IPv6 support which is annoying on IPv4 only boxes.

UseIPv6 off

# If set on you can experience a longer connection delay in many cases.

IdentLookups off

ServerName «Ftp Server»

ServerType standalone

DeferWelcome off

MultilineRFC2228 on

DefaultServer on

ShowSymlinks on

TimeoutNoTransfer 600

TimeoutStalled 600

TimeoutIdle 1200

DisplayLogin welcome.msg

DisplayChdir .message true

ListOptions "-l"

DenyFilter \*.*/

UseEncoding on

UseEncoding UTF-8 cp1251

LangDefault ru_RU

LangPath /usr/share/locale

Получается следущая картина при запуске:

router - mod_lang/0.9: skipping possible language 'it': not supported by setlocale(3); see `locale -a'

router - mod_lang/0.9: skipping possible language 'ru': not supported by setlocale(3); see `locale -a'

router - mod_lang/0.9: skipping possible language 'ja_JP': not supported by setlocale(3); see `locale -a'

router - mod_lang/0.9: skipping possible language 'en_US': not supported by setlocale(3); see `locale -a'

router - mod_lang/0.9: skipping possible language 'fr_FR': not supported by setlocale(3); see `locale -a'

router - mod_lang/0.9: skipping possible language 'zh_TW': not supported by setlocale(3); see `locale -a'

router - mod_lang/0.9: skipping possible language 'bg_BG': not supported by setlocale(3); see `locale -a'

router - mod_lang/0.9: skipping possible language 'ko_KR': not supported by setlocale(3); see `locale -a'

router - mod_lang/0.9: skipping possible language 'zh_CN': not supported by setlocale(3); see `locale -a'

router - mod_lang/0.9: LangDefault 'ru_RU', configured for server 'Ftp Server', is not a supported language, removing

router - ProFTPD 1.3.3a (maint) (built Mon Jul 5 2010 08:48:09 UTC) standalone mode STARTUP

Типа не поддерживается рус язык.

router:/etc/proftpd# locale -a

C

POSIX

ru_RU.cp1251

ru_RU.utf8

В результате у клиента получается следующие у клиента:

tartdir= 220 ProFTPD 1.3.3a Server ( Ftp Server) [192.168.0.*]

USER ftp1

331 оЕПВИПДЙН РБТПМШ ДМС РПМШЪПЧБФЕМС ftp1

PASS ***********

230 рПМШЪПЧБФЕМШ ftp1 РПДЛМАЮЈО

SYST

215 UNIX Type: L8

FEAT

211-Features:

MDTM

MFMT

TVFS

UTF8

MFF modify;UNIX.group;UNIX.mode;

MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;

SITE MKDIR

SITE RMDIR

SITE UTIME

LANG en-US.UTF-8;en-US

SITE SYMLINK

REST STREAM

SIZE

211 лПОЕГ

Connect ok!

Куда капнуть, почему не видит ru locale?

Ответ на: комментарий от Superuser9

Это не то решение, что мне нужно. Я это все прошел.

Выставил в конфиги перекодирование на лету Encoding On

Тут именно проблема в том, что proftpd не видит локаль

router - mod_lang/0.9: LangDefault 'ru_RU', configured for server 'Ftp Server', is not a supported language, removing

CheGev80 ()
Ответ на: комментарий от CheGev80

Меня смущает вот что:

Поставил из тестового репозитория debian lenny

Это каг?
Могу посоветовать вот что: поставь из репок стабильного Lenny именно версию 1.3.1. Модули для него есть.
Если нужно именно вручную собрать, то присоедини source репку, скачай сорцы proftpd и собери как тебе нужно.

Superuser9 ()
Ответ на: комментарий от Superuser9

Поставил вот так:

aptitude install - t testing proftpd

1.3.1 версию ставил, но она не подерживает кодировку на лету, а патч который добавляет эту функцию, с ним не работает через експлодер:

http://www.linux.org.ru/forum/admin/5141610

Ставил 1.3.3 из сырцов, вроде все нормально настроил, все работало, но не запускался с инит скрипта дебиан(родного от 1.3.1):

http://linuxforum.ru/viewtopic.php?id=5469

Вот я и решил с тестового поставить, думал, что проблем не будет, а оказалось, что еще хуже.

CheGev80 ()
Ответ на: комментарий от CheGev80

Если есть возможность запретить юзерам юзать эксплорер я бы так и сделал. ИМХО конечно, но у меня складывается ощущение, что в системе остались файлы от предыдущей версии proftpd. Попробуй их ручками вычистить. Еще мысль: попробуй собрать 1.3.3 в виртуалке с твоим конфигом. Если проблем не будет, значит точно систему засорил.

Superuser9 ()
Ответ на: комментарий от Superuser9

Ну тут в чем все и дело, что я уже на чистую систему ставил из тестового репа proftpd. Так что остаться ничего не должно. А от эксплодера у меня никак не отвяжешься.

CheGev80 ()
Ответ на: комментарий от CheGev80

Со стороны клиента фтп все нормально, до поры, когда перезапустишь службу proftpd, служебные сообщения от сервера клиету

выводятся ввиде иероглифов. Помогает только полная перегрузка сервера.
Попробуй значит в скрипт запуска дописать параметр запуска --config /путь_к_конфигу.

Superuser9 ()
Ответ на: комментарий от Superuser9

Нет, не помогает. Там он кстати уже прописан в OPTIONS. Ладно щас попробую еще раз из сырцов собрать. Еще есть мысль, что когда я прописал тест репозиторий, я сделал update системы, может какой файл обновился, который не нужно было обновлять. Вот щас поставлю из сырцов и ясно станет.

CheGev80 ()
Ответ на: комментарий от CheGev80

Переставил со сырцов, все нормально заработало. Все дело в тестовом пакете из репо. Не пойму чего разработчики дебиана, так резину тянут. Ну ведь 1.3.1 это уже прошлый век. Давно бы протестили.

CheGev80 ()
Ответ на: комментарий от Superuser9

Ну все равно, если в конфиге устанавливаешь DefaultLang ru_RU

он при старте ругается:

router.gulliverco.ru - mod_lang/0.9: LangDefault 'ru_RU.utf8', configured for server 'Ftp Server', is not a supported language, removing ProFTPD Version: 1.3.3a (maint)

Но запускается и нормально работает)

CheGev80 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.