LINUX.ORG.RU
ФорумAdmin

DBD:mysql ошибка при установке


0

0

здраствуйте помогите разобраться ос FreeBSD 8.0 установил apache и mysql55 начал ставить DBD::mysql для перла через cpan выдаёт ошибку:

Test Summary Report ------------------- t/40catalog.t (Wstat: 2304 Tests: 4 Failed: 0) Non-zero exit status: 9 Parse errors: Bad plan. You planned 77 tests but ran 4. Files=39, Tests=754, 17 wallclock secs ( 1.20 usr 0.40 sys + 10.98 cusr 2.23 csys = 14.80 CPU) Result: FAIL Failed 1/39 test programs. 0/754 subtests failed. *** Error code 255

Stop in /root/.cpan/build/DBD-mysql-4.015-BVP9kH. CAPTTOFU/DBD-mysql-4.015.tar.gz /usr/bin/make test — NOT OK //hint// to see the cpan-testers results for installing this module, try: reports CAPTTOFU/DBD-mysql-4.015.tar.gz Warning (usually harmless): 'YAML' not installed, will not store persistent state Running make install make test had returned bad status, won't install without force Failed during this command: CAPTTOFU/DBD-mysql-4.015.tar.gz : make_test NO

что это такое и что с этим делать? или может установить этот модуль другими способами? он в портах есть?

★★★★★

Ответ на: комментарий от zgen

о спс большое установил. а я когда в портах искал думал чё такое p5, оказывается это perl5 )

а с ошибкой которую выдавал cpan я так думаю DBD-mysql-4.015.tar.gz это для mysql4 а для mysql55 в cpan нет модуля?

TDrive ★★★★★ ()
Ответ на: комментарий от hizel

mysql использую для сайта написанного на perle ставил mysql55 так как думал что ставить лучше последнюю версию или я ошибаюсь? есть поводы не использовать 55?

TDrive ★★★★★ ()
Ответ на: комментарий от TDrive

что ставить лучше последнюю версию или я ошибаюсь?

Ставить лучше то, с чем меньше проблем.

есть поводы не использовать 55?

А вашего - недостаточно? А есть у вас поводы использовать именно 5.5? Вы например в курсе, чем 5.5 от 5.0 или от 4.x отличается? Вы используете те возможности, которые реализованы в 5.5?

zgen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.