LINUX.ORG.RU
ФорумAdmin

не стартуют X-ы


0

0

здрасте..., все перепробовал....Х - не стартует и все...., пробовал stratx, gdm, дрова настраивал по разному в Xorg.conf пробовал ставить и ati и fglrx и radeon (видюха Radeon 9600 PRO 128мб, gentoo, ядро 2.6.31)

вот логи gdm: disable primary dac

init memmap

init common

init crtc1

init pll1

freq: 157500000

best_freq: 157500000

best_feedback_div: 35

best_ref_div: 3

best_post_div: 2

restore memmap

restore common

restore crtc1

restore pll1

finished PLL1

set RMX

set primary dac

enable primary dac

disable TV

expected keysym, got XF86TouchpadToggle: line 122 of inet

disable primary dac

finished PLL2

finished PLL1

Entering Restore TV

Restore TV PLL

Restore TVHV

Restore TV Restarts

Restore Timing Tables

Restore TV standard

Leaving Restore TV

вот xorg.conf:

Section «ServerLayout»

   Identifier «X.org Configured»

   Screen 0 «Screen0» 0 0

   InputDevice «Mouse0» «CorePointer»

   InputDevice «Keyboard0» «CoreKeyboard»

EndSection

Section «Files»

   ModulePath «/usr/lib/xorg/modules»

   FontPath «/usr/share/fonts/misc/»

   FontPath «/usr/share/fonts/TTF/»

   FontPath «/usr/share/fonts/OTF»

   FontPath «/usr/share/fonts/Type1/»

   FontPath «/usr/share/fonts/100dpi/»

   FontPath «/usr/share/fonts/75dpi/»

EndSection

Section «Module»

   Load «glx»

   Load «extmod»

   Load «record»

   Load «dri2»

   Load «dbe»

   Load «dri»

EndSection

Section «InputDevice»

   Identifier «Keyboard0»

   Driver «kbd»

Option «XkbRules» «xorg»

   Option «XkbModel» «microsoft»

Option «XkbLayout» «us,ru»

   Option «XkbOption» «grp:rctrl_toggle,grp_led:num»

EndSection

Section «InputDevice»

   Identifier «Mouse0»

   Driver «mouse»    Option    «Protocol» «auto»

   Option    «Device» «/dev/input/mice»

   Option    «ZAxisMapping» «4 5 6 7»

EndSection

Section «Monitor»

   #DisplaySize    380 270   # mm

   Identifier «Monitor0»

   VendorName «SAM»

   ModelName «SyncMaster»

   HorizSync 30.0 - 96.0

   VertRefresh 50.0 - 160.0

   Option    «DPMS»

EndSection

Section «Device»

Option «mtrr» «false»

   Option    «backingstore» «true»

   Identifier «Card0»

   Driver «radeon»

   VendorName «ATI Technologies Inc»

   BoardName «RV350 AP [Radeon 9600]»

   BusID «PCI:2:0:0»

EndSection

Section «Screen»

   Identifier «Screen0»

   Device «Card0»

   Monitor «Monitor0»

   SubSection «Display»

      Viewport 0 0

      Depth 24

      Modes «1280x1024»

   EndSubSection

EndSection


Re: не стартуют X-ы

А теперь осиль форматирование и попробуй ещё раз.

GotF ★★★★★ ()

форматирование поправь. а вывод лучше в pastebin.com скидывать к примеру а то &nbsp глаза вырывают У тя походу проблемы с разверткой монитора . попробуй пониже поставить попробуй vesa также

pinachet ★★★★★ ()

А ещё очень полезно что-то типа /var/log/Xorg.0.log посмотреть. Там обычно всё написано.

Ximen ★★★★ ()
Ответ на: комментарий от Bod

grep EE /var/log/Xorg.0.log

(ww) warning, (EE) error, (NI) not implemented, (??) unknown. (II) Loading extension MIT-SCREEN-SAVER

XeNoN ()
Ответ на: комментарий от XeNoN

А если тупо попытаться пересоздать xorg.conf?

# X -configure

Bod ★★★★ ()

ATI Radeon 9600 + Samsung SyncMaster 710N, xorg.conf:

Section "Extensions"
    Option "Composite"
EndSection

Section "ServerFlags"
    #DontZap # disable <Ctrl><Alt><BS> (server abort)
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    Load "dri" # direct rendering
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us,ru(winkeys)"
    Option "XkbOptions" "compose:rwin,grp:ctrl_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
EndSection

Section "InputDevice"
    Identifier "Mouse2"
    Driver "evdev"
    Option "bustype" "0x0011"
    Option "product" "0x0006"
    Option "relBits" "+0+1+2"
    Option "HWheelRelativeAxisButtons" "7 6"
    Option "vendor" "0x0002"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "SyncMaster"
    HorizSync 30-81
    VertRefresh 56-75

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630

    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "ATI Technologies Inc"
    BoardName "ATI Radeon 9500 - X850"
    Driver "ati"
    Option "DPMS"
    Option "XaaNoOffscreenPixmaps" "1"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
        Depth 8
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection

    Subsection "Display"
        Depth 15
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection

    Subsection "Display"
        Depth 16
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection

    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Mouse2" "SendCoreEvents"
    Screen "screen1"
EndSection

nnz ★★★★ ()

При создании нового конфига, на экране появились артефакты(прямоугольники цветные).... и повисло))

XeNoN ()
Ответ на: комментарий от XeNoN

Значит имхо дело не в конфигах, а что-то просто криво собралось. Или иксы, или драйвера. Скорее иксы.

Bod ★★★★ ()
Ответ на: комментарий от Bod

Попробовал Ваш конфиг - не прокатывает... дрова и иксы пересобирал по неск раз...Что делать ума не приложу

XeNoN ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.