LINUX.ORG.RU
ФорумAdmin

Опять проблемы! Сеть!


0

0

Здравствуйте! Никак не могу заставить работать сеть из двух, подключенных на прямую через "витую пару" компьютеров. Даже ping не проходит. Система Slackware. В ядро я включил поддержку своей сетевой платы. Через ifconfig -a видит. Интерфейс поднял. Маршрутизацию прописал, а работать не хочет. Может кто-нибудь напомнит Шаги по настройке сети?

Re: Опять проблемы! Сеть!

Может надо было _напрямую_ подключать через кросс, не?

UserUnknown ★★★★★ ()

Re: Опять проблемы! Сеть!

Кроссовер вродь для современных карт не обязателен. Но если железо старое, то лучше кросс.

vensder ()
Ответ на: Re: Опять проблемы! Сеть! от sin_a

А может не служить.

>Признаком рабочего (правильно обжатого, для данной пары адаптеров) кабеля может служить светодиод около разъёма.

Моя первая сетевуха (PCI, 10Mbit, RTL8029) не имела никакой светодиодной индикации :-] Но это уже предмет археологии.

Camel ★★★★★ ()
Ответ на: Re: Опять проблемы! Сеть! от nnz

Re: Опять проблемы! Сеть!

Кабель обжат кроссовером и работает корректно. На обеих машинах, помимо линукса, стоят "окна". Дело именно в настройке системы. Что-то я делаю не так. -подняли интерфейс с помощью ifconfig -отредактировали файл /etc/rc.d/rc.inet1.conf -добавили в route Все, вроде, как положено, но даже пинговать не хочет.

TheTurtle ()
Ответ на: Re: Опять проблемы! Сеть! от TheTurtle

Re: Опять проблемы! Сеть!

Бывали случаи, когда виндос при выключении переводил сетевую карту в какой-то "спящий режим". Для оживления такой карты в линуксе приходилось снимать питание с компьютера. Правда не помню, был-ли виден интерфейс по ifconfig.

sin_a ★★★★★ ()

Re: Опять проблемы! Сеть!

ifconfig -a с обоих компов в студию

z0D5e8n7x_2 ()
Ответ на: Re: Опять проблемы! Сеть! от chocholl

Re: Опять проблемы! Сеть!

ifconfig -a будет вечером. Забыл совсем написать, что себя он пингует, а соседний компьютер нет.

TheTurtle ()
Ответ на: Re: Опять проблемы! Сеть! от TheTurtle

Re: Опять проблемы! Сеть!

Если вы
> подняли интерфейс с помощью ifconfig ( видимо ifconfig eth0 up) -отредактировали файл /etc/rc.d/rc.inet1.conf -добавили в route

(то есть поредактировали какой то там текстовый файл) то чего бы пингам то ходить?
А если было все не так, то какого _водного указателя_ вы не выложили в точности все свои действия и конфиги на рассмотрение? Вендовозные привычки слака еще не отшибла?

kilolife ★★★★★ ()
Ответ на: Re: Опять проблемы! Сеть! от kilolife

Re: Опять проблемы! Сеть!

eth0 Link encap:Ethernet HWaddr 00:13:8F:64:12:D0 BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 b) TX bytes:0 (0.0 b) Interrupt:17 Base address:0x6c00

lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:2 errors:0 dropped:0 overruns:0 frame:0 TX packets:2 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

--------------------------------------------

ifconfig eth0 192.168.0.2 broadcast 192.168.0.255 netmask 255.255.255.0 up

--------------------------------------------

# /etc/rc.d/rc.inet1.conf # # This file contains the configuration settings for network interfaces. # If USE_DHCP[interface] is set to "yes", this overrides any other settings. # If you don't have an interface, leave the settings null ("").

# Config information for eth0: IPADDR[0]="192.168.0.2" NETMASK[0]="255.255.255.0" USE_DHCP[0]="" DHCP_HOSTNAME[0]=""

# Config information for eth1: IPADDR[1]="" NETMASK[1]="" USE_DHCP[1]="" DHCP_HOSTNAME[1]=""

# Config information for eth2: IPADDR[2]="" NETMASK[2]="" USE_DHCP[2]="" DHCP_HOSTNAME[2]=""

# Config information for eth3: IPADDR[3]="" NETMASK[3]="" USE_DHCP[3]="" DHCP_HOSTNAME[3]=""

# Default gateway IP address: GATEWAY="192.168.0.254"

# Change this to "yes" for debugging output to stdout. Unfortunately, # /sbin/hotplug seems to disable stdout so you'll only see debugging output # when rc.inet1 is called directly. DEBUG_ETH_UP="no"

----------------------------------------------------

route add -net 192.168.0.2 netmask 255.255.255.0 eth0 //На эту команду начинает ругаться, мол маска не та.

---------------------------------------------------

route add -net 192.168.0.2 netmask 255.255.255.255 eth0

---------------------------------------------------

route

---------------------------------------------------

Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface darkstar.darkst * 255.255.255.255 UH 0 0 0 eth0 localnet * 255.255.255.0 U 0 0 0 eth0 loopback * 255.0.0.0 U 0 0 0 lo default 192.168.0.254 0.0.0.0 UG 1 0 0 eth0

TheTurtle ()
Ответ на: Re: Опять проблемы! Сеть! от TheTurtle

Re: Опять проблемы! Сеть!

А на втором компе :) Подозреваю, что они в разных подсетях.

На втором:

ifconfig eth0 192.168.0.3 broadcast 192.168.0.255 netmask 255.255.255.0 up

anton_jugatsu ★★★★ ()
Ответ на: Re: Опять проблемы! Сеть! от TheTurtle

Re: Опять проблемы! Сеть!

> eth0 Link encap:Ethernet HWaddr 00:13:8F:64:12:D0 BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 b) TX bytes:0 (0.0 b) Interrupt:17 Base address:0x6c00

а можно его же, но после выполнения

> ifconfig eth0 192.168.0.2 broadcast 192.168.0.255 netmask 255.255.255.0 up

... кстати и пинги может пойдут...

А route зачем прописывать?.. Может сначала надо в него посмотреть? Может там и без лишних движений, напоминающих ано^W^W всё уже прописано?..

ps. похоже что только ifconfig lo up забыли сделать...

ei-grad ★★★★★ ()

Re: Опять проблемы! Сеть!

> Шаги по настройке сети

На первом компе:

> ifconfig eth0 192.168.0.1

> ping 192.168.0.2

На втором компе:

> ifconfig eth0 192.168.0.2

> ping 192.168.0.1

Хотя хз, если слака то может еще up надо добавить... но врядли

ei-grad ★★★★★ ()
Ответ на: Re: Опять проблемы! Сеть! от TheTurtle

Re: Опять проблемы! Сеть!

> Я хотел спросить. А моя проблема может возникать из-за того, что у меня встроенные сетевые карты Realtek8139?

Попробуй установить Ubuntu.

ei-grad ★★★★★ ()
Ответ на: Re: Опять проблемы! Сеть! от ei-grad

Re: Опять проблемы! Сеть!

> > Я хотел спросить. А моя проблема может возникать из-за того, что у меня встроенные сетевые карты Realtek8139?

Абсолютно исключено! Как раз наоборот.

lspci G Eth

05:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

lsmod G 8139

8139too 31616 0

8139cp 27520 0

mii 13440 2 8139too,8139cp

anton_jugatsu ★★★★ ()
Ответ на: Re: Опять проблемы! Сеть! от anton_jugatsu

Re: Опять проблемы! Сеть!

Значит так, друзья мои, основательно покопался в интернете и таки нашел людей, которые побывали в моей шкуре. Оказывается настройки сетевой карты в Windows влияют после перезагрузки на Linux. В "Диспетчере задач" в свойствах сетевой карты есть пункт "Wake on after reboot" его надо поставить в значение enable и все заработает

TheTurtle ()
Ответ на: Re: Опять проблемы! Сеть! от TheTurtle

Re: Опять проблемы! Сеть!

Вот винда погана! И загрузчик она линуксовый затирает, и карту выключает, лишь бы Линуксу насолить.

vensder ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.