LINUX.ORG.RU
ФорумAdmin

VM: killing process


0

0

народ!

Есть сервак под 2.4.7-10 работает неплохо(ни разу не вис - uptime 112 дней) - но маломощный P3 128RAM

Перенес систему полностью без изменений на другую машину P4 256DDR RAM Все завелось, Но что-то периодически при работе все на этом сервере на 3-10 сек замирает(потом отвисает) - а иногда даже сервер подвисает - на консоле как полагается список регистров.

Я подумал что ядро не под нужный процессор скомпилено и поставил 2.4.18, скомпилив под Пень4.

Это все пока работает - 30Мин пока.

Делаю проверку под нагрузкой - на каждом из этих серверов пускаю сканнер drweb - он сканирует увесистый file.tar.gz

На первом наблюдается следующее - RAM,SWAP,CPU в течении 10 мин оттаются занятыми почти на 100% - очень медленно система на все реагирует - на вход по телнету например - но в конце кондов задача отрабатыватся. - все приходит в норму.

На втором(новом) - все ресурсы тоже остаются занятыми на 100% почти, в течениии минут 5, в это время войти по телнет иногда невозможно - после ввода пароля и продолжительного ожидания консоль схлопывается, если я всеж вхожу со втрой или третьей попытки и зарускаю тор - та пишет : Segmentation fault, то же пишет vi при попытке открыть файл... После чего в логах следующее: Oct 17 17:12:28 mail sshd(pam_unix)[932]: session opened for user root by (uid=0) Oct 17 17:14:55 mail kernel: Out of Memory: Killed process 931 (drweb). Oct 17 17:14:55 mail kernel: VM: killing process drweb

Можно это как-то исправить без замены железа?

anonymous

Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.