LINUX.ORG.RU
ФорумAdmin

Настройка SoftRAID по инструкции. Не монтируется SWAP


0

0

Руководство http://en.opensuse.org/How_to_install_SUSE...n_software_RAID

Делал все один в один (почти). Поэтому конфиги не привожу.

В результате, при загрузке лезут сообщения: Unable to find swap-space signature

gate:~ # cat /proc/mdstat Personalities : [raid1] [raid0] [raid6] [raid5] [raid4] md3 : active(auto-read-only) raid1 sdc1[0] sdd1[1] 244195864 blocks super 1.0 [2/2] [UU] bitmap: 0/466 pages [0KB], 256KB chunk

md0 : active raid1 sda1[0] sdb1[1] 104376 blocks super 1.0 [2/2] [UU] bitmap: 0/7 pages [0KB], 8KB chunk

md2 : active raid1 sda3[0] sdb3[1] 239890476 blocks super 1.0 [2/2] [UU] bitmap: 1/458 pages [4KB], 256KB chunk

md1 : active(auto-read-only) raid1 sda2[0] sdb2[1] 4200984 blocks super 1.0 [2/2] [UU] bitmap: 0/9 pages [0KB], 256KB chunk

unused devices: <none> gate:~ #

Подозреваю, что все беды от того, что статус active(auto-read-only). Почему так вышло? В какую сторону копать?

Re: Настройка SoftRAID по инструкции. Не монтируется SWAP

man swapon ?

anonymous ()

Re: Настройка SoftRAID по инструкции. Не монтируется SWAP

Cудя по всему правильный линк был:

http://en.opensuse.org/How_to_install_SUSE_Linux_on_software_RAID

--- это для желающих нарушить традицию, сходить по ссылке и посмотреть комикс).

Автору топика --- все таки приведи конфиги. А то даже не понятно, какое из md-устройств куда монтируется и где должен быть swap.

mky ★★★★★ ()

Re: Настройка SoftRAID по инструкции. Не монтируется SWAP

Имеется 2 диска sda и sdb

sda1
      md0   (/boot)
sdb1
-----------------------------
sda2
      md1   (swap)
sdb2
-----------------------------
sda3
      md2   (/)
sdb3
-----------------------------
sdc1
      md3   (нет точки монтирования)
sdd1


gate:~ # cat /etc/mdadm.conf
DEVICE partitions
ARRAY /dev/md0 level=raid1 UUID=ca6595fe:9a781daf:16558129:555789e3
ARRAY /dev/md1 level=raid1 UUID=fa5c4c72:2a0c7242:a3ccd30e:73f134b8
ARRAY /dev/md2 level=raid1 UUID=61468a77:8b0bb39d:e9363418:71d323fc
ARRAY /dev/md3 level=raid1 UUID=dd597675:eacc31a9:a325ef99:4043ba6d
gate:~ # 

gate:~ # swapon -a
swapon: /dev/md1: Недопустимый аргумент

gate:~ # cat /etc/fstab
/dev/md2             /                    reiserfs   acl,user_xattr        1 1
/dev/md0             /boot                reiserfs   acl,user_xattr        1 2
/dev/md1             swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
gate:~ # 

babahvl ()

Re: Настройка SoftRAID по инструкции. Не монтируется SWAP

А то! Делал.
Тут дело вот еще какое
Дано:
http://en.opensuse.org/How_to_install_SUSE...n_software_RAID - инструкция (прошу заметить с оффсайта) по настройке softRAID
2 диска - sda и sdb
Разметку хотим такую - 
sda1 - swap (512Mb), sda2 - / (2Gb)
sdb1 - swap (512Mb), sdb2 - / (2Gb)

Из этих разделов хотим сделать softraid level=1 (зеркало)
md0 - swap (512Mb)
md1 - / (2Gb)

Собственно в инсталяторе происходит вся разметка (по инструкции!)
Далее установка в обычном режиме. Набор приложений минимальный.

Имеем после установки:
В процессе загрузки лезет сообщение:
Anmount to enable any swap space Error (пишу на память, могу ошибиться, но суть такая)

В cat /proc/swaps ничего нет
top тоже показывает, что своп = 0
Короче он не смонтировался

cat /proc/mdstat говорит, что md0 (swap) есть как read-only
с md1 (/) все в порядке.

Собственно вопрос:
Почему используя инстялятор и руководствуясь инструкцией так выходит, что своп не инициализируется?
И как эту проблему решить?

babahvl ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.