LINUX.ORG.RU
решено ФорумAdmin

do-release-upgrade запретить удаление не поддерживаемых пакетов

 ,


0

1

Добрый вечер! При выполнении обновления с ubuntu 14 до ubuntu 16 do-release-upgrade удаляет, по его мнению, пакеты, которые более не поддерживаются новой версией ubuntu. Беда в том, что эти пакеты мне нужны. «Расстрельный список» включает в себя очень много пакетов. Как запретить такие вольности, но при этом обновиться..?

Если что, речь идёт о zimbra:

Удалить: libperl5.18 zimbra-apache zimbra-common-core-jar 
  zimbra-common-core-libs zimbra-common-mbox-conf 
  zimbra-common-mbox-conf-attrs zimbra-common-mbox-conf-msgs 
  zimbra-common-mbox-conf-rights zimbra-common-mbox-db 
  zimbra-common-mbox-docs zimbra-common-mbox-native-lib zimbra-core 
  zimbra-core-components zimbra-ldap zimbra-ldap-components 
  zimbra-logger zimbra-mbox-service zimbra-mta zimbra-mta-components 
  zimbra-mta-patch zimbra-patch zimbra-proxy zimbra-proxy-patch 
  zimbra-snmp zimbra-spell zimbra-store zimbra-timezone-data 

Удалить aptitude libasprintf0c2 libpython3.4-minimal 
  libpython3.4-stdlib libxapian22 perl-modules python3.4 
  python3.4-minimal systemd-services zimbra-cluebringer 
  zimbra-os-requirements zimbra-perl zimbra-perl-archive-zip 
  zimbra-perl-berkeleydb zimbra-perl-bit-vector 
  zimbra-perl-cache-fastmmap zimbra-perl-compress-raw-bzip2 
  zimbra-perl-compress-raw-zlib zimbra-perl-config-inifiles 
  zimbra-perl-convert-uulib zimbra-perl-crypt-openssl-random 
  zimbra-perl-crypt-openssl-rsa zimbra-perl-data-uuid 
  zimbra-perl-date-calc zimbra-perl-db-file zimbra-perl-dbd-mysql 
  zimbra-perl-dbd-sqlite zimbra-perl-dbi zimbra-perl-digest-hmac 
  zimbra-perl-digest-sha1 zimbra-perl-encode-detect 
  zimbra-perl-file-libmagic zimbra-perl-filesys-df 
  zimbra-perl-html-parser zimbra-perl-http-cookies 
  zimbra-perl-http-daemon zimbra-perl-http-message 
  zimbra-perl-http-negotiate zimbra-perl-innotop 
  zimbra-perl-io-compress zimbra-perl-io-socket-inet6 
  zimbra-perl-io-socket-ip zimbra-perl-io-socket-ssl 
  zimbra-perl-libwww zimbra-perl-list-moreutils 
  zimbra-perl-lwp-protocol-https zimbra-perl-mail-dkim
 zimbra-perl-mail-spamassassin zimbra-perl-mail-spf 
  zimbra-perl-net-dns zimbra-perl-net-dns-resolver-programmable 
  zimbra-perl-net-http zimbra-perl-net-ldap zimbra-perl-net-ldapapi 
  zimbra-perl-net-libidn zimbra-perl-net-ssleay 
  zimbra-perl-netaddr-ip zimbra-perl-proc-processtable 
  zimbra-perl-soap-lite zimbra-perl-socket zimbra-perl-socket-linux 
  zimbra-perl-swatchdog zimbra-perl-term-readkey 
  zimbra-perl-unix-getrusage zimbra-perl-unix-syslog 
  zimbra-perl-xml-parser zimbra-perl-xml-sax-expat 
  zimbra-perl-xml-simple zimbra-perl-zmq-libzmq3 zimbra-pflogsumm 
  zimbra-prepflog zimbra-spamassassin-rules (было установлено 
  автоматически)

Беда в том, что после такого «удара», zimbra подходящей версии ubuntu (install.sh) уже не видит саму себя, говорит: что нет установленной zimbra, и ставит мне всё с нуля…

★★★★★

apt-mark hold не помогает? В случае с дебианом - он предотвращает любые автоматические действия с пакетом в ходе обновлений.

Беда в том, что после такого «удара», zimbra подходящей версии ubuntu (install.sh) уже не видит саму себя, говорит: что нет установленной zimbra, и ставит мне всё с нуля…

Ничего не понятно. Ты снёс zimbra (не знаю что это), потом решил поставить назад и он говорит что не установлено?

firkax ()
Последнее исправление: firkax (всего исправлений: 2)

Первая ссылка запросу «zimbra upgrade from ubuntu 14.04», если что - https://news.numlock.ch/linux/how-to-upgrade-zimbrazcs-8-8-ga-from-ubuntu-14-...

Update: предложенная мною ссылка сработает если ты ЕЩЕ не обновился. Если уже обновился - то видимо придется ставить с нуля, или откатываться до бэкапа(ты же сделал бэкап, да?)

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)
Ответ на: комментарий от Pinkbyte

Спасибо большое! Я как единственно верным решением видел прописать новые репозитории zimbra, в момент запуска do-release-upgrade, что бы эта сука не удаляла а обновляла пакеты! Удивительно то, что когда я делал обновление с ubuntu 12 до ubuntu 14 - такой беды не было. Я вот как-то не смог вгуглить сию ссылку. Старею, видимо…

Я не просто сделал backup, я всё делаю на точной копии продуктива. У меня весьма не маленький инстанс зимбры от 2012 года, обслуживание которого сводится к подкрутке спам правил и добавления места. :)

DALDON ★★★★★ ()
Ответ на: комментарий от firkax

Ты снёс zimbra (не знаю что это), потом решил поставить назад и он говорит что не установлено?

Ну не я, а do-release-upgrade :) Да, оно к херам выносит все бинарики, а инсталлятор, похоже ориентируется о том, установлена ли zimbra или нет, именно по наличию каких-то бинариков. Вот и кричит: zimbra не установлена, а каталог с её базой данных есть, давай мол снесу и поставлю всё с нуля.

DALDON ★★★★★ ()
Ответ на: комментарий от firkax

Спасибо! Быть может зависит от весрии do-release-upgrade, я гуглил ответы в 2012-2014 годов. :) Ну, так-как у меня софт именно такого года. Если грамотный вариант не сгодится, попробую костыль :)

DALDON ★★★★★ ()