LINUX.ORG.RU
ФорумAdmin

Не запускается реплика.

 , ,


0

1

Здравствуйте. Работают два инстанса. mysql  Ver 15.1 Distrib 10.2.26-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2 Debian 9.11. Один из них (ram_db порт 3307) реплиципровался на прежнем сервере (10.0.32-MariaDB, Debian 8). На новом железе и софте реплика не запускается. (сервер реплики тоже новый и с тем же софтом, старого уже нет совсем).

Сейчас состояние Seconds_Behind_Master: NULL, т. е. репликция не началась. При этом: Slave_SQL_Running_State: Slave has read all relay log; waiting for the slave I/O thread to update it

Slave_IO_State: NULL

Slave_IO_Running: Preparing Slave_SQL_Running: Yes

На slave сервере в master.err пишет:

2019-12-25 10:10:05 140098672510144 [Note] Plugin 'FEEDBACK' is disabled.
2019-12-25 10:10:06 140098672510144 [Note] Server socket created on IP: '0.0.0.0'.
2019-12-25 10:10:06 140098672510144 [Note] Reading of all Master_info entries succeeded
2019-12-25 10:10:06 140098672510144 [Note] Added new Master_info " to hash table
2019-12-25 10:10:06 140098672510144 [Note] /usr/sbin/mysqld: ready for connections.
Version: '10.2.26-MariaDB-10.2.26+maria~stretch-log'  socket: '/var/run/mysqld/mysqld1.sock'  port: 3307  mariadb.org binary distribution
2019-12-25 10:10:06 140091111847680 [Note] Slave SQL thread initialized, starting replication in log 'ram_db_binlog.000692' at position 346, relay log './master-relay-bin.000001' position: 4
2019-12-25 10:10:07 140091112154880 [Note] Slave I/O thread: connected to master 'vasy@192.168.102.74:3307',replication started in log 'ram_db_binlog.000692' at position 346
2019-12-25 10:10:53 140091129861888 [Note] InnoDB: Buffer pool(s) load completed at 191225 10:10:53

Позиция правильная ('ram_db_binlog.000692' at position 346). Не понятно только при чем тут relay log './master-relay-bin.000001' position: 4.
При попытке сделать stop slave консоль зависает. При попытке остановить инстанс не стопится. До того как на машине выполняешь start slave, т. е. пока она master, все стопится и стартует номально.
Если не было конекта к master серверу ( например не было создано пользователя или просто не было связи по сети) все также стопилось и стартовало номально.

Выходит, что по логам все нормально, но реплика не запускается и не догоняет. И виснет, когда законектится.
Поделитесь пожалуйста соображениями.

stop slave консоль зависает

И как долго оно висит? Может оно по сети не может куда-то достучаться? Понаблюдай сеть, ФС. Добавь логам вербозности.

deep-purple ★★★★★ ()

Может, на самом деле проблема где-то в файрволлах или подобном?

turtle_bazon ★★★★★ ()

Похоже на проблемы в сети…

Shulman ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.