LINUX.ORG.RU
решено ФорумAdmin

Kubernetes Cluster

 ,


0

1

Добрый день коллеги !

Подскажите,где можно найти список нормально работающих вместе kubelet kubeadm kubectl flannel docker-ce Ставлю на убунту 16.04. Столкнулся с тем что есть конфликты версий.

Или может быть есть скрипт готовый для развертывания ?

Спасибо.

Ответ на: комментарий от AntonyRF

kubectl get nodes

kubermos1 NotReady master 6m26s v1.16.0

kubermos2.ptg.local NotReady <none> 2m51s v1.16.0

kubermos3.ptg.local NotReady <none> 2m44s v1.16.0

kubectl get pods -n kube-system

coredns-5644d7b6d9-5b95h 0/1 Pending

coredns-5644d7b6d9-p87cm 0/1 Pending

systemctl status kubelet

ep 26 12:52:28 kubermos1 kubelet[27952]: E0926 12:52:28.681569 27952 kubelet.go:2187] Container runtime network not ready: NetworkReady=false reason:NetworkPluginNotReady message:docker: network plugin is not ready: cni config unin Sep 26 12:52:33 kubermos1 kubelet[27952]: W0926 12:52:33.581963 27952 cni.go:202] Error validating CNI config &{cbr0 false [0xc000e3f000 0xc000e3f080] [123 10 32 32 34 110 97 109 101 34 58 32 34 99 98 114 48 34 44 10 32 32 34 112 1 Sep 26 12:52:33 kubermos1 kubelet[27952]: W0926 12:52:33.582117 27952 cni.go:237] Unable to update cni config: no valid networks found in /etc/cni/net.d

borisgorbunov ()

Что такое kubesprey не слышал.

У меня локальн всё на 16.04 отлично работает по стандартным докам с стандарных репозиториев:

https://docs.docker.com/install/linux/docker-ce/ubuntu/

https://kubernetes.io/docs/setup/production-environment/tools/kubeadm/create-...

Вот такие версии, разы ты так просишь:

ivan@ivanpc:~$ dpkg-query --showformat='${Package}-${Version}\n' --show kubelet kubeadm kubectl docker-ce
docker-ce-5:19.03.2~3-0~ubuntu-xenial
kubeadm-1.16.0-00
kubectl-1.16.0-00
kubelet-1.16.0-00

sphericalhorse ★★★★ ()