LINUX.ORG.RU

timedatectl ... NTP enabled: yes

systemctl status systemd-timesyncd

ntpq

timedatectl не работает с ntpd, только с systemd-timesyncd. Судя по выводу ntpq, время синхронизировано, т.е. ntpd работает нормально. Выхода два — либо отключить systemd-timesyncd, либо наоборот, добиться его работы и отключить ntpd.

gremlin_the_red ★★ ()
Ответ на: комментарий от gremlin_the_red

timedatectl не работает с ntpd, только с systemd-timesyncd

Как минимум, работает еще и с chrony (показывает NTP synchronized: yes). Скорее всего, работает с любым клиентом, реализующим соответствующий интерфейс в D-Bus.

deadNightTiger ★★★★ ()
Ответ на: комментарий от ams0114

Найди такой сервер с которым

ntpdate -q [ntp_server]

будет выдавать что-то вроде

ntpdate -q ntp.ubuntu.com
server 91.189.94.4, stratum 2, offset 0.000112, delay 0.13164
10 Jan 20:47:03 ntpdate[31419]: adjust time server 91.189.94.4 offset 0.000112 sec

и юзай его

Хотя мне кажется тут с файерволом что-то не так

alx777 ()
Ответ на: комментарий от gremlin_the_red

Оно отрубается, если стоит сторонний NTP-сервер. По крайней мере в дебиане оно не запускается, если находит бинарники других серверов.

$ systemctl cat systemd-timesyncd.service
...
# /lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf
[Unit]
# don't run timesyncd if we have another NTP daemon installed
ConditionFileIsExecutable=!/usr/sbin/ntpd
ConditionFileIsExecutable=!/usr/sbin/openntpd
ConditionFileIsExecutable=!/usr/sbin/chronyd
ConditionFileIsExecutable=!/usr/sbin/VBoxService
Radjah ★★★★★ ()