LINUX.ORG.RU
ФорумAdmin

При загрузке не всегда активируется сетевая карта

 ,


0

1

Доброго времени суток!

Решил вот поделиться проблемой, проблема уже как пол года.
При загрузке Ubuntu 18.04 lts Server довольно часто не стартует сетевая I350-4.

Выражается это в том что после загрузки через «ifconfig -a» у меня нет ни одного сетевого интерфейса кроме lo.

Причём такое бывает через раз, то карта есть, то карты нет!

Подскажите куда копать и где смотреть!

p.s. Не совсем в тему, но на этом компьютере (это роутер вообще то) я поднимаю два PPPoE, два провайдера, маршрутизация и всё остальное вроде работает, на этом же форуме советовался, но уже пару раз было что не поднимались оба PPPoE, причём руками через «pon» всё стартует, можно ли как то отслеживать и принудительно стартовать?!

Ответ на: комментарий от anonymous

В любое время. Там инфа от ядра с самого начала загрузки.

Несовсем так. Через неделю уже можно не увидеть, что там было. А, может, и через день. Зависит от количества сообщений от ядра в процессе работы.

AS ★★★★★ ()
Ответ на: комментарий от Uranus

да, когда не определилась сетевая карта нужно посмотреть «что» есть в dmesg (ошибки, предупреждения, и т.д.).

В /var/log/ есть несколько логов (messages, kern.log, syslog, ...) после старта там можно найти «проблемные места» — со временем они могут быть перезаписаны.

anymouze ★★ ()
Ответ на: комментарий от Uranus

Хм..., надо ещё конечно потестировать, но..., может ли вызывать такие проблемы включенный hyper-threading, как выключил его вроде проблемы исчезли, пишу «вроде», потому что это рабочий роутер и слишком часто и долго я не могу его перезагружать..., даже загрузка стала по ощущениям быстрее на четверть...

p.s. Комп шесть ядер,с HT 12.

Uranus ()