LINUX.ORG.RU

Почему скачивает файл.

 , ,


0

1

Когда захожу на сайт у меня сразу начинает скачивать файл index.php, который указан в конфиге nginx. Так не должно быть потому что до того момента пока не начал переводить сайт на https , все работало нормально. Права на папки и файлы есть. Сам проект на wordpress. Подскажите пожалуйста.

server {
            server_name site.com;
                        listen 80; # managed by Certbot
                        access_log off;
                        #error_log on;
                        root /home/site.com/ct;
                        index index.php index.html index.htm;
    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/site.com/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/site.com/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
}
server {
        listen   80;
        access_log off;
        error_log on;
        error_log /home/site.com/logs/ct.error.log;
        root /home/site.com/ct;
        # include /etc/nginx/conf/ddos2.conf;
        index index.php index.html index.htm;
        server_name site.com;
        rewrite ^ https://site.com$request_uri? permanent; #301 redirect;
        client_max_body_size 32m;
location / {
        try_files $uri $uri/ /index.php?$args;
}
        location ~ \.php$ {
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                include /etc/nginx/fastcgi_params;
#               fastcgi_pass   unix:/var/run/php5-fpm.sock;
                fastcgi_pass   127.0.0.1:9000;
                fastcgi_index index.php;
                fastcgi_connect_timeout 250;
                fastcgi_send_timeout 250;
                fastcgi_read_timeout 250;
                fastcgi_buffer_size 256k;
                fastcgi_buffers 4 256k;
                fastcgi_busy_buffers_size 256k;
                fastcgi_temp_file_write_size 256k;
                fastcgi_intercept_errors on;
        fastcgi_param SCRIPT_FILENAME /home/site.com/site$fastcgi_script_name;
        }
    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/site.com/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/site.com/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
}
Ответ на: комментарий от RaptorsWings
location / {
        try_files $uri $uri/ /index.php?$args;
}

Вот же. У тебя это до

location ~ \.php$ 

И там тебе еще анонимус выше правильно написал. Удивительно что это вообще работает хоть как-то. Алсо, у тебя редирект то срабатывает? Еще я бы завел отдельную секцию `server` под ssl. Ибо я все еще не понимаю как это вообще может работать :)

Перепиши этот конфиг с нуля лучш.

anonymous ()