LINUX.ORG.RU

Postfix and g suite как релей.

 , , , ,


0

1

Приветствую форумчани.
Столкнулся с проблемой отправки почты с postfix в качестве релея выступает smtp-relay.gmail.com.
Получаю ошибку:
550-5.7.1 Invalid credentials for relay [xxx.xx.xx.125]. The IP address you've 550-5.7.1 registered in your G Suite SMTP Relay service doesn't match domain of 550-5.7.1 the account this email is being sent from. If you are trying to relay 550-5.7.1 mail from a domain that isn't registered under your G Suite account 550-5.7.1 or has empty envelope-from, you must configure your mail server 550-5.7.1 either to use SMTP AUTH to identify the sending domain or to present 550-5.7.1 one of your domain names in the HELO or EHLO command

Домен mysite.com
TLS включён, HELO прописано в 3 местах
main.cf
smtpd_banner = $myhostname ESMTP
smtp_always_send_ehlo = yes
smtp_helo_name = mysite.com

master.cf
smtp unix - - y - - smtp
-o smtp_helo_name=mysite.com
Но при этом всё равно выдаёт в HELO IP xxx.xx.xx.125
postconf -n

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
compatibility_level = 2
dovecot_destination_recipient_limit = 1
inet_interfaces = all
inet_protocols = ipv4
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
maximal_backoff_time = 8000s
maximal_queue_lifetime = 7d
minimal_backoff_time = 1000s
mydestination =
mydomain = mysite.com
myhostname = mysite.com
mynetworks = 127.0.0.0/8
myorigin = $mydomain
readme_directory = no
recipient_delimiter = +
relayhost = smtp-relay.gmail.com:587
smtp_always_send_ehlo = yes
smtp_helo_name = mysite.com
smtp_helo_timeout = 60s
smtp_tls_note_starttls_offer = yes
smtp_tls_security_level = encrypt
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_tls_wrappermode = yes
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_hard_error_limit = 12
smtpd_recipient_limit = 16
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_non_fqdn_recipient reject_unauth_destination reject_unknown_recipient_domain reject_unauth_pipelining permit
smtpd_relay_restrictions = reject_unauth_pipelining permit_mynetworks permit_sasl_authenticated reject_non_fqdn_recipient reject_unauth_destination reject_unknown_recipient_domain permit
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_exceptions_networks = $mynetworks
smtpd_sasl_local_domain = srv-web-1
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = permit_sasl_authenticated permit_mynetworks warn_if_reject reject_non_fqdn_sender reject_unknown_sender_domain reject_unauth_pipelining permit
smtpd_soft_error_limit = 3
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/postfix/ssl/mysite.com.cert
smtpd_tls_key_file = /etc/postfix/ssl/mysite.com.key
smtpd_tls_loglevel = 1
smtpd_tls_mandatory_protocols = !SSLv2,!SSLv3
smtpd_tls_received_header = yes
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
unknown_local_recipient_reject_code = 450
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf mysql:/etc/postfix/mysql-virtual-email2email.cf
virtual_gid_maps = static:2222
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
virtual_minimum_uid = 2222
virtual_transport = smtp:smtp-relay.gmail.com:587
virtual_uid_maps = static:2222

Прошу помощи разобраться в этой проблеме. Спасибо.

Но при этом всё равно выдаёт в HELO IP xxx.xx.xx.125

Это вы в своих логах видите (при вкл. debug/verbose) или верите тому, что пишет гугл?

mky ★★★★★ ()
Ответ на: комментарий от mky

модулем WP

Это я смотрю модулем WP (Multi SMTP) 3: Connection: opening to xx.xx.xx.40:587, timeout=300, options=array ( ) 3: Connection: opened 2: SERVER -> CLIENT: 220 mysite.org ESMTP Postfix (Debian/GNU) 1: CLIENT -> SERVER: EHLO xx.xx.xx.125 2: SERVER -> CLIENT: 250-mysite.org 250-PIPELINING 250-SIZE 10240000 250-VRFY 250-ETRN 250-STARTTLS 250-ENHANCEDSTATUSCODES 250-8BITMIME 250-DSN 250 SMTPUTF8 1: CLIENT -> SERVER: STARTTLS 2: SERVER -> CLIENT: 220 2.0.0 Ready to start TLS 3: SMTP Error: Could not connect to SMTP host. 1: CLIENT -> SERVER: QUIT

(((, может я не прав, подскажите как точно проверить что мой smtp server передаёт правильный HELO. Спасибо

SimbioS ()
Ответ на: модулем WP от SimbioS

ЕМНИП, в master.cf в строку

smtp unix - ...
нужно добавить в конец ″-vvv″ (опции команды smtpd), и тогда при отправке письма в логи насыпится куча сообщений, среди них и смотреть.

P.S. А этот ip-адрес [xxx.xx.xx.125] имеет обратную запись в DNS (PTR)?

mky ★★★★★ ()