LINUX.ORG.RU
ФорумAdmin

syslog-ng, journald

 , ,


2

2

ставлю syslog-ng

в /etc/systemd/journald.conf:
ForwardToSyslog=yes

далее

systemctl restart systemd-journald.service
systemctl enable syslog-ng@default
systemctl start syslog-ng@default

в /var/log появляются логи kernel.log, syslog.log..

что бы логи не писались дважды и journald, и syslog-ng:

в /etc/systemd/journald.conf:
Storage=none

после этого, текстовые логи перестают заполнятся.

/etc/syslog-ng/syslog-ng.conf

source src {
  system();
  internal();
};

подскажите что можно сделать, source поменять, syslog-ng.service юнит файл.

в инетернете все какое-то путаное, ответа найти не получается.

Ответ на: комментарий от mandala

Они не напрямую пишутся, а транслируются, что ж ты ожидал

для rsyslog поменять Storage=none, ForwardToSyslog=yes работает. т.е. возможность видимо есть.

barberry ★★ ()

покопался в rsyslog.service:

[Install]
WantedBy=multi-user.target
Alias=syslog.service       <---

добавил для syslog-ng.service

systemctl enable syslog-ng@default
Created symlink /etc/systemd/system/syslog.service → /usr/lib/systemd/system/syslog-ng.service

это типа теперь syslog-ng стал имплементацией syslog

kernel.log, auth.log, daemon.log.. заполняются.

barberry ★★ ()

в предыдущем сообщении поспешил написать, т.к. забыл поставить Storage=none.

или syslog-ng не умеет с none, или я не нашел как.

в итоге, все что осталось, после чистой установки, установить Storage=volatile, journald теперь хранит свои логи в памяти.

barberry ★★ ()
Последнее исправление: barberry (всего исправлений: 1)
Ответ на: комментарий от mandala

Они не напрямую пишутся, а транслируются, что ж ты ожидал.

Одно не мешает другому.

Ставь openrc вместо systemd.

Вредные советы?

intelfx ★★★★★ ()
Ответ на: комментарий от intelfx

Одно не мешает другому

Угу, уже увидел.

Вредные советы?

Зато сколько секса!

mandala ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.