LINUX.ORG.RU
ФорумAdmin

Настройка VPN сервера за роутером

 , , , ,


1

1

Приветствую. Есть задача настроить VPN сервер на Mikrotik, который находится за роутером провайдера, доступ к нему есть, как и ко всем остальным узлам. Пробую настроить для начала простой PPTP VPN, но что-то, видимо делаю не так, не работает. Прошу помощи спецов. Схема по ссылке: https://ibb.co/jHAb8S

Есть задача настроить VPN сервер на Mikrotik, который находится за роутером провайдера

Если роутер провайдера делает NAT для Mikrotik-а - как ты собрался к нему подключаться?

PPTP

Не лучший выбора для VPN-сервера, находящегося за NAT-ом. Точнее - сложно придумать более худший выбор

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Я хочу оставить роутер провайдера как точку раздачи интернета по WiFi и физический коннектор к оптике. @Pinkbyte, твое мнение, как лучше быть в этой ситуации, когда нужен WiFi, VPN сервер?

ivan_biv ()

Sercomm RV6699? МГТС GPON что ли?

Переводи его в бридж, чтобы внешний IP был на микротике.

Deleted ()
Ответ на: комментарий от ivan_biv

Если есть логин/пароль к провайдерскому роутеру и хочется именно его использовать для раздачи Wi-Fi, а Mikrotik-у оставить только VPN, тогда выбор очевиден - используй такой VPN, в котором можно просто пробросить порт для соединения. Очевидно что PPTP, в котором нужно пробрасывать порт TCP 1723 и еще до кучи GRE - таковым не является.

А вот L2TP или OpenVPN - вполне. OpenVPN в реализации Mikrotik имеет свои особенности, так что тут не всё так просто. Была бы у тебя чисто-линуксовая машина - я бы голосовал за OpenVPN(говорят еще wireguard хорош, но я не щупал). А тут - хз, выбора не так чтобы много и он - непростой. Ибо L2TP в чистом виде не безопасен, поэтому тут еще напрашивается IPSec.

Pinkbyte ★★★★★ ()
Ответ на: комментарий от ivan_biv

Не будет, конечно. Точнее, саму точку можно включить, скорее всего, только интернета там не будет.

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)
Ответ на: комментарий от Pinkbyte

Да, я не указал, нужна безопасность и простота.

Если проще сделать мостом роутер провайдера, и нормально настроить VPN (к стати, какой рекомендуете простота/качество) + купить точку доступа - вполне. Лиж бы было надежно, просто, безопасно )

ivan_biv ()

В общем решил я перевести роутер провайдера в режим моста, и настроить VPN на Mikrotik. Ваше мнение, правильное ли решение?

Делал по инструкции http://wifisystem.ru/docs/mikrotik/openvpn-server-mikrotik/

Настроил клиента на Windows. В результате клиент постоянно переподключается. Логи Mikrotik https://ibb.co/iteUv7

Лог клиента:

Sat Mar 10 01:26:18 2018 MANAGEMENT: >STATE:1520627178,RECONNECTING,connection-reset,,
Sat Mar 10 01:26:18 2018 Restart pause, 5 second(s)
Sat Mar 10 01:26:23 2018 Socket Buffers: R=[8192->8192] S=[8192->8192]
Sat Mar 10 01:26:23 2018 Attempting to establish TCP connection with [AF_INET]XXX.XXX.XXX.XXX:1194 [nonblock]
Sat Mar 10 01:26:23 2018 MANAGEMENT: >STATE:1520627183,TCP_CONNECT,,,
Sat Mar 10 01:26:24 2018 TCP connection established with [AF_INET]XXX.XXX.XXX.XXX:1194
Sat Mar 10 01:26:24 2018 TCPv4_CLIENT link local: [undef]
Sat Mar 10 01:26:24 2018 TCPv4_CLIENT link remote: [AF_INET]XXX.XXX.XXX.XXX:1194
Sat Mar 10 01:26:24 2018 MANAGEMENT: >STATE:1520627184,WAIT,,,
Sat Mar 10 01:26:24 2018 MANAGEMENT: >STATE:1520627184,AUTH,,,
Sat Mar 10 01:26:24 2018 TLS: Initial packet from [AF_INET]XXX.XXX.XXX.XXX:1194, sid=fab6e04b 061d4005
Sat Mar 10 01:26:24 2018 Connection reset, restarting [0]
Sat Mar 10 01:26:24 2018 SIGUSR1[soft,connection-reset] received, process restarting
Sat Mar 10 01:26:24 2018 MANAGEMENT: >STATE:1520627184,RECONNECTING,connection-reset,,
Sat Mar 10 01:26:24 2018 Restart pause, 5 second(s)
Sat Mar 10 01:26:29 2018 Socket Buffers: R=[8192->8192] S=[8192->8192]
Sat Mar 10 01:26:29 2018 Attempting to establish TCP connection with [AF_INET]XXX.XXX.XXX.XXX:1194 [nonblock]
Sat Mar 10 01:26:29 2018 MANAGEMENT: >STATE:1520627189,TCP_CONNECT,,,
Sat Mar 10 01:26:30 2018 MANAGEMENT: CMD 'signal SIGHUP'
Sat Mar 10 01:26:30 2018 SIGHUP[hard,init_instance] received, process restarting
Sat Mar 10 01:26:30 2018 MANAGEMENT: >STATE:1520627190,RECONNECTING,init_instance,,
Sat Mar 10 01:26:30 2018 OpenVPN 2.3.18 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Oct 26 2017
Sat Mar 10 01:26:30 2018 Windows version 6.1 (Windows 7) 64bit
Sat Mar 10 01:26:30 2018 library versions: OpenSSL 1.0.2l  25 May 2017, LZO 2.10
Sat Mar 10 01:26:30 2018 Restart pause, 5 second(s)

Вот экспорт:

# mar/09/2018 23:55:32 by RouterOS 6.41.2
# software id = ZWQB-BZ1T
#
# model = RouterBOARD 750G r3
# serial number = 6F3808A7C929
/interface bridge
add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no comment=defconf name=bridge
/interface ethernet
set [ find default-name=ether1 ] name=eth1-wan
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=openvpn-pool ranges=172.30.0.10-172.30.0.253
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
/ppp profile
add local-address=172.30.0.1 name=openvpn-profile-1 remote-address=openvpn-pool
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=eth1-wan list=WAN
/interface ovpn-server server
set certificate=server.crt_0 cipher=blowfish128,aes128,aes192,aes256 default-profile=openvpn-profile-1 enabled=yes require-client-certificate=yes
/interface pppoe-server server
add authentication=mschap1,mschap2 interface=eth1-wan keepalive-timeout=disabled service-name=service1
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=eth1-wan
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input dst-port=1194 in-interface=eth1-wan protocol=tcp
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/ppp secret
add name=YYYY password=XXX profile=openvpn-profile-1 service=ovpn
/system clock
set time-zone-name=Europe/Moscow
/system routerboard mode-button
set enabled=no on-event=""
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
ivan_biv ()

Удалось поднять VPN, через шаманство с конфигом клиента. Но на микротике вижу ошибку: https://ibb.co/f2dUf7 что это? это клиент два раза шлет пакет или что?

ivan_biv ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.