LINUX.ORG.RU
решено ФорумAdmin

Awstats для nginx: не находится статистика

 , , , ,


0

1

Добрый день. Не могу решить проблему с просмотром статистики awstats: получаю ошибку 404 от nginx.

Настраиваю awstats для nginx. Ставлю задачу для cron. Всё делаю вот по этому руководству: http://www.tech-notes.net/awstats-for-nginx/

Вижу, что awstats работает, по крайней мере в /var/lib/awstats/ создаются текстовые файлы, в которых предположительно содержится информация по месяцам.

Когда пытаюсь зайти на свой сайт по адресу: my_site.com/awstats/awstats.pl?config=my_site.com получаю ошибку: 404 Not Found

При попытке обновить awstats вручную: sudo /usr/lib/cgi-bin/awstats.pl -update -config=my_site.com вылезала ошибка «perl: warning: Please check that your locale settings», которая была решена с помощью «sudo dpkg-reconfigure locales».

Но это не помогло, ошибка 404 не пропадает.

Настройки такие:

server {
    listen 80 default_server;
    listen [::]:80 default_server;
    root  /usr/share/wordpress;
    location /awstats/ {
        root   /usr/lib/cgi-bin;
        index  index.html index.htm index.pl;
    }
    location /awstatsclasses/ {
        alias /usr/share/awstats/lib/;
    }
    location /awstats-icon/ {
        alias /usr/share/awstats/icon/;
    }
    location /awstatscss {
        alias /usr/share/doc/awstats/examples/css/;
    }
}

Спасибо!

Ответ на: комментарий от bluerosepig

Тебе нужен будет ещё spawn-fcgi
Ищи как поставить и настроить связку nginx+perl+spawn-fcgi
Ну или любой другой cgi-helper, умеющий перл.

imul ★★★★★ ()
8 января 2018 г.

После переноса awstats.pl в директорию в корне сайта всё заработало.

bluerosepig ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.