LINUX.ORG.RU
ФорумAdmin

OpenVPN - выборочно открываются сайты

 


0

1

Взял сервер у vscale.io (selectel)
Развернул ovpn вот этим скриптом: https://github.com/Nyr/openvpn-install

Все подключается, работает, но есть проблема:
Некоторые сайты открываются нормально, а некоторые нет. К примеру, гугл со всеми поддоменами работает отлично, а яндекс нет. При этом яндекс пингуется. Как-то странно...

Ответ на: комментарий от Deleted

PING http://www.YANDEX.ru (77.88.55.55) 1472(1500) bytes of data.
1480 bytes from yandex.ru (77.88.55.55): icmp_seq=1 ttl=58 time=407 ms
1480 bytes from yandex.ru (77.88.55.55): icmp_seq=2 ttl=58 time=435 ms
1480 bytes from yandex.ru (77.88.55.55): icmp_seq=3 ttl=58 time=422 ms
1480 bytes from yandex.ru (77.88.55.55): icmp_seq=4 ttl=58 time=393 ms
1480 bytes from yandex.ru (77.88.55.55): icmp_seq=5 ttl=58 time=407 ms

nexcode ()
Ответ на: комментарий от nexcode

А вот так пингуется google (он открывается в браузере):
PING http://www.google.com (173.194.222.99) 1472(1500) bytes of data.
72 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=1 ttl=49 (truncated)
72 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=2 ttl=49 (truncated)
72 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=3 ttl=49 (truncated)
72 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=4 ttl=49 (truncated)
72 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=5 ttl=49 (truncated)

nexcode ()
Ответ на: комментарий от nexcode

PING http://www.google.com (173.194.222.99) 56(84) bytes of data.
64 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=1 ttl=49 time=107 ms
64 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=2 ttl=49 time=101 ms
64 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=3 ttl=49 time=94.8 ms
64 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=4 ttl=49 time=104 ms
64 bytes from lo-in-f99.1e100.net (173.194.222.99): icmp_seq=5 ttl=49 time=124 ms

nexcode ()
Ответ на: комментарий от anc

Пока ради интереса настроил сервер и клиент на mtu=1200
Вроде бы все сайты открываются нормально.
Подскажите, как определить подходящее значение mtu не методом тыка?

nexcode ()
Ответ на: комментарий от nexcode

Выше написал:
1. mtu-test в конфиге клиента (тестировать будет долго о чем он и сообщает в логах)
2. Можно и вручную указать там же.
3. Если это на роутере то iptables TCPMSS

anc ★★★★★ ()

в мане openvpn сказано, что openvpn сам правит mss в проходяших через тунель пакетах и шаманить с mtu не рекомендуется. я смотрел у себя tcpdump с тунеля - да это действительно так. скорее всего твой скрипт говно, какую-нибудь отсебятину в конфиги пихает.

Rost ★★★★ ()
Ответ на: комментарий от Rost

Конфиг выглядит так:
port 1194
proto udp
dev tun
sndbuf 0
rcvbuf 0
ca ca.crt
cert server.crt
key server.key
dh dh.pem
tls-auth ta.key 0
topology subnet
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push «redirect-gateway def1 bypass-dhcp»
push «dhcp-option DNS 188.93.16.19»
push «dhcp-option DNS 188.93.17.19»
push «dhcp-option DNS 8.8.8.8»
push «dhcp-option DNS 8.8.4.4»
keepalive 10 120
cipher AES-128-CBC
comp-lzo
user nobody
group nobody
persist-key
persist-tun
status openvpn-status.log
verb 3
crl-verify crl.pem

Ну и я туда дописал:
tun-mtu 1200

nexcode ()
Ответ на: комментарий от nexcode

Также, насколько я понимаю, по факту настройка mss сделает то же самое, просто его значение не учитывает заголовки:
Примерно так: MSS + заголовок TCP + заголовок IP ≤ MTU

nexcode ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.