LINUX.ORG.RU
решено ФорумAdmin

Corosync+Pacemaker

 , , , ,


2

2

Всем привет!

Настраиваю связку Corosync+Pacemaker по ману

http://ninjix.blogspot.de/2011/01/highly-available-zabbix-monitoring.html


Ноды запускаются и работают:


Online: [ dus-zabbixdb-1 dus-zabbixdb-2 ]

Resource Group: zabbix_group
fs_mysql (ocf::heartbeat:Filesystem): Started dus-zabbixdb-1
ip_mysql (ocf::heartbeat:IPaddr2): Started dus-zabbixdb-1
mysqld (lsb:mysql): Started dus-zabbixdb-1
Master/Slave Set: ms_drbd_mysql [drbd_mysql]
Masters: [ dus-zabbixdb-1 ]
Slaves: [ dus-zabbixdb-2 ]
apache (lsb:apache2): Started dus-zabbixdb-2
zabbix (lsb:zabbix-server): Started dus-zabbixdb-2



Меня смущает то, что mysql запускается на первой ноде, а apache и zabbix запускаются на второй ноде. Если остановить вторую ноду, то все берет на себя первая нода, но как только включаешь вторую, apache и zabbix убегают туда. Почему так происходит. Да всех сервисов выделен один адрес 192.168.5.250, таким образом только mysql бывает доступен. Если же выключить вторую ноду, тогда подхватывается apache и zabbix.
Подскажите пожалуйста как поправить.

За ранее спасибо!


Ответ на: комментарий от router

В конфиге crm стоит:

group zabbix_group fs_mysql ip_mysql mysqld zabbix apache


Должно все в одной группе идти, или я не прав?

kbu ()
Ответ на: комментарий от zolden
node $id=«1084753400» dus-zabbixdb-1                                                                                                                                                         
node $id=«1084753401» dus-zabbixdb-2
primitive apache lsb:apache2 \
meta target-role=«Started»
primitive drbd_mysql ocf:linbit:drbd \
params drbd_resource=«mysql_r0» \
op monitor interval=«15s»
primitive fs_mysql ocf:heartbeat:Filesystem \
params device=«/dev/drbd/by-res/mysql_r0» directory=«/mnt/» fstype=«ext4» options=«acl» \
meta target-role=«Started»
primitive ip_mysql ocf:heartbeat:IPaddr2 \
params ip=«192.168.5.250» nic=«eth0» \
meta target-role=«Started»
primitive mysqld lsb:mysql \
op start interval=«0» timeout=«120s» \
op stop interval=«0» timeout=«120s» \
op monitor interval=«30s» \
meta target-role=«Started»
primitive zabbix lsb:zabbix-server \
op start interval=«0» timeout=«60» delay=«5s» \
op monitor interval=«30s» \
meta target-role=«Started»
group zabbix_group fs_mysql ip_mysql mysqld \
meta target-role=«Started»
ms ms_drbd_mysql drbd_mysql \
meta master-max=«1» master-node-max=«1» clone-max=«2» clone-node-max=«1» notify=«true» target-role=«Started»
colocation mysql_on_drbd inf: _rsc_set_ zabbix_group ms_drbd_mysql:Master
order mysql_after_drbd inf: _rsc_set_ ms_drbd_mysql:promote zabbix_group:start
property $id=«cib-bootstrap-options» \
dc-version=«1.1.10-42f2063» \
cluster-infrastructure=«corosync» \
expected-quorum-votes=«2» \
no-quorum-policy=«ignore» \
stonith-enabled=«false» \
last-lrm-refresh=«1294782404»
kbu ()
Ответ на: комментарий от kbu

Странно, сейчас в группе вижу только мускл..
хотя скармливал вот этот конфиг:


primitive apache lsb:apache2
primitive drbd_mysql ocf:linbit:drbd \
params drbd_resource=«mysql_r0» \
op monitor interval=«15s»
primitive fs_mysql ocf:heartbeat:Filesystem \
params device=«/dev/drbd/by-res/mysql_r0» directory=«/mnt/» fstype=«ext4» options=«acl»
primitive ip_mysql ocf:heartbeat:IPaddr2 \
params ip=«192.168.5.250» nic=«eth0»
primitive mysqld lsb:mysql \
op start interval=«0» timeout=«120s» \
op stop interval=«0» timeout=«120s» \
op monitor interval=«30s»
primitive zabbix lsb:zabbix-server \
op start interval=«0» timeout=«60» delay=«5s» \
op monitor interval=«30s»
group zabbix_group fs_mysql ip_mysql mysqld zabbix apache \
meta target-role=«Started»
ms ms_drbd_mysql drbd_mysql \
meta master-max=«1» master-node-max=«1» clone-max=«2» clone-node-max=«1» notify=«true» target-role=«Master»
colocation mysql_on_drbd inf: _rsc_set_ zabbix_group ms_drbd_mysql:Master
order mysql_after_drbd inf: _rsc_set_ ms_drbd_mysql:promote zabbix_group:start
property $id=«cib-bootstrap-options» \
dc-version=«1.1.10-42f2063» \
cluster-infrastructure=«openais» \
expected-quorum-votes=«2» \
no-quorum-policy=«ignore» \
stonith-enabled=«false» \
last-lrm-refresh=«1294782404»

kbu ()
Ответ на: комментарий от zolden

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 00:0c:29:b5:fb:0f brd ff:ff:ff:ff:ff:ff
inet 192.168.5.248/24 brd 192.168.5.255 scope global eth0
valid_lft forever preferred_lft forever
inet 192.168.5.250/32 brd 192.168.5.250 scope global eth0
valid_lft forever preferred_lft forever
inet6 fe80::20c:29ff:feb5:fb0f/64 scope link
valid_lft forever preferred_lft forever



что-то не так?

kbu ()
Ответ на: комментарий от kbu

Да норм в общем-то...когда много плавающих адресов удобно добавлять параметр iflabel, в вашем случае в эту строчку «params ip=«192.168.5.250» nic=«eth0»», чисто для наглядности
Но у вас он один, поэтому не так всё усложнено

zolden ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.