LINUX.ORG.RU
ФорумAdmin

Установка\удаление пактов

 


0

1
Setting up courier-authlib-mysql (0.63.0-3) ...
/var/run/courier/authdaemon/pid.lock: No such file or directory
dpkg: error processing courier-authlib-mysql (--configure):
 subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
                                      Errors were encountered while processing:
 courier-authlib-mysql
E: Sub-process /usr/bin/dpkg returned an error code (1)

Как это исправить?(debian)

Очень похоже на ошибку в самом пакете. Но можно в качестве костыля создать директорию /var/run/courier/authdaemon (владелец — пользователь, от которого запускается демон, или рут) и затем sudo dpkg-reconfigure courier-authlib-mysql

proud_anon ★★★★★ ()
Ответ на: комментарий от proud_anon

root@debian:~# dpkg-reconfigure courier-authlib-mysql /usr/sbin/dpkg-reconfigure: courier-authlib-mysql is broken or not fully installed

giraff ()
Ответ на: комментарий от Nokman

apt-get install vsftpd Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: vsftpd : Depends: libc6 (>= 2.15) but 2.11.3-4 is to be installed Depends: libssl1.0.0 (>= 1.0.0) but it is not installable E: Broken packages

giraff ()
Ответ на: комментарий от giraff

dpkg-reconfigure courier-authlib-mysql /usr/sbin/dpkg-reconfigure: courier-authlib-mysql is broken or not fully installed

Тогда apt-get install --reinstall courier-authlib-mysql

The following packages have unmet dependencies: vsftpd : Depends: libc6 (>= 2.15) but 2.11.3-4 is to be installed Depends: libssl1.0.0 (>= 1.0.0) but it is not installable E: Broken packages

Я так понимаю, у тебя там Debian Squeeze, на который ты накатил пакетов из Sid. Может, проще перейти на Jessie?

proud_anon ★★★★★ ()
Ответ на: комментарий от proud_anon
 apt-get install vsftpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vsftpd : Depends: libc6 (>= 2.15) but 2.11.3-4 is to be installed
          Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
E: Broken packages

Тоже самое выдает.

giraff ()
Ответ на: комментарий от giraff

Depends: libc6 (>= 2.15)

В текущем stable 2.19. Правь sources.list и обновляйся уже.

Nokman ()
Ответ на: комментарий от Nokman
# 

# deb cdrom:[Debian GNU/Linux 6.0.8 _Squeeze_ - Official amd64 NETINST Binary-1 20131019-21:43]/ squeeze main

#deb cdrom:[Debian GNU/Linux 6.0.8 _Squeeze_ - Official amd64 NETINST Binary-1 20131019-21:43]/ squeeze main

deb http://ftp.ru.debian.org/debian/ squeeze main
deb-src http://ftp.ru.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.ru.debian.org/debian/ squeeze-updates main
deb-src http://ftp.ru.debian.org/debian/ squeeze-updates main
deb http://repo.ajenti.org/debian main main debian
deb http://repo.ajenti.org/debian main main debian

giraff ()
Ответ на: комментарий от giraff

repo.ajenti.org

Вот тебе ответ. Или убирай эту панель, или обновляй всю систему до текущего stable.

leave ★★★★★ ()
Ответ на: комментарий от giraff

Переустановить я советовал courier-authlib-mysql, о том, что vsftpd от переустановки заработает, я не говорил. vsftpd у тебя не работает потому, что ты его поставил из repo.ajenti.org, а репозиторий Backports не подключил, тогда как у них на сайте написано, что на Squeeze это надо сделать.

Но только новой libc в Backports всё равно нет, поэтому как это поможет, я не знаю. Может быть это позволит поставить их панель с vsftpd из Backports, а не с их сервера. Лучше подумай об обновлении до Jessie.

proud_anon ★★★★★ ()
Последнее исправление: proud_anon (всего исправлений: 2)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.