LINUX.ORG.RU
ФорумAdmin

странная проблема с vpn


0

0

Имеем сервер под FEDORA 4. Провайдер дает интернет через vpn доступ.
Делать нечего - скачал pptpclient 1.7, от версии 1.5 взял cli pptp-command. Коннекчусь. Коннект проходит, сервер провайдера выдает мне адрес, а потом начинается что-то странное. Через ppp интерфейс видно, как уходит куча трафика (порядка 1 гига за пару минут), причем на езернет этого трафика нет (физически включение на ADSL, столько просто физические не пролезет, причем на передачу). Включаю tcpdump - вижу примерно такое:
14:06:00.506858 IP 10.0.27.10 > 10.128.4.1: call 44739 seq 1932076 gre-ppp-paylo
14:06:00.506909 IP 10.0.27.10 > 10.128.4.1: call 44739 seq 1932077 gre-ppp-paylo
14:06:00.507005 IP 10.0.27.10 > 10.128.4.1: call 44739 seq 1932078 gre-ppp-paylo
14:06:00.507013 IP 10.0.27.10 > 10.128.4.1: call 44739 seq 1932079 gre-ppp-paylo
14:06:00.507022 IP 10.0.27.10 > 10.128.4.1: call 44739 seq 1932080 gre-ppp-paylo
14:06:00.507036 IP 10.0.27.10 > 10.128.4.1: call 44739 seq 1932081 gre-ppp-paylo
14:06:00.507065 IP 10.0.27.10 > 10.128.4.1: gre
И таких записей - море.

В это время у меня ничего не пингается.
Через минуту примерно интерфейс ppp падает со статистикой "принято 1 гиг, передано 40 байт".
Дома у меня другой провайдер, но все работает просто замечательно по моей схеме. Что это может быть примерно?
Да, еще. Мне пришлось сменить мак-адрес карточки, так как соединение было настроено на другой комп временно, а у них раздача по dhcp статическая. Причем адрес, получаю нормально на езернете.


anonymous

Re: странная проблема с vpn

У меня была такая же проблема. Дело было в route таблице.

У меня было так, что поднимался pppM интерфейс, а шлюзом по умолчанию был ethN интерфейс. Я решил так: удалял перед запуском vpn соединения шлюз по умолчанию и прописывал в route таблице путь к серваке через ethN. Когда интерфейс поднимался, я прописывал сам шлюз по умолчанию.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.