LINUX.ORG.RU
ФорумAdmin

Помогите разобраться и настроить роутер для IPTV

 


0

1

Здравствуйте, уже неделю мучаюсь с настройкой роутера tp-link wr841n v9, на прошивке OpenWrt Barrier Breaker 14.07

Моя цель - просмотр IPTV на ps3 через xupnpd.

С родной прошивкой проблем нет, обычный PPPoE login/pass - через программу IPTV показывает. На dd-wrt прошивке тоже настроить получается: включал igmpsnooping в bridging, выключал filtermulticasting, разрешал recieve iptv. Но не смог установить там xupnpd.

В openwrt не могу разобраться как настроить IGMP proxy, какие порты разрешать и т.п., так как я новичок.

Прошу, если не сложно, помочь мне понять и разобраться в настройке.


Моя цель - просмотр IPTV

С родной прошивкой проблем нет

Ну и пользуйся родной прошивкой.

mbivanyuk ★★★★★ ()
Ответ на: комментарий от mbivanyuk

С родной прошивкой не посмотришь на телевизоре. Очень много статей про настройку xupnpd для ps3 через openwrt, но у меня не получается настроить хотя бы просмотр iptv на компе через openwrt.

Вот например взять etc/config/igmpproxy:

config igmpproxy option quickleave 1

config phyint option network wan option direction upstream list altnet 0.0.0.0/0

config phyint option network lan option direction downstream

Можно писать list altnet 0.0.0.0/0? И как вообще определить этот адрес?

il1988 ()
12 января 2015 г.

настраивал updxy и IGMPPROXY на TPLINK TL-WR741ND v4.20 с OpenWrt Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530). Подключаем кабель с интернетом к WAN, провод LAN к компу.Сбрасываю настройки на дефолтные Меняю пароль. IP адрес роутера на 192.168.2.1 Устанавливаю пакеты язык, updxy, IGMPPROXY. Ставлю в загрузку updxy, IGMPPROXY- Включаю (не запускаю)(updxy в принципе при нормально настроеном IGMPPROXY и не нужен, поставил на всякий случай для всяких там Android-ов). Для тех кто незнает какие адреса altnet прописывать в /etc/init.d/igmpproxy и хочет их узнать с помощью утилиты tcpdump, советую это сделать до установки других пакетов, поскольку после установки tcpdump на моем TP-Link TL-WR741ND с установлеными updxy, IGMPPROXY остается 7% свободного места и остальное может не влезть. Для тех у кого памяти побольше могу игнорировать. Настройка IP-TV по инструкци wiki http://wiki.openwrt.org/ru/doc/howto/udp_multicast Команда cat /sys/devices/virtual/net/br-lan/bridge/multicast_snooping получем 1. Редактируем /etc/config/igmpproxy согласно wiki, главное правильные строки altnet и ставим службу в автозагрузку. Редактируем /etc/config/firewall и добавляем строки именно так [spoiler=/etc/config/firewall] Код: config rule option name 'Allow-IGMP' option src 'wan' option proto 'igmp' option target 'ACCEPT' config rule option name 'Allow-IPTV-IGMPPROXY' option src 'wan' option proto 'udp' option dest 'lan' option dest_ip '224.0.0.0/4' option target 'ACCEPT' config rule option name 'Allow-IPTV-ALL' option src 'wan' option proto 'all' option dest_ip '224.0.0.0/4' option target 'ACCEPT' [/spoiler] Согласно рекомендации wiki (в самом конце) по совместному использованию igmpproxy и udpxy. Если вы планируете использовать одновременно igmpproxy и udpxy, то в файле конфигурации фаервола – /etc/config/firewall у вас в итоге должно быть два правила: [spoiler=/etc/config/firewall] Код: config rule option name 'Allow-IGMP' option src 'wan' option proto 'igmp' option target 'ACCEPT' config rule option name 'Allow-IPTV-ALL' option src 'wan' option proto 'all' option dest_ip '224.0.0.0/4' option target 'ACCEPT' [/spoiler] У меня не заработало, работает только с тремя правилами как выше. Перезапускаем firewall и igmpproxy. Теперь, что касается updxy, я ничего не редактировал, а просто в СИСТЕМА-ЗАПУСК ЛОКАЛЬНЫЙ ЗАПУСК добавил перед «exit 0» строку: udpxy -a 192.168.2.1 -p 4022 -B 512kb -M 30 Значения 192.168.2.1, 4022 и 512kb у Вас могут быть другими. Заходим http://192.168.2.1:4022/status и видим, что все включилось. В настройках IP-TV Player сеттевой интерфейс меняем с авто на 192.168.2.1:4022 и радуемся.

v111 ()
16 июля 2015 г.
Ответ на: комментарий от v111

В настройках IP-TV Player сеттевой интерфейс меняем с авто на 192.168.2.1:4022 и радуемся.

очень полезное ваше сообщение для меня было, очень рад что попал в эту тему не ожидано приятно и познавательно оказалось))) еще было бы не плохо еслиб дали совет почему на роутере TP-Link TL-WR 741nd есть интернет по кабелю но нет по wi fi, я вообще дуб в это деле инфу по настройке черпал в статье Как настроить роутер TP-Link TL-WR 741ndя думаю вы сможете что то дельное посоветовать))

Niellyear ()
11 января 2016 г.

Настроил, работает все нормально. НО! Не могу понять такого прикола: перегружаю роутер по питанию - и IP TV не работает, пока не перезагрузишь роутер через интерфейс (софтом). Странно это как-то... Кто сталкивался, в чем прикол, как лечится?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.