LINUX.ORG.RU
решено ФорумAdmin

Grub автоматически не запускает ОС

 , ,


0

1

ОС: Ubuntu Server 14.04

Была замечена следующая проблема: при невыясненных обстоятельствах Grub выводит список ядер, доступных для загрузки, но не загружает автоматические 0-ю ОС. Если подключить клавиатуру и нажать Enter, то загрузка продолжается нормально.

Конфиг Grub'а дефолтный.

> cat /etc/default/grub 
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Как можно заставить Grub загружать ОС не смотря ни на что?

P.S. UEFI

★★

Никогда таких проблем не было. UEFI нет.


GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT=«quiet splash»
GRUB_CMDLINE_LINUX_DEFAULT=«quiet acpi_enforce_resources=lax elevator=cfq splash»
GRUB_CMDLINE_LINUX=«»

acpi_enforce_resources=lax elevator=cfq это мне нужно так.

hbars ★★★★★ ()
Ответ на: комментарий от kostik87

Поставьте другой загрузчик, если уверены, что проблема в grub.

Не уверен. Просто к Ubunt'e плохо отношусь :)
Первый раз такое вижу.

SaBo ★★ ()
Ответ на: комментарий от SaBo

Не уверен. Просто к Ubunt'e плохо отношусь :)
Первый раз такое вижу.

Ну странные люди. Да причем здесь *ubunta к загрузчику. Его же не в Африке писали.
Да это может быть хоть где.

strange unplayable bug

hbars ★★★★★ ()

GRUB_DISABLE_RECOVERY=«true»

раскомментировать

anonymous ()
Ответ на: комментарий от SaBo

Ну ось то серверная стоит? Выруби уефай и грузись в легаси режиме.

blind_oracle ★★★★★ ()

Попробуй снести пакет grub со всеми его настройками.

У меня так после одного обновления стало. Причём смысла я так до сих пор и не понял. После каждого обновления ядра ломается, я делаю переустановку grub с удалением его конфигов и всё становится нормально до следующего обновления ядра.

anonymous ()

Попробуй раскоментировать hidden timeout и закоментировать обычный. Мне помогло.

GRUB_HIDDEN_TIMEOUT=3
#GRUB_TIMEOUT=2

xmichael ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.