LINUX.ORG.RU
ФорумAdmin

XRDP - RUS-ENG раскладка


0

1

Здравствуйте! Как я уже понял в стандартном XRDP, нет переключения языка по нажатию alt+shift, поэтому пытаемся запустить с костылём, цепляемся терминально, открываем командную строку и вводим:

setxkbmap -layout «us,ru(winkeys)» -model «pc105» -option «grp:alt_shift_toggle»

Когда сидишь под пользователем и вводишь эту строчку в терминал, смена языка начинает работать. Теперь задача поставить в автозапуск сессии эту строчку. Захожу в файлик автозапуска:

nano /etc/xdg/lxsession/LXDE/autostart

Добавляю строчку со знаком «@» вначале

@setxkbmap -layout «us,ru(winkeys)» -model «pc105» -option «grp:alt_shift_toggle»

Автозапуск этой строчки срабатывает только один раз, после перезагрузки компьютера, после повторного подключения, код почему то не выполняется. Однако, специально проверял файл «autostart», он отрабатывает, но вот именно эту строчку почему то не берёт. Если перезагрузить компьютер ещё раз, всё опять заработает только один раз. Что я упустил из виду, подскажите пожалуйста

Ответ на: комментарий от BOOBLIK

~/.config/lxsession/LXDE/autostart

lxsession вообще каталога нет, но я создал, и всё тоже самое

MuTbKa ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.