LINUX.ORG.RU
ФорумAdmin

Совершенно тупой вопрос про ядро

 ,


0

2

Тему можно удалить сразу как будет внятный ответ. Спросить по сути просто некого.

Есть Mint 17, недавно я на него накатил последнее ядро 3.14.1-031401-lowlatency из репы убунты, ядро ок, так как от того же по сути дистрибутива убунты, из той же ветки.

В репе с ядрами убунты есть пакеты ядра 3,15, которое я хочу поставить, но оно подписано как для utopic, а не для trusty. Вчера пришла обновляшка linux-firmware, там 3.15 поддерживается.

Вопрос — чем чревата установка ядра из другой ветки?


чем чревата установка ядра из другой ветки?

ничем
только лишь неодобрением собиральщиков дистрибутива

amorpher ★★★★★ ()

Есть Mint 17, недавно я на него накатил последнее ядро 3.14.1-031401-lowlatency из репы убунты
В репе с ядрами убунты есть пакеты ядра 3,15, которое я хочу поставить, но оно подписано как для utopic, а не для trusty

Бывший гентушник смотрит на это как на какие-то выдуманные проблемы.

mix_mix ★★★★★ ()

господа гусары, кто-нибудь, научите этого юношу ручной сборке ядра посредством теребления kernel-package.

darkenshvein ★★★★★ ()
Ответ на: комментарий от darkenshvein

думаю, собирать ядро имеет смысл только тогда, когда стоит какая-то конкретная задача, которую стоковое ядро выполнить не может, и приходится собирать самому. в моём случае таких специфических задач нет

emostar ()

Вопрос — чем чревата установка ядра из другой ветки?

ничем. Если у тебя не дебиан, ставить ядро отличное от дефолтного нет смысла

Xegai ★★ ()
Ответ на: комментарий от emostar

В таком случае для вас будет такой ответ: ставить ядро, которого нет в официальной ветке дистрибутива так же не имеет смысла, если вы не знаете зачем это нужно, а гонитесь лишь за циферками.

kostik87 ★★★★★ ()
Ответ на: комментарий от mix_mix

Ну тогда как гентушник говорю бывшему гентушнику: нечего тогда говорить про ядра и их версии, раз сам неосилил.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Что значит не осилил? Я на ней 6 лет сидел. Надоело потом просто.

mix_mix ★★★★★ ()

kernel ppa
не слушай еретиков с предложениями компилирования ядра

ubuntuawp ★★ ()
Ответ на: комментарий от Deleted

Хуже. Постарел я, захотелось комфорта и юзабилити, но с юниксовой консолью, когда нужно. Сменил ориентацию, в общем. А вот под линуксовое ведро до сих пор пишу модули, теперь лишь гоняю под виртуалочкой.

mix_mix ★★★★★ ()
Последнее исправление: mix_mix (всего исправлений: 2 )
Ответ на: комментарий от ados

Ну про консоль я в современном понимании. Эмулятор терминала, пакетный менеджер, zsh, coreutils, ssh, git etc. Всё как в линуксе, только без боли.

mix_mix ★★★★★ ()
Ответ на: комментарий от kostik87

мне нужно сжатие для zswap, которого нет в 14, а в 15 оно появилось. не помню как называется, гуглить надо. крутое, короче сжатие.

emostar ()

Бывают несовместимости иногда, но не при таком малом расхождении версий.

hibou ★★★★★ ()
Ответ на: комментарий от emostar

мне нужно сжатие для zswap, которого нет в 14, а в 15 оно появилось. не помню как называется, гуглить надо. крутое, короче сжатие.

Разве не в 3.11?

Zswap is a new feature as of v3.11 and interacts heavily with memory reclaim

wasted ()
Ответ на: комментарий от emostar

да, zswap появился в версии 3.11, но сжатие LZ4 не работало нигде, а в 3.15 его пообещали

http://www.phoronix.com/scan.php?page=news_item&px=MTQwODY - Здесь пишут, что в 3.11 добавлено.

http://www.pivpav.ru/post/154 - Здесь показывают, как это реализовать.

wasted ()
Ответ на: комментарий от wasted

последняя статья у меня даже в закладках есть. и при загрузке оно пишет что-то типа примерно: LZ4 compressing is not supported, switching to default compressing method

emostar ()
Ответ на: комментарий от emostar

Собрал на 3.14.9

1. Ядро

CONFIG_LZ4_COMPRESS=y

CONFIG_LZ4_DECOMPRESS=y

CONFIG_ZSWAP=y

2. Параметры:

zswap.enabled=1

zswap.compressor=lz4

zswap.max_pool_percent=80

3. Вывод:

[ 0.821262] zswap: loading zswap

[ 0.821505] zswap: using lz4 compressor

wasted ()

Обычно ничем. Можете обновляться.

lucentcode ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.