LINUX.ORG.RU
решено ФорумAdmin

Настройка i2p сайта

 , ,


0

2

Поднимаю i2p сайт на своем десктопе. Сайт работает на nginx +uwsgi+django. nginx и uwsgi настроил, локально по ip:port (127.0.0.1:8999) - сайт отлично работает, делаю i2p тунель на 127.0.0.1 порт 8999 - открываю по i2p адресу - вижу сообщение

Welcome to Nginx

и все. В логи эти запросы он не пишет.

Все перекопал, не могу найти проблему.

cat /etc/nginx/sites-enabled/example.i2p

server {
	listen   8999;# default_server; ## listen for ipv4; this line is default and implied
	#listen   [::]:80 default ipv6only=on; ## listen for ipv6

	root /work/htdocs/example.com;
	index index.html index.htm;
	client_max_body_size 60m;
	# Make site accessible from http://localhost/
	server_name localhost тут_короткийадрес.i2p тутадрес_b32.b32.i2p;
	                             
	access_log /var/log/nginx/example.access.log;
	error_log /var/log/nginx/example.error.log;
        
	location / { 
	uwsgi_pass unix://var/run/uwsgi/example.socket; 
	    include uwsgi_params;
	}
}

файл - /etc/nginx/sites-enabled/default вообще удалил, ничего не изменилось

★★★★★

Ответ на: комментарий от unikum

Пробовал и так и так, не помогает.

Сейчас так например - listen 127.0.0.1:8999 default_server;

эффект тот же.

pi11 ★★★★★ ()

Все оказалось на столько просто, что мне стало стыдно =)

оказывается после смены конфигурации тунеля в i2p его (тунель) нужно перезапускать (по крайней мере у меня после этого заработало).

pi11 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.