LINUX.ORG.RU

158
Всего сообщений: 6245

Запуск по умолчанию

Как заставить linux (ubuntu) запускаться только под определённым пользователем, например root с id 0? И ненадо писать про passwd, он только добавляет пользователя. Где указать это?

 ,

Megafox ()

Ubuntu Core (snappy) vs Ubuntu Server

Ubuntu Core, the smallest Ubuntu ever, the perfect host operating system for IoT devices and large-scale cloud container deployments

Какие в 2018 году есть преимущества первого над вторым для cloud container deployments?

 

magres ()

Проблема с установкой wine в ubuntu 17.10

Если я устанавливаю wine из wine репозитория, то при установке возникает ошибка:

dpkg: error processing archive /tmp/apt-dpkg-install-Jr9k6i/48-libsane1_1.0.27-1~experimental2ubuntu2.1_i386.deb (--unpack):
 trying to overwrite shared '/lib/udev/hwdb.d/20-sane.hwdb', which is different from other instances of package libsane1:i386
и wine работает нестабильно. То, что должно запускаться без проблем, не запускается.

Если устанавливать виртуальный пакет wine из репозитория ubuntu, такой ошибки нет, но и версия старая.

Поиск в сети выдает кучу похожих вопросов, но ни одного нормального ответа на них.

Кто-нибудь сталкивался с этим и как решить проблему?

 ,

denko ()

Как разбить диск в Linux Debian/Ubuntu в preseed?

Согласно официальному мануалу (https://www.debian.org/releases/stable/amd64/apbs04.html.en) у нас есть в preseed:

#d-i partman-auto/expert_recipe string                         \
#      boot-root ::                                            \
#              40 50 100 ext3                                  \
#                      $primary{ } $bootable{ }                \
#                      method{ format } format{ }              \
#                      use_filesystem{ } filesystem{ ext3 }    \
#                      mountpoint{ /boot }                     \
#              .                                               \
#              500 10000 1000000000 ext3                       \
#                      method{ format } format{ }              \
#                      use_filesystem{ } filesystem{ ext3 }    \
#                      mountpoint{ / }                         \
#              .                                               \
#              64 512 300% linux-swap                          \
#                      method{ swap } format{ }                \
#              .

Ок, но если мне нужно всего, создать первичный раздел размером 30 GB и далее за ним же, создать SWAP размером 2 GB. Как мне поступить в данном случае ? Я почитав документацию немного не понял, там вроде идет максимальное и минимальное значение. Может быть Вы сталкивались с этим ? Спасибо.

 , , , ,

piduna ()

Получение данных с демона

Добрый день, пишу сюда впервые. На данный момент пишу магистерскую работу. Собственно возник вопрос , ответ на который , возможно , укажет мне направление.

Дано: 2 ПК + свитч под управлением ОС типа Linux (OpenIL(Open Industrial Linux) v1.0)). На 2х ПК и на свитче стоит lldpd и запущен он как демон, т.е. железо понимает пакеты LLDP и может обнаруживать друг друга по запросу из терминала. Данный демон имеет свой CLI (lldpcli) и по запросу «show neighbors» или «show chassis» выдаёт что-то подобное:

Chassis:     
  ChassisID:    mac 18:db:f2:3b:ba:29
  SysName:      alex-Latitude-E5570
  SysDescr:     Ubuntu 17.04 Linux 4.10.0-42-generic #46-Ubuntu SMP Mon Dec 4 14:36:05 UTC 2017 i686
  TTL:          120
  MgmtIP:       10.22.1.217
  MgmtIP:       fe80::9648:fbb:be4f:930d
  Capability:   Bridge, off
  Capability:   Router, on
  Capability:   Wlan, on
  Capability:   Station, off

Задача состоит в том , чтобы создать приложение, которое будет данную инфу собирать в какой-то файл и в перспективе отображать на web-сервисе (локальном). Вопрос: «На какие языки (java / python) стоит обратить внимание, чтобы можно было корректно работать с данной информацией.

P.S. не судите строго студента, с этим всем работаю впервые, поэтому вопросы от меня весьма „тупые“ и есть куда развиваться (надеюсь)

 , ,

tampap ()

Proxy-сервер на базе squid за роутером

Исходные данные:

  • IP-адрес на WAN-порту маршрутизатора: 10.223.71.15
  • IP-адрес самого шлюза: 192.168.0.1
  • IP-адрес интерфейса сервера (eth0), где необходимо поднять squid: 192.168.0.46
  • Внешний IP-адрес, выданный провайдером, вида: 176.*.*.*

Была задача поднять ipv6-прокси на основе туннеля ipv6-ipv4, чтобы в дальнейшем использовать их в формате: 176.*.*.*:30001-*****. Само туннелирование настроено и работает, а вот с поднятием squid возникла проблема.

Изначально ifconfig выглядел так:

eth0      Link encap:Ethernet  HWaddr 00:1d:60:e0:58:3a  
          inet addr:192.168.0.46  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fd01::21d:60ff:fee0:583a/64 Scope:Общий
          inet6 addr: fe80::21d:60ff:fee0:583a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7639426 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4122592 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:10389315184 (10.3 GB)  TX bytes:648579796 (648.5 MB)

he-ipv6   Link encap:IPv6-in-IPv4  
          inet6 addr: 2001:470:*:*:*:*:*:*/64 Scope:Общий
          inet6 addr: 2001:470:*:*:*:*:*:*/64 Scope:Общий
          и т.д.

squid.conf так:

acl localnet src 192.168.0.0/24

http_access allow all

http_port 176.*.*.*:30000 name=p30000
http_port 176.*.*.*:30001 name=p30001
http_port 176.*.*.*:30002 name=p30002
http_port 176.*.*.*:30003 name=p30003
http_port 176.*.*.*:30004 name=p30004

Но при попытке стартануть squid в логи сыпалось следующее:

commBind: Cannot bind socket FD 11 to 176.*.*.*:30000: (99) Cannot assign requested address
При замене 176.*.*.* на 192.168.0.46 или на 127.0.0.1 прокси сервер начинал работать нормально, естественно только из локальной сети, в логах ошибок больше не было.

Повесил этот внешний адрес на eth0, ifconfig стал следующим:

eth0      Link encap:Ethernet  HWaddr 00:1d:60:e0:58:3a  
          inet addr:192.168.0.46  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fd01::21d:60ff:fee0:583a/64 Scope:Общий
          inet6 addr: fe80::21d:60ff:fee0:583a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7639426 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4122592 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:10389315184 (10.3 GB)  TX bytes:648579796 (648.5 MB)
          Interrupt:17 

eth0:1    Link encap:Ethernet  HWaddr 00:1d:60:e0:58:3a  
          inet addr:176.*.*.*  Bcast:176.113.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:17 

he-ipv6   Link encap:IPv6-in-IPv4  
          inet6 addr: 2001:470:*:*:*:*:*:*/64 Scope:Общий
          inet6 addr: 2001:470:*:*:*:*:*:*/64 Scope:Общий

Теперь прокси работает и при использовании 176.*.*.*:30001 в браузере, то есть через внешний айпи, но только если проверять с того же самого сервера. Извне и из локальной сети происходит connection timed out. На роутере порты проброшены, серверу назначена статика 192.168.0.46, подозреваю, что дело где-то в iptables.

/etc/network/interfaces:

auto lo
iface lo inet loopback

iface eth0 inet dhcp
auto eth0

auto he-ipv6
iface he-ipv6 inet6 v4tunnel
        address 2001:470:70:f06::2
        netmask 64
        endpoint 216.66.80.162
        ttl 255
        up ip -6 route add default dev he-ipv6
        down ip -6 route del default dev he-ipv6

Ubuntu 14.04

В какую сторону стоит копать для решения проблемы? Заранее спасибо.

 , , ,

HellFire0 ()

ubuntu, lubuntu (10.04) проблемы с окнами и панелями

ubuntu 10.04 (гном2)- после загрузки пропадает правая часть основной панели на рабочем столе, помогает каждый раз ее перемещать влево или впрво или вверх так ввостанавливается, что очень неудобно, подскажите можно ли это починить?

поставил лубунту-дестоп на убунту 10.04 теперь активное окно теряют фокус на 0,5 секунды, выглядит это как постоянно мигает заголовок на активном окне, работать невозможно. Можно ли починить?

 , ,

deepforest ()

Черный квадрат в Ubuntu 16.04. Это што такое???

Итак, раньше Убунта летала, как ягодка, но в последнее время, стала твориться какая-то аномалия. Уже даже пару раз переустанавливал и всё равно, через несколько дней появляется этот черный квадрат Малевича, после загрузки системы

Фото: https://hostingkartinok.com/show-image.php?id=4d11d98c7c3a48c6cb4394040b212304

На соседнем диске так же установлена Виндовс 8, но когда я захожу на этот диск из под убунты, то появляется ошибка открытия диска(может есть на диске какой-то битый файл, из-за которого убунту не может нормально открыть этот диск). Может от этого черный квадрат?

Ставятся свежая версия убунты с последними обновлениями

 ,

NetSurf ()

Как правильно сделать бекпорт usb-modeswitch из Debian Testing в Ubuntu Xenial?

Суть в том, что у меня есть 4g мопед. Он прошит в Hilink (Hostless Modem с автоматическим переключением в рабочую композицию CDC). На нескольких компах со свежем арчем, как и на венде, я просто втыкаю его в юсб, появляется сетевая карта, за несколько секунд к ней подключается кабель и всё работает.
Но не на ARM версии Ubuntu Xenial на моей Raspberry Pi. Там бесконечно идёт подключение, затем отключается итд. Причину я нашёл (кажется): https://bugs.launchpad.net/ubuntu/ source/usb-modeswitch/ bug/1607001
И человек сделал backport is Ubuntu Zesty в Xenial пакета usb-modeswitch 2.4 (где вроде и должно быть исправлено). Проблема в том, что на ARM нет Ubuntu Zesty (либо Testing), а самый свежий - Xenial.
Но посмотрев список файлов Raspbian Testing (wget http://archive.raspbian.org/raspbian/dists/testing/main/binary-armhf/Packages), я нашёл там

Package: usb-modeswitch
Version: 2.5.2+repack0-1
Depends: libc6 (>= 2.4), libjim0.77 (>= 0.72), libusb-1.0-0 (>= 2:1.0.9), usb-modeswitch-data (>= 20140529)
Filename: pool/main/u/usb-modeswitch/usb-modeswitch_2.5.2+repack0-1_armhf.deb
А это его зависимость из того же репа:
Package: libc6
Source: glibc
Version: 2.26-2+rpi1
Получается, в репах даже свои зависимости не решены?
И как тогда установить?

 , ,

fehhner ()

сборка php 5.3 на ubuntu

Клиент попросил собрать php 5.3.29 на ubuntu 16.04.3

./configure --prefix=/opt/php-5.3.29 --with-config-file-path=/opt/php-5.3.29 --with-apxs2=/usr/bin/apxs --with-curl --with-openssl --enable-maintainer-zts --with-xmlrpc --with-gd --with-imap --with-ldap --with-mcrypt --with-mcrypt --enable-bcmath --with-gettext --with-mysql --with-xsl --enable-soap --enable-mbstring --enable-zip --with-kerberos --with-imap-ssl --with-pcre-regex --with-pdo-mysql --enable-exif --enable-mbregex --enable-sysvshm --enable-sysvsem --with-zlib --with-bz2 --with-mcrypt --enable-calendar --enable-cli --with-readline --with-tidy --enable-gd-native-ttf --with-freetype-dir=/usr/lib --with-gd --with-jpeg-dir=/usr/lib --enable-sockets --with-mysqli=mysqlnd

делаю make

/usr/bin/ld: /usr/local/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32 against `.data' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/libssl.a: error adding symbols: Bad value
collect2: error: ld returned 1 exit status
Makefile:148: recipe for target 'libphp5.la' failed
make: *** [libphp5.la] Error 1

если я делаю

./configure shared --prefix=/opt/php-5.3.29 --with-config-file-path=/opt/php-5.3.29 --with-apxs2=/usr/bin/apxs --with-curl --with-openssl --enable-maintainer-zts --with-xmlrpc --with-gd --with-imap --with-ldap --with-mcrypt --with-mcrypt --enable-bcmath --with-gettext --with-mysql --with-xsl --enable-soap --enable-mbstring --enable-zip --with-kerberos --with-imap-ssl --with-pcre-regex --with-pdo-mysql --enable-exif --enable-mbregex --enable-sysvshm --enable-sysvsem --with-zlib --with-bz2 --with-mcrypt --enable-calendar --enable-cli --with-readline --with-tidy --enable-gd-native-ttf --with-freetype-dir=/usr/lib --with-gd --with-jpeg-dir=/usr/lib --enable-sockets --with-mysqli=mysqlnd
потом делаю make, то ошибки нет, но когда делаю make install
nstalling PHP SAPI module:       apache2handler
/usr/share/apache2/build/instdso.sh SH_LIBTOOL='/usr/share/apr-1.0/build/libtool' libphp5.la /usr/lib/apache2/modules
/usr/share/apr-1.0/build/libtool --mode=install install libphp5.la /usr/lib/apache2/modules/
libtool: install: install .libs/libphp5.lai /usr/lib/apache2/modules/libphp5.la
libtool: install: install .libs/libphp5.a /usr/lib/apache2/modules/libphp5.a
libtool: install: chmod 644 /usr/lib/apache2/modules/libphp5.a
libtool: install: x86_64-linux-gnu-ranlib /usr/lib/apache2/modules/libphp5.a
libtool: install: warning: remember to run `libtool --finish /opt/source/php-5.3.29/libs'
Warning!  dlname not found in /usr/lib/apache2/modules/libphp5.la.
Assuming installing a .so rather than a libtool archive.
chmod 644 /usr/lib/apache2/modules/libphp5.so
chmod: cannot access '/usr/lib/apache2/modules/libphp5.so': No such file or directory
apxs:Error: Command failed with rc=65536
.
Makefile:157: recipe for target 'install-sapi' failed
make: *** [install-sapi] Error 1

как можно исправить ошибки в 1 или во 2 случаях?

 , ,

Garcia ()

Каким образом система выбирает репозитории, если пакет находится в нескольких из них?

Linux Mint использует свой собственный репозиторий и убунтовский. Как я понимаю, некоторые пакеты находятся в обоих, при этом с одинаковыми версиями, но с разными дефолтными настройками. Каким образом установщик понимает, откуда ему такой пакет дергать, и можно ли это поведение поменять для конкретного пакета?

В частности я хотел бы в минте иметь убунтовскую версию Firefox'а, так как гуглопоиск в минтовой лисе испорчен (не работают поисковые предположения), и похоже считается что это не баг, а фича, так как фикс проблемы только усложнился при переходе с 17 на 18 версию минта.

Ну или может есть варианты окончательно и бесповоротно пофиксить гугл в минтовом Firefox, чтобы еще и с обновлениями не ломался?

 , ,

STinger ()

А вы уже ставили последнее паникующее обновление ядра?

А мне уже пришло, родимое, 3.13.0-140, с тем самым патчем видимо, и успешно паникует на старте.

 ,

mm3 ()

Проблемы с вебкамерой в Ubuntu 16.04 и Mint 18.3

Камера logitech c525 перестала работать как камера (микрофон работает) в Mint18.3 KDE и Ubuntu 16.04. В win7 работает как раньше. Где-то в последний месяц это произошло. Обнаружил, когда скайп включил. Какое-то обновление системы могло повлиять? И как вернуть все назад?:)

 ,

ArtemQ ()

Вопросы по Ubuquity UniFi и switches

Всем привет,

Вопрос 1: Есть контроллер UniFi на убунте, который при каждом обновлении теряет пользователей веб-морды в mariadb. Куда копать и как бороться? Пока что ничего существенного не нагуглил.

Вопрос 2: Слышал про свитчи Ubuquity:

https://www.ubnt.com/unifi-switching/unifi-switch-16-xg/

https://www.ubnt.com/unifi-switching/unifi-switch-16-150w/

https://www.ubnt.com/unifi-switching/unifi-switch-2448/

Кто имел опыт? Чем хороши относительно других (HP, или D-Link, например)?

 ,

zuxla ()

Ubuntu обновляет пакеты как-то странно.

Кто-нибудь заметил в Ubuntu такое странное поведение, когда обновляешь пакеты через командную строку:

# apt-get update && apt-get upgrade
, пакеты обновляются, но, сразу после обновления, появляется гуёвое окно с сообщением, что есть обновления и предлагает опять обновить, просит пароль и т.д. Вот пример из лога по последнему такому случаю, где запись с временем 13:23:41 это обновление из командной строки, а 13:30:12 это всплыло гуёвое окно.
$ cat /var/log/apt/history.log
...
Start-Date: 2018-01-17  13:23:01
Commandline: apt-get upgrade
Requested-By: barin (1000)
Upgrade: poppler-utils:amd64 (0.41.0-0ubuntu1.5, 0.41.0-0ubuntu1.6), intel-microcode:amd64 (3.20170707.1, 3.20180108.0~ubuntu16.04.2), transmission-common:amd64 (2.84-3ubuntu3, 2.84-3ubuntu3.1), linux-libc-dev:amd64 (4.4.0-104.127, 4.4.0-109.132), ruby2.3:amd64 (2.3.1-2~16.04.4, 2.3.1-2~16.04.5), gir1.2-gdkpixbuf-2.0:amd64 (2.32.2-1ubuntu1.3, 2.32.2-1ubuntu1.4), libgdk-pixbuf2.0-0:amd64 (2.32.2-1ubuntu1.3, 2.32.2-1ubuntu1.4), skypeforlinux:amd64 (8.11.0.4, 8.13.0.2), smplayer:amd64 (17.12.0-1~xenial1, 18.1.0-1~xenial1), libruby2.3:amd64 (2.3.1-2~16.04.4, 2.3.1-2~16.04.5), smtube:amd64 (17.5.0-1~xenial1, 18.1.0-1~xenial1), distro-info-data:amd64 (0.28ubuntu0.6, 0.28ubuntu0.7), libwebkit2gtk-4.0-37:amd64 (2.18.4-0ubuntu0.16.04.1, 2.18.5-0ubuntu0.16.04.1), libgdk-pixbuf2.0-common:amd64 (2.32.2-1ubuntu1.3, 2.32.2-1ubuntu1.4), libgdk-pixbuf2.0-dev:amd64 (2.32.2-1ubuntu1.3, 2.32.2-1ubuntu1.4), gir1.2-webkit2-4.0:amd64 (2.18.4-0ubuntu0.16.04.1, 2.18.5-0ubuntu0.16.04.1), transmission-gtk:amd64 (2.84-3ubuntu3, 2.84-3ubuntu3.1), linux-tools-common:amd64 (4.4.0-104.127, 4.4.0-109.132), libpoppler-glib8:amd64 (0.41.0-0ubuntu1.5, 0.41.0-0ubuntu1.6), libpoppler58:amd64 (0.41.0-0ubuntu1.5, 0.41.0-0ubuntu1.6), libjavascriptcoregtk-4.0-18:amd64 (2.18.4-0ubuntu0.16.04.1, 2.18.5-0ubuntu0.16.04.1), ubuntu-mono:amd64 (14.04+16.04.20161024-0ubuntu1, 14.04+16.04.20171116-0ubuntu1), libwebkit2gtk-4.0-37-gtk2:amd64 (2.18.4-0ubuntu0.16.04.1, 2.18.5-0ubuntu0.16.04.1), gir1.2-javascriptcoregtk-4.0:amd64 (2.18.4-0ubuntu0.16.04.1, 2.18.5-0ubuntu0.16.04.1)
End-Date: 2018-01-17  13:23:41

Start-Date: 2018-01-17  13:28:58
Commandline: aptdaemon role='role-commit-packages' sender=':1.53'
Install: linux-image-4.13.0-25-generic:amd64 (4.13.0-25.29~16.04.2, automatic), linux-headers-4.13.0-25:amd64 (4.13.0-25.29~16.04.2, automatic), linux-image-extra-4.13.0-25-generic:amd64 (4.13.0-25.29~16.04.2, automatic), linux-headers-4.13.0-25-generic:amd64 (4.13.0-25.29~16.04.2, automatic)
Upgrade: linux-generic-hwe-16.04-edge:amd64 (4.13.0.21.27, 4.13.0.25.31), linux-headers-generic-hwe-16.04-edge:amd64 (4.13.0.21.27, 4.13.0.25.31), linux-image-generic-hwe-16.04-edge:amd64 (4.13.0.21.27, 4.13.0.25.31)
End-Date: 2018-01-17  13:30:12
...
Подскажите о Гуру, какого х** это я где-то галочку поставил или это новшество Ubuntu и как его отключить?
Почему команда apt-get upgrade обновила не все установленные пакеты, а часть оставила обновлять какому-то aptdaemon-у?
P.s.: раньше такого не было!

 , ,

superuser ()

[РЕШЕНО] Ubuntu 18.04 на x86

Узнавши из новостей этого сайта, то, что новый Ubuntu 18.04 не будет поддерживать 32-разрядные процессоры.

Мой 4-й пенек не одобряет.

И так вопрос, раз Ubuntu 18.04 не поддерживает x86, то что мне делать?

Может есть какие-то Linux альтернативы Ubuntu с постоянной поддержкой?

 , ,

hugonote ()

Linux всегда был такой глючный?

Поставил родителям на ноут Убунту после ужаса вин10. Ожидал увидеть стабильную систему. Я в шоке конечно. Разделю свое недоумение на две категории: глюки и возможности интерфейса.

1. Глюки. Поставил Оперу, открываю: а указатель мыши в виде часов и ниче не помогает включая перезапуск приложения. Тока перезапуск ОС помог. Захотел сделать настроить им автосмену обоев; Куда там. Пришлось скачивать отдельную прогу Wallch. Она вообще постоянно вылетает. Это как вообще понимать? На винду плевались с ее обновлениями,заторможенностью/, но даже там такой херни не было.

2. Возможности. Какой дебил ограничил возможность сортировать в наутилусе порядок папок в боковом меню. Их перетаскивать вверх вниз нельзя! Автосмены обоев у Убунте вообще нет. Они там совсем головой тронулись в маниакальном стремление все упростить?

Тока не надо говорить что это Убунта! gnome shell на многих дистрах, на федоре например! а классический гном унылое говно. а кеды перегружены. хотелось бы нормальный простой десктоп с адекватными возможностями но не перегруженный. а такого нет! либо адский примтив либо кеды!

 

Anatuz ()

Поставлю родителям на комп Убунту. Можно ли в штатном загрузчике сделать так, чтобы по умолчанию сразу грузилась Убунта без меню выбора?

А например, при нажатии сочетания клавиш уже выскакивала менюшка, где можно загрузить Винду. Как это сделать? Корчое чтобв никто не знал что на компе еще и винда установлена.

 ,

Anatuz ()

Обновление тонкого клиента 1С

Добрый день, есть такие кто победил проблему установки тонкого клиента 1С в Linux? При обновлении выдает ошибку.
В Ubuntu:

dpkg: относительно .../1c-enterprise83-thin-client_8.3.11-2924_amd64.deb, содержащего 1c-enterprise83-thin-client:
 1c-enterprise83-thin-client конфликтует с 1c-enterprise83-common
  1c-enterprise83-common (версия 8.3.11-2924) существует и распакован, но не настроен.
dpkg: не удалось обработать параметр ./1c-enterprise83-thin-client_8.3.11-2924_amd64.deb (--install):
 конфликт пакетов -- 1c-enterprise83-thin-client не будет установлен
В Fedora
Ошибка: 
 Проблема: package 1C_Enterprise83-thin-client-8.3.11-2924.x86_64 conflicts with 1C_Enterprise83-common provided by 1C_Enterprise83-common-8.3.11-2924.x86_64
  - conflicting requests
С другими пакетами проблем нет, но мне нужен именно тонкий клиент.

Решение: тут

 , ,

StellzZz ()

Не могу использовать sudo

Пытаюсь использовать sudo, но вижу ошибку:

sudo: effective uid is not 0, is sudo installed setuid root

Я уже всё перепробывал, но не помогает. Как её исправить? Sudo я установил архиватором потому, что у моего урезанного linux нет ничего для этого. Как выставить правильные разрешения? Или что ещё ей надо? Ubuntu 14.04 LTS, но просто урезана до нельзя. Доступа к команде su не имею, так как её можно запустить только в терминале, а графический интерфейс настроить не могу пока не получу sudo, поэтому использую скрипты.

 ,

Megafox ()