LINUX.ORG.RU

4
Всего сообщений: 279

Мерцающий экран ноутбука при подключении HDMI

Здравствуйте! Столкнулся с такой проблемой:

Дано: ноутбук с установленной ubuntu 20.04 Подключенный по HDMI второй монитор

Что случилось: Всё работало прекрасно, до недавнего времени. Обнаружил этот глюк после того как оставил ноут на ночь включенным. При выходе из блокировки экрана монитор работает так как надо, а экран ноута мерцает (имею в виду не рябь, а полностью темный экран, который периодически вспыхивает и гаснет). Если подключить монитор к выключенному ноуту, а потом ноут включить, то все работает как надо, но до первой блокировки экрана.

Кабель, разъемы проверил - все ок.

С чем это может быть связано? Как лечить?

 , ,

coizar ()

Подключить внешний монитор

Привет. Проблема следующая - есть intel проц c интегрированной видеокартой GMA X4500HD, используемый драйвер - i915. Всё норм за исключением одной боли - при подключении внешнего монитора через HDMI он работает очень криво (постоянно какие-то помехи на картинке, периодически сигнал вовсе пропадает - 5 сек показывает, 3 секунды нет). При этом до загрузки ядра (в биосе, в меню загрузчика) с картинкой всё норм и нет никаких проблем пока ядро не стартанёт (т.е проблема возникает до всяких иксов и вяленных), также всё нормально работало под виндой.

Пробовал включить заливку firmware на карту (оказалось, что не поддерживается), потихоньку включаю/выключаю опции драйвера i915 наугад, пока эффекта нет.

Может кто-то уже боролся с таким? Куда копать?

 , ,

kvpfs ()

Запуск внешнего монитора на дискретной видеокарте Debian 10

Всем привет. Может кто подсказать, как сделать, чтобы HDMI порт на ноуте автоматически работал на дискретной видеокарте?

Ноутбук HP 15-ay002ur, Debian 10, интегрированная видеокарта Intel® HD Graphics 520, дискретная видеокарта AMD Radeon™ R5 M430

Из-за 2к монитора, проц вечно загружен.

 ,

TheLinuxUser ()

2 вопроса: Audio через HDMI и Video на Hyperv_drm

Здравствуйте.

У меня кончились мысли.

Сначала по поводу Проблемы с AMDGPU (комментарий) вот этого комментария - стал смотреть как дела в других дистрибутивах, и обнаружил что в VoidLinux нормально всё играет в телевизоре без подмены EDID. В ArchLinux, например, так и не играет. Смотрел в cat /proc/asound/card1/eld\#0.3 и в pactl list sinks на обоих, сравнивал - никакой разницы не вижу. Но разница должна же где-то быть. Где ещё искать места почему в Void звук слышен всегда, а в Arch только при подмене EDID?

-----------------------

Потом практически ровно наоборот - линуксы у меня умеют, как с железа стартовать, так и под Hyper-V. Начиная с 5.14 в Linux добавили hyperv_drm и он прекрасен. В ArchLinux всё замечательно теперь показывает без hyperv_fb. Не могу заставить Void делать также. Сравнивал Xorg.0.log на обеих - в ArchLinux есть такие строчки:

[     4.399] (==) Automatically adding devices
[     4.399] (==) Automatically enabling devices
[     4.399] (==) Automatically adding GPU devices
[     4.399] (==) Automatically binding GPU devices
а в Void последней строчки нет. Что это за binding? Как заставить X в Void тоже «Automatically binding»? Второе большое отличие - Void ругается на open /dev/dri/card0: No such file or directory. А с этим как бороться осознано? В интернетах решения уровня «переустановил пакет такой-то и заработало».

Может есть у кого какие-нибудь комментарии по обоим квестам?

 , , , ,

Toxo2 ()

Проблемы с AMDGPU

Итак, Athlon 5370 со встроеным видеоядром Sea Islands. Драйвер - Amdgpu.

VGA - все работает отлично, хоть на Radeon, хоть на Amdgpu.

Подключаю HDMI и начинаются проблемы. Картинка шикарная (прямо не понимаю как раньше жил без HDMI) звука нет. C параметром amdgpu.dc=1 звук появляется, а вот изображение летит к чертям. Сглаживания - ноль, вместо шрифтов - лесенки, контрастность такая, что не видно разницы между черным и серым цветом. Артефактов нет, все грузится и работает как обычно.

А теперь самая мякотка. Скриншот приложить не могу, потому что скриншот всего этого безобразия выглядит НОРМАЛЬНО! То есть, вообще никакой разницы с amdgpu.dc=0

Radeon по HDMI рисует такой же ужас.

Куда копать? Есть заклинания чтоб включить звук, не включая DC? Настройки моника не помогают вообще никак. Да и не моник это, а телек.

P.S. Gnome, Wayland.

 , , ,

qtm ()

Расскажите про HDMI сплиттеры

Ситуация: на видеокарте есть только один HDMI и нет VGA. Нужно подключить два монитора по HDMI, ибо если подключить один из мониторов через конвертер DVI-D/DP в VGA, то получится говно (даже не все настройки монитора доступны, лул). Читаю про HDMI сплиттеры. Получится ли с ними подключить два монитора, будто они подключены к двум разным портам видяхи, или сплиттеры вообще не для этого? Прям ничего крутого мне не надо, никаких 4к у меня нет, всего лишь два FullHD монитора, один на 60 Гц, другой на 75 (вот с этим тоже конвертер не справляется, выдавая только 60).

UPD: нашёл кабель DP -> HDMI.

 ,

LikeABoss ()

Ноутбук с HDMI внешним монитором. Мигание монитора.

Имеется ноутбук с HDMI выходом для внешнего монитора. Не имеет значения ни модель ни конфигурация. На самом деле проверено на 6 разных ноутбуках. На ноутбуке установлен Linux. Дистрибутив не имеет занчения. Важно - ядро, не выше 4.19 Подключаем к ноутбуку внешний монитор. Включаем ноутбук. Авторизируемся в системе и пользуемся без проблем. Все отлично.

Второй момент. На этом же ноутбуке, на этом же дистрибутиве, но с ядром выше 4.19, в частности 5.х Подключаем к ноутбуку внешний монитор. Включаем ноутбук. На дисплее ноутбука (делее - дисплей) - процесс загрузки. Далее дисплей отключается и через секунду включается, с ним включается и внешний монитор (далее - монитор). Появляется DM. Пытаемся ввести данные для авторизации и... дисплей отключается и монитор отключается, через секунду дисплей включается и монитор включается. Вводим логин и... дисплей отключается и монитор отключается, через секунду дисплей включается и монитор включается. Вводим пароль и... дисплей отключается и монитор отключается, через секунду дисплей включается и монитор включается. Жмем Enter и мы должны быть на рабочем столе, но нет. Дисплей отключается и монитор отключается, через секунду дисплей включается и монитор включается и мы на рабочем столе. И тут через секунду дисплей отключается и монитор отключается, через секунду дисплей включается и монитор включается. Все можно работать. Но главное - не трогать регулятор громкости и не включать видео. Если же попробовать изменить громкость - дисплей отключается и монитор отключается, через секунду дисплей включается и монитор включается и дальше все нормально. Если же включить видос с ютюбчика (или не с ютюбчика) - дисплей отключается и монитор отключается, через секунду дисплей включается и монитор включается и дальше все нормально. Если кликнуть по другому видосу - дисплей отключается и монитор отключается, через секунду дисплей включается и монитор включается и дальше все нормально. Жесть. Проверено на 6 разных ноутбуках, на 3 разных дистрибутивах, на 2 разных мониторах и разных HDMI кабелях. Дело в ядре 5.х Кто виноват и что делать?

 , , , ,

e50e60 ()

Переключение монитора и USB между двумя компьютерами

Имеется один монитор и одно USB подключение общего адаптера беспроводных мыши и клавиатуры. Требуется переключать их между двумя компьютерами. Монитор умеет переключаться лишь между двумя источниками видео сигнала, а USB переключать не умеет. Приходится физически перебрасывать USB адаптер мыши и клавиатуры между компьютерами.

Ищу устройство, которое умеет это делать само, причём необязательно при помощи хитрых сочетаний клавиш, можно и кнопкой. Требуется поддержка как display port, так и hdmi. На крайний случай может подойти переключалка лишь USB. Что вы можете посоветовать?

 , , ,

hummer ()

Черный экран на мониторе при подключении по HDMI

Ноут с двумя графиками, подключил по хдми к монику, он говорит связь есть, но картинок и звуков нема. xrandr -q не определяет. Телепаты и ванги, созываю вас

 , , ,

NanoXRV ()

2k на пассивном переходнике dvi>hdmi?

@Zubok Прошу прощения за беспокойство. Не мог бы ты подсказать? Чисто физически или теоретически может ли пассивный переходник dvi>hdmi выдать 2k разрешение несмотря на то, что распиновка у переходника duallink? Кмк нет, или я неправ?

 , ,

Procenko ()

usb ->hdmi адаптер

Добрый день.
купил юсб док вот такой

Пытаюсь вывести с него, с ubuntu видео на монитор.

lsusb пишет

Bus 003 Device 008: ID 25a4:9311
Bus 003 Device 007: ID 214b:7250 USB2.0 HUB

подскажите, как завести

 , ,

darkenshvein ()

Запуск внешнего монитора на дискретной видеокарте Debian 10

Всем привет. Может кто подсказать, как сделать, чтобы HDMI порт на ноуте автоматически работал на дискретной видеокарте?

Ноутбук HP 15-ay002ur, Debian 10, интегрированная видеокарта Intel® HD Graphics 520, дискретная видеокарта AMD Radeon™ R5 M430

 ,

TheLinuxUser ()

нет звука по HDMI

alsactl version 1.1.5 Lenovo L340 15iwl opensuse 15.2 ядро 5.3, но уже пробовала 5.10, сусю 15.3, дебиян пробовала, убунты там всякие… нигде не работает, хотя с того же самого диска загружаюсь на hp 250 G5 и тот же самый монитор уже определяется как hdmi sound output.

в pavucontrol, настройках кде и т п видны только динамики самого ноута и блютуз гарнитура, если она подключена. Но! скрин на Gdrive некоторые программы, у которых есть функция выбора источника звука, могут собственно выводить его в HDMI, то есть он реально работает, но почему-то вывести через него все приложения нельзя.

‘aplay -l’ https://pastebin.com/1sHpUrUh тут виден только выход на динамики ноута

‘pacmd list-sinks’ https://pastebin.com/WQrSr1Eh аналогично

но на скрине видно, vital почему-то выход на hdmi видит.

 , ,

fadi1s ()

Debian 11. Lenovo Legion 5. Intel + NVidia.

Я являюсь владельцем ноутбука Lenovo Legion 5 (2020 года).

Конфигурация железа:
1) CPU - Core i7-10750H
2) GPU1 - Intel UHD (встроенная)
3) GPU2 - NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] (дискретная)
4) В Биосе есть два режима работы видео: гибридный и дискретный. Выставлен гибридный режим (встроенная + дискретная). В дискретном режиме внешний начинает работать. Но нужен именно гибридный режим
5) Внутренний экран в гибридном режиме работает на втроенной карте. HDMI выход на внешний монитор выводит изображение только через дискретную карту, вне зависимости от режима.

На данный ноутбук устанавливаю дистрибутив «Debian 11 KDE with non-free» (debian-live-11.0.0-amd64-kde+nonfree.iso), стандартный тоже пробовал.

Проблема:
Не отображается изображение на внешнем мониторе (HDMI), когда запущена Debian (внутренний работает).

Хотя при загрузке на несколько секунд показывается дебиановский загрузочный экран на обоих экранах (встроенном и внешнем).
Если установить дрова Nvidia, то перестанет работать встроенный экран, начнет работать внешний.
Еще пробовал ставить Manjaro 21.07 KDE.
В ней оба экрана работают, стоят какие-то open source драйвера: video-linux, даже не обязательно устанавливать NVidia драйвера.
Вот как выглядят установленные дрова в Manjaro (картинка взята для примера): Картинка

Вопрос:
Как заставить работать Debian 11 c внешним монитором, при том чтобы работал и встроенный?

Похожая проблема:
Похожая проблема: ссылка. Но там на Manjaro, на Manjaro у меня работает. И там решение написано скомкано.

P.S. Я в Linux неопытный пользователь пока еще (по крайней мере в области драйверов и железа в линукс).

 , , ,

vibondarenko ()

ARM64 и DTB, редактирование DTS, как добиться звука по HDMI?

Приветствую! Есть кто разбирается в этом? На нескольких одноплатниках проблема одна-не знаю как направить звук по HDMI. Не определяется аудио на дтб из линукс исходниках, что ни делал.

Может про это есть где гайды? Или кто шарит куда что писать в дтс?

Любой инфе буду рад.

 , ,

burato ()

NVIDIA. Opensuse Tumbleweed. Монитор плюс Телевизор.

Всех приветствую! Есть ПК, в нем видеокарта Nvidia 1070 ti. К ней подключен монитор по Display Port, все работает нормально. При подключении телевизора по HDMI, начинаются чудеса:

  • Телевизор говорит, что нет сигнала.
  • Телевизор показывает изображение, но гаснет с рандомной(от 1 сек до 5) частотой бесконечно.
  • Телевизор показывает изображение, но гаснет с рандомной(от 1 сек до 5) частотой и потом говорит нет сигнала.

Драйвреа установлены из репозитория проприетарные - без всяких шаманств. xorg.conf - руками тоже «не щупанный» был, потом пытался ковырять, но все откатил до дефолта. Кабель HDMI проверен на другом устройстве. Телевизор тоже полностью исправен и с других устройств по HDMI все показывает. Разрешение что на мониторе, что на телевизоре одинаковое, частота обновления тоже.

Причем такое поведение и во время загрузки, до запуска иксов. Может кто сталкивался, в чем может быть причина такого поведения?

 , ,

XtouRusX ()

Не работает звук по hdmi arch-linux based distr

Всем привет, не могу заставить работать звук через hdmi, стоит pipewire, пробовал также pavucontrol, когда выбираю hdmi в устройствах звука, звука нет совсем, тоесть при подключении ТВ у меня либо звук через ноутбук идет, либо его совсем нету, помогите пожалуйста пофиксить это…

 , , , ,

fmx1k ()

Kubuntu самовольно переключает аудио-выходы

Доброго времени суток уважаемому Сообществу.

Установил свежую Kubuntu LTSB, подключил к компу (встроенная видяха) телевизор через HDMI. Всё работает. Но с разной периодичностью, система самовольно переключает аудио-вывод с HDMI на встроенные порты материнки.

Указывал в настройках микшера «Использовать только это устройство для вывода звука». Не помогает.

Как победить это?

Заранее благодарен за помощь.

 , ,

kuguar ()

При установки драйверов nvidia пропадают звуковые устройства HDMI

Добрый день!

Являюсь начинающим пользователем Linux и из-за нехватки знаний прошу помощи в решении проблемы. В общих чертах - в системе не отображается звуковое устройство HDMI.

Есть система:

voodoo@Orion:~$ inxi -b
System:    Host: Orion Kernel: 5.4.0-77-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa 
Machine:   Type: Desktop Mobo: Gigabyte model: H97M-HD3 v: x.x serial: <superuser/root required> UEFI: American Megatrends 
           v: F7 date: 04/21/2015 
CPU:       Quad Core: Intel Core i7-4790 type: MT MCP speed: 798 MHz min/max: 800/4000 MHz 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 460.84 
           Display: x11 server: X.Org 1.20.9 driver: nvidia resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 460.84 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
Drives:    Local Storage: total: 1.46 TiB used: 400.26 GiB (26.9%) 
Info:      Processes: 270 Uptime: 1h 02m Memory: 7.70 GiB used: 2.53 GiB (32.9%) Shell: bash inxi: 3.0.38 

voodoo@Orion:~$ groups voodoo
voodoo : voodoo adm dialout cdrom sudo audio dip plugdev lpadmin sambashare

с установленными драйверами nvidia v: 460.84 в системе определяется только одно playback устройство - встроенная звуковая, хотя lspci выводит 2 устройства (встроенная звуковая + NVIDIA).

voodoo@Orion:~$ lspci -knn | grep "Audio" -iA2
00:1b.0 Audio device [0403]: Intel Corporation 9 Series Chipset Family HD Audio Controller [8086:8ca0]
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family HD Audio Controller [1458:a182]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
--
01:00.1 Audio device [0403]: NVIDIA Corporation GP104 High Definition Audio Controller [10de:10f0] (rev a1)
	Subsystem: NVIDIA Corporation GP104 High Definition Audio Controller [10de:1b81]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel


voodoo@Orion:~$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7210000 irq 32


voodoo@Orion:~$ aplay -l
**** Список PLAYBACK устройств ****
карта 0: PCH [HDA Intel PCH], устройство 0: ALC887-VD Analog [ALC887-VD Analog]
  Подустройства: 0/1
  Подустройство №0: subdevice #0

при удалении драйверов nvidia sudo apt purge nvidia* появляются следующие устройства и звук на монитор начинает выводиться:

voodoo@Orion:~$ inxi -b
System:    Host: Orion Kernel: 5.4.0-77-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa 
Machine:   Type: Desktop Mobo: Gigabyte model: H97M-HD3 v: x.x serial: <superuser/root required> UEFI: American Megatrends 
           v: F7 date: 04/21/2015 
CPU:       Quad Core: Intel Core i7-4790 type: MT MCP speed: 2295 MHz min/max: 800/4000 MHz 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nouveau v: kernel 
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: vesa resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: NV134 v: 4.3 Mesa 20.2.6 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
Drives:    Local Storage: total: 1.46 TiB used: 398.71 GiB (26.8%) 
Info:      Processes: 269 Uptime: 2m Memory: 7.70 GiB used: 1.25 GiB (16.2%) Shell: bash inxi: 3.0.38 


voodoo@Orion:~$ lspci -knn | grep "Audio" -iA2
00:1b.0 Audio device [0403]: Intel Corporation 9 Series Chipset Family HD Audio Controller [8086:8ca0]
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family HD Audio Controller [1458:a182]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
--
01:00.1 Audio device [0403]: NVIDIA Corporation GP104 High Definition Audio Controller [10de:10f0] (rev a1)
	Subsystem: NVIDIA Corporation GP104 High Definition Audio Controller [10de:1b81]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel


voodoo@Orion:~$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7210000 irq 34
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17


voodoo@Orion:~$ aplay -l
**** Список PLAYBACK устройств ****
карта 0: PCH [HDA Intel PCH], устройство 0: ALC887-VD Analog [ALC887-VD Analog]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 3: HDMI 0 [HDMI 0]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 7: HDMI 1 [HDMI 1]
  Подустройства: 0/1
  Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 8: HDMI 2 [HDMI 2]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 9: HDMI 3 [HDMI 3]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 10: HDMI 4 [HDMI 4]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 11: HDMI 5 [HDMI 5]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 12: HDMI 6 [HDMI 6]
  Подустройства: 1/1
  Подустройство №0: subdevice #0

Из-за чего может возникать данная проблема и в какую сторону рыть для ее решения? Спасибо!

P.S. Пытался найти решение проблемы в интернете, но большинство тем описывают ситуации в которых не происходит автоматического переключения звука на HDMI при подключении ТВ к ноутбуку.

voodoo@Orion:~$ sudo dmesg | grep snd
[    3.760606] snd_hda_intel 0000:00:1b.0: enabling device (0000 -> 0002)
[    3.847430] snd_hda_codec_realtek hdaudioC0D2: autoconfig for ALC887-VD: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[    3.847432] snd_hda_codec_realtek hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.847434] snd_hda_codec_realtek hdaudioC0D2:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    3.847435] snd_hda_codec_realtek hdaudioC0D2:    mono: mono_out=0x0
[    3.847436] snd_hda_codec_realtek hdaudioC0D2:    inputs:
[    3.847437] snd_hda_codec_realtek hdaudioC0D2:      Front Mic=0x19
[    3.847439] snd_hda_codec_realtek hdaudioC0D2:      Rear Mic=0x18
[    3.847440] snd_hda_codec_realtek hdaudioC0D2:      Line=0x1a
[    5.435834] snd_hda_intel 0000:01:00.1: Disabling MSI
[    5.435839] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    5.435855] snd_hda_intel 0000:01:00.1: number of I/O streams is 30, forcing separate stream tags
[    5.537971] snd_hda_intel 0000:01:00.1: no codecs initialized

Явно последние 4 строчки должны мне что-то сказать, да только что?

 , ,

bad_popeye ()

Проблема с подключением внешнего монитора

В общем, такая байда. Линь на ноуте с разрешением 1366 x 768. Нужна зеркалка на внешнем мониторе, который 1920x1080. Подключаюсь через HDMI. В итоге какая-то ерунда: на внешнем монике скукоженный вариант, то есть тупо прямоугольник в верхнем левом углу. Пытаюсь вручную ставить разрешение для внешнего - на ноуте сбрасывает до 1024x768. Все, что можно сделать это тупо вырубить дисплей ноута и тогда на внешнем все в поряде. Но этот вариант не катит, нужен контроль. Каким-то образом они друг другу мешают и, очевидно, что если б они оба были FHD, то проблемы бы не было. Попробовал два дистра, Ubuntu и Linux Mint, хотя это один хрен. Среда - XFCE. У меня мелькнуло подозрение, что нужно создавать xorg.conf и прописывать туда оба дисплея, но хотелось бы более простого решения, ибо чертовски лень. У кого какие предложения?

 , ,

Damiano ()