LINUX.ORG.RU

Сообщения sugresmax

 

Mikrotik RBLHGGR

Даже не знаю как такое загуглить. В домашней сети установлен Mikrotik RBLHGGR как маршрутизатор.

Схема стандартная: маршрутизатор - коммутатор - компьютеры. И в такой схеме маршрутизатор виден в winbox, например. Но не доступен но по IP, ни по MAC. Интернета нет, как и DHCP и т.п. сервисов, развернутых на нем.

Если я подключаю его непосредственно к компьютеру, то все начинает работать. Есть связь с внешним миром (именно так я сюда и пишу:)).

Настройки сбрасывал на дефолтные. Кабель менял. Питание проверял.

Подскажите, люди добрые, что сделать с этой бездушной железякой, чтоб вернуть в дом интернет. Спасибо.

 ,

sugresmax ()

nginx циклически редиректит по ipv4

Столкнулся с проблемой. Установил ssl сертификат от Letsencrypt на свой сайт. До этого момент сайт работал без проблем.

Получается такая ситуация, что по ipv6 сайт нормально редиректит c http на https, а по ipv4 происходит циклический редирект.

Я уже забанен в гугле, 100 раз конфиг перепроверил. Подобная конфигурация работает на других серверах.

Собственно сам конфиг:

server {
    listen 80;
    listen [::]:80;
    server_name .mydomain.ru;
    return 301 https://mydomain.ru$request_uri;
}

server {
    server_name mydomain.ru;

    listen ssl http2;
    listen [::]:443 ssl http2 ipv6only=on; # managed by Certbot

    keepalive_timeout   70;


    ssl_certificate /etc/letsencrypt/live/mydomain.ru/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/mydomain.ru/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
}

Может быть кто то подскажет где я ошибся? Спасибо.

 ,

sugresmax ()

Не праздник что-ли?

Почему никто никого не поздравляет с праздником?

зы. С днем программиста, коллеги.

 

sugresmax ()

Сетевуха включается/выключается сама по себе

На домашнем сервачке под управлением debian 9 работает minidlna, transmission, ну и пара сайтиков на рельсах для личного использования. По непонятным причинам сетевуха выключается, затем сама включается и т.д. В логах нашел:

Dec  9 10:16:58 server kernel: [38681.271913] r8169 0000:01:00.0 enp1s0: link down
Dec  9 10:17:00 server kernel: [38683.491904] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:15:53 server kernel: [171813.721318] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:15:55 server kernel: [171815.960916] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:15:56 server kernel: [171816.762148] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:15:58 server kernel: [171819.012221] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:17:44 server kernel: [171925.200097] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:17:47 server kernel: [171927.538255] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:31:58 server kernel: [172778.384806] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:32:00 server kernel: [172780.598695] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:32:01 server kernel: [172781.773747] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:32:03 server kernel: [172784.008100] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:32:12 server kernel: [172792.586515] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:32:14 server kernel: [172794.822961] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:32:15 server kernel: [172796.260644] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:32:18 server kernel: [172798.490310] r8169 0000:01:00.0 enp1s0: link up
Dec 11 09:56:49 server kernel: [210268.541493] r8169 0000:01:00.0 enp1s0: link down
Dec 11 09:56:57 server kernel: [210276.970128] r8169 0000:01:00.0 enp1s0: link up
Dec 11 09:56:58 server kernel: [210278.012069] r8169 0000:01:00.0 enp1s0: link down
Dec 11 09:57:00 server kernel: [210280.249588] r8169 0000:01:00.0 enp1s0: link up

Подскажите, такое поведение сетевухи исправить возможно?

 ,

sugresmax ()

KDE4, NVIDIA180.51

Приветствую всех.

Возникла проблема: Установил KDE4 на Debian Sid. Установил драйвера Nvidia (брал с их сайта NVIDIA-Linux-x86_64-180.51).

Сейчас рабочий стол загружается только после переустановки этих самых драйверов. А иначе просто черный экран, и переключиться в консоль не удается. В логах kdm и Xorg ошибок нет.

Помогите советом, как исправить. Заранее благодарен.

Видеокарта: 7600 GS

$ uname -a
Linux sugresmax 2.6.29-2-amd64 #1 SMP Sun May 17 17:15:47 UTC 2009 x86_64 GNU/Linux

sugresmax ()

RSS подписка на новые темы