postfix пропускает русские exe-файлы
в header_checks
/^content-(type|disposition):.*name[[:space:]]*=.*\.(cpl|cmd|bat|exe|com|wsf|sc r|pif|chm|hta|shs|js|vbe|vbs)/ DISCARD Bad attachment file name extension: $2
в header_checks
/^content-(type|disposition):.*name[[:space:]]*=.*\.(cpl|cmd|bat|exe|com|wsf|sc r|pif|chm|hta|shs|js|vbe|vbs)/ DISCARD Bad attachment file name extension: $2
mount /mnt/DOS/ Failed to mount '/dev/sda1': Operation not supported Mount is denied because the NTFS journal file is unclean. Choices are: A) Shutdown Windows properly. B) Click the 'Safely Remove Hardware' icon in the Windows taskbar notification area before disconnecting the device. C) Use 'Eject' from Windows Explorer to safely remove the device. D) If you ran chkdsk previously then boot Windows again which will automatically initialize the journal. E) Run 'ntfsfix' on Linux which will reset the NTFS journal. F) Mount the volume read-only by using the 'ro' mount option.
разрешает монтировать только в r/o, а r/w не дает. Помогает загрузка винды и выключение. А можно ли из линукса такое исправить не перезагружаясь в винду?
под виндами работает, а под линуксом: usb-storage: device found at 5 usb-storage: waiting for device to settle before scanning scsi 4:0:0:0: Direct-Access JetFlash TS512MJF2A/120 8.07 PQ: 0 ANSI: 2 SCSI device sda: 1023998 512-byte hdwr sectors (524 MB) sda: Write Protect is off sda: Mode Sense: 03 00 00 00 sda: assuming drive cache: write through SCSI device sda: 1023998 512-byte hdwr sectors (524 MB) sda: Write Protect is off sda: Mode Sense: 03 00 00 00 sda: assuming drive cache: write through sda: unknown partition table sd 4:0:0:0: Attached scsi removable disk sda sd 4:0:0:0: Attached scsi generic sg0 type 0 usb-storage: device scan complete transcend JetFlash 512 (больше нет опознавательных знаков). 2.6.20 Slackware 11.0
fetchmail: WARNING: Running as root is discouraged.
как-нибудь этого можно избежать продолжаяя ее забирать так же от рута?
9 подсетей. Срок жизни адреса 32 дня. Наша админка находится в 5й подсетке. Само собой при переустановке системы или установки новой машинка забирает адрес из 5й подсети. В последнее время начали обновлять технику и все проходит через нас. А потом машинки разлетаются по разным подсеткам. Что произойдет, когда закончатся адреса в 5й подсети? Перестанет выдавать или освободит те, которые не работают в данный момент?
xorg.conf-2 xorg.conf-orig xorg.conf.backup xorg.conrf xorg.conf-fbdev xorg.conf-vesa
ладно. Думаю в другом месте гляну - /usr/X11R6/lib/X11 оказалось и там нет:
Cards Options XErrorDB Xcms.txt rgb.txt seyon.help xman.help xorg.conf.backup xorg.conf.eg
встает вопрос, а откуда xorg тянет настройки и 1152[865/75Гц?
вообщем есть локальный почтовик на postfix - el.ru. если почта падает на user@el.ru то он ложит письмо в локальный ящик. А как делать так, что если письмо посылается на test@el.ru, то он его ложил не в локальный ящик, а пересылал через провайдеровский релей? Вопрос ранее задавал, но ответ не сработал -------------------------------------------------- /etc/postfix/virtual el.ru domain user1@el.ru user1@el.ru user2@el.ru user2@el.ru postmap hash:/etc/postfix/virtual /etc/postfix/main.cf virtual_alias_maps = hash:/etc/postfix/virtual virtual_alias_domains = $virtual_alias_maps relayhost = ip_mailserver_with_normal_mailbox т.е. отправляешь почту самому себе, но через нужный relay.. ---------------------------------------------------- если локаьно пользователь не создан, то получаю ункноум узер, если создан, то письмо ложится локально и все. попробовал через transport, но не смог разобраться с форматом ------------------- test@elsib.ru smtp:smtp.relay ------------------- # postmap /etc/postfix/transport postmap: warning: /etc/postfix/transport: logical line must not start with whitespace: " test@elsib.ru ..."
-A POSTROUTING -s 192.168.7.0/255.255.255.0 -o eth0 -j SNAT --to-source 192.168.100.2
-A INPUT -s 192.168.7.248 -i eth1 -m mac --mac-source 00:0C:F1:C3:E8:6E -j ACCEPT -A INPUT -s 192.168.7.248 -i eth1 -j REJECT
( ^^^^ это правило перед всеми разрешающими)
-A FORWARD -s 192.168.7.248 -i eth1 -o eth0 -j ACCEPT -A FORWARD -d 192.168.7.248 -i eth0 -o eth1 -j ACCEPT
-A OUTPUT -s 192.168.5.2 -d 192.168.8.248 -o eth1 -j ACCEPT
беру машину с другим маком, ставлю тот же IP - машина спокойно выходит в инет.
меняю правило -A FORWARD -s 192.168.7.248 -i eth1 -o eth0 -m mac --mac-source 00:0C:F1:C3:E8:6E -j ACCEPT
пинги и трасеровка с машинки бегают, а вот из браузера в инет уже не получается. Задумывается навсегда
Что я делаю не так?
1181193565.671 0 192.168.5.29 TCP_DENIED/407 1742 GET http://dc.ru-board.com/ - NONE/- text/html
такое ощущение что она просто не собирается авторизироваться. Может что в сквиде можно сделать? Не хотелось бы нат открывать для них по некоторым причинам связанным с подсчетом трафика и статистикой урлов
acl sburl url_regex -i "/usr/local/squid/etc/url/sburl" acl sburl_domain ident_regex "/usr/local/squid/etc/url/sburl"
acl sb proxy_auth "/usr/local/squid/etc/groups/sb" http_access allow sb_ports CONNECT
acl sb proxy_auth "/usr/local/squid/etc/groups/sb" http_access allow sb_ports CONNECT password
и еще. Где найти уже собраный миднайт командер? тут нет его http://archive.ubuntu.com/ubuntu/
вообщем на станом сервачке умерла мамка и мне выделили новык комп под сервак. на старом было Slackware 10.2 на новом поставил Slackware 11.0
все перенеслось вроде без проблем, кроме связки DNS+DHCP.
При попытке обновления в логах вижу:
May 16 14:55:38 proxy dhcpd: if Irin.elsib.local IN TXT "31e6eaaa127e560b7b0ca7f053fd1ee7d9" rrset exists and Irin.elsib.local IN A 192.168.6.15 rrset exists delete Irin.elsib.local IN A 192.168.6.15: bad DNS key.
В dhcpd.conf
key DHCP_UPDATER {
algorithm HMAC-MD5.SIG-ALG.REG.INT;
secret WvJ5ooY7M5/PGFJA0LYwpQ==;
}
-----------
в named.conf
key "rndc-key" {
algorithm hmac-md5;
secret "WvJ5ooY7M5/PGFJA0LYwpQ==";
};
и на каждую (их 8) зону такая запись.
zone "8.168.192.in-addr.arpa" IN {
type master;
file "my.192.168.8";
allow-update { key rndc-key; };
// notify no;
};
make[2]: Entering directory `/usr/src/deys/2007-04-04/xmovie-1.9.13/xmovie' g++ -c `cat i686/c_flags` load.C -o i686/load.o In file included from ../guicast/bcsubwindow.h:4, from ../guicast/bcbutton.h:5, from ../guicast/guicast.h:5, from load.C:1: ../guicast/arraylist.h: In member function `void ArrayList<TYPE>::remove_object_number(int)': ../guicast/arraylist.h:176: error: `stderr' was not declared in this scope ../guicast/arraylist.h:176: error: there are no arguments to `fprintf' that depend on a template parameter, so a declaration of `fprintf' must be available ../guicast/arraylist.h:176: error: (if you use `-fpermissive', G++ will accept your code, but allowing the use of an undeclared name is deprecated) ../guicast/arraylist.h: In member function `void ArrayList<TYPE>::remove_object()': ../guicast/arraylist.h:192: error: `stderr' was not declared in this scope ../guicast/arraylist.h:192: error: there are no arguments to `fprintf' that depend on a template parameter, so a declaration of `fprintf' must be available make[2]: *** [i686/load.o] Ошибка 1 make[2]: Leaving directory `/usr/src/deys/2007-04-04/xmovie-1.9.13/xmovie' make[1]: *** [all] Ошибка 2 make[1]: Leaving directory `/usr/src/deys/2007-04-04/xmovie-1.9.13' make: *** [all] Ошибка 2
как выяснить какого пакета ему недостает? Сам не програмист и си знаю ток на уровне tar zxvf xxxxx.tar.gz make && make install и все. Дистрибутив Slackware 11.0
| ← назад | следующие → |