LINUX.ORG.RU

Сообщения albertn

 

Pulseaudio zeroconf звук по сети

Форум — Desktop

У меня есть сервер, к которому подключены колонки 5.1, и есть ноутбук, с которого нужно передавать звук на 5.1.

На обоих тачках стоит гента. Поставил pulseaudio и там и там.

На сервере дописал следующие строчки в конфиг:

load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1;192.168.0.0/24 auth-anonymous=1
load-module module-zeroconf-publish
load-module module-rtp-recv
На ноутбуке:
load-module module-zeroconf-discover
Теперь если я в файле /etc/pulse/client.conf укажу строчку
default-server = tcp:192.168.0.3:4713
То все работает замечательно

Либо если я запущу mplayer следующей командой:

mplayer -ao pulse:192.168.0.3 -channels 6 Фильм.avi
То все так-же хорошо.

Но на днях я нашел программу pasystray (замена padevchooser). Она позволяет перенаправлять звук у каждой программы туда, куда надо (находя другие серверы по zeroconf). Учитывая, что это ноутбук, данный функционал я счел очень полезным, но с ним возникла проблема.

При смене sink на pulseaudio сервера, звук передается на сервер, но видео начинает тупить и зависает. Попытка поставить самую последнюю версию pulseaudio и на сервере и на ноутбуке ни к чему не привела.

Моет кто знает как это все завести?

 ,

albertn ()

Не работает Canon LBP6000 на Gentoo

Форум — Desktop

Нашел кучу мануалов по установке, но ничего не заработало. Опишу последовательность действий:

Скачиваю с https://bugs.gentoo.org/show_bug.cgi?id=130612 3 файла

  • init file for ccpd
  • cndrvcups-capt-2.20.ebuild
  • cndrvcups-common-2.20.ebuild

К двум последним добавляю к имени _p1 (вышла уже новая версия) и кидаю все в /usr/local/portage (подправив версию в зависимостях).

Скачиваю с официального сайта дрова, и кидаю их в distfiles.

Ставлю cndrvcups-capt.

emerge cndrvcups-capt

Добавляю в /etc/conf.d/modules модуль usblp.

Добавляю принтер

# /usr/sbin/lpadmin -p CanonLBP6000 -m CNCUPSLBP6018CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E
# /usr/sbin/ccpdadmin -p CanonLBP6000 -o /dev/usb/lp0

 CUPS_ConfigPath = /etc/cups/
 LOG Path        = None
 UI Port         = 59787

 Entry Num  : Spooler   : Backend       : FIFO path             : Device Path   : Status 
 ----------------------------------------------------------------------------
     [0]    : CanonLBP6000      : ccp           : /var/ccpd/fifo0       : /dev/usb/lp0  :

Добавляю ccpd в автозагрузку

rc-update add ccpd default

После перезагрузки машины и принтера не заработало. Может я что-то не так делаю?

PS. после запуска ccpd создает 250 процессов, которые можно убить только через killall -9 ccpd, это нормально?

 , ,

albertn ()

pyodbc + unixODBC + FreeTDS + MSSQL + русские буквы

Форум — Development

Доброго времени суток!

Мне дали доступ к хранимке на MSSQL, которую мне нужно переработать в python. Решил использовать связку, указанную в сабже.

# cat /etc/unixODBC/odbcinst.ini

[FreeTDS]
Description=FreeTDS
Driver=/usr/lib/libtdsodbc.so
UsageCount=1

# cat /etc/unixODBC/odbc.ini

[MSSQL]
Driver=FreeTDS
Description=Database
Trace=No
Server=192.168.2.2
Port=1433
Database=database
UID=user
PWD=password
TDS Version=8.0

При запуске

# isql MSSQL user password

Все работает как надо, но при подключении из pyodbc возникли две проблемы:

1. При записи

con = pyodbc.connect("DNS=MSSQL;UID=user;PWD=password")
Вываливается ошибка: pyodbc.Error: ('IM002', '[IM002] [unixODBC][Driver Manager]Data source name not found, and no default driver specified (0) (SQLDriverConnectW)')

2. Если же сделать строку вида

con = pyodbc.connect("UID=user;PWD=password;DATABASE=database;DRIVER={FreeTDS};SERVER=192.168.2.2;PORT=1433")
то подключение работает, но во всех не юникодовых строках русские буквы заменяются знаками вопроса. Уже не знаю куда копать. Может кто-то сможет посоветовать?

PS. pymssql не умеет возвращать юникодовые данные.

PPS. Парсить вывод isql не выход.

albertn ()

PulseAudio + mpd

Форум — Multimedia

Доброго времени суток.

Недавно решил перейти на PulseAudio. Все бы хорошо, но звук не хочет одновременно работать у двух различных пользователей (мой и mpd).

Как я понял, если пользователей не добавлять в группу audio, то работает режим Fast user switching, и воспроизводится звук того пользователя, чья консоль открыта в данный момент, а мне нужно, чтобы mpd работал всегда. При добавлении всех пользователей в группу audio, звук не перестает работать в разных консолях, но работает только от одного пользователя.

Если использовать system-wide режим, то все работает нормально, но авторы его не рекомендуют использовать. http://www.pulseaudio.org/wiki/WhatIsWrongWithSystemMode К тому-же этот флаг замаскирован в профиле # Don't use system-wide mode unless you *really* know what you're doing.

Некоторые запускают mpd от того-же пользователя, но это не решение, а костыль.

И еще, в начале была небольшая проблема, что не хотели стартовать одновременно два сервера под разными пользователями. решилось добавлением .nofail и .fail для load-module module-esound-protocol-unix

Уже успел проклянуть этот pulseaudio, и думал вернуться обратно на alsa. Перерыл весь интернет, ничего толкового не нашел и решил написать здесь.

Дистрибутив - Gentoo.

media-sound/pulseaudio-0.9.22-r2 (X alsa asyncns avahi bluetooth caps dbus glib ipv6 libsamplerate lirc realtime udev)

media-sound/mpd-0.16.2 (aac alsa ao audiofile bzip2 cdio curl ffmpeg fifo flac id3 ipv6 lame libsamplerate mad mikmod modplug musepack network ogg openal profile pulseaudio sndfile sqlite tcpd unicode vorbis wavpack zeroconf zip)

Все делал по этой http://en.gentoo-wiki.com/wiki/PulseAudio и этой http://pulseaudio.org/wiki/PerfectSetup инструкциям.

albertn ()

Apache + SSH

Форум — Admin

Есть сервак с одним внешним IP. На нем стоит apache и ssh. У меня на работе стоит прокси, который разрешает connect только на 443 порт. До этого я ssh порт менял на 443 и все работало отлично, но сейчас понадобилось поднять https, и теперь ищу пути решения.

У меня есть два доменных имени, к примеру http://www.myserver.com и ssh.myserver.com. Пытался через ProxyPass настроить перенаправление на ssh, но ничего не вышло. Вот конфиг:

<VirtualHost ssh.myserver.com:443>
        ServerName ssh.myserver.com
        NameVirtualHost ssh.myserver.com:443
        AllowCONNECT 22 443
        ProxyRequests Off
        ProxyPreserveHost On
        ProxyPass / http://127.0.0.1:22/
</VirtualHost>

При попытке подключения через ssh клиент, он зависает и ничего не говорит, причем даже в логах ничего не отображается. Зато если через браузер, то в логах отображается запрос. Попытки прикрутить ssl ни к чему не привели.

Даже не знаю возможно ли так настроить систему? Гуглил по поводу этой связки, ничего толкового не нашел, разве что поднять прокси, и в клиенте указать его, но я на работе и так через прокси сижу :(

И еще один вопрос. У меня сейчас только один виртуальный хост на 443 порту, т.е. к нему можно подключаться хоть по ip. Можно ли сделать чтобы ssh нормально подключался и сайт по https работал?

albertn ()

[tc][nat] Приоритеты входящего трафика

Форум — Admin

Есть сервер, подключенный к интернет через ADSL. Настроен NAT и качалка. Но когда сервер качает, на остальных компах практически пропадает интернет, а нужно, чтобы интернет пропадал на сервере. Приоритет исходящего трафика удалось настроить через tc, но на входящий он никак не влияет. Думал поставить очередь ifb, но она не умеет работать с nat, для imq нужны патчи, да и не уверен, что она даст нужный результат, т.к. скорость интернета значительно меньше скорости сети. Есть ли какой-нибудь вариант настроить приоритеты входящего трафика?

Заранее спасибо.

albertn ()

WM5 + Synce

Форум — Linux-hardware

Уже несколько месяцев не могу настроить нормальную работу. Уже и ядро менял, патчил, копал весь интернет но ничего не получается. У кого получилось подключить помогите пожалуйста.

Qtek 8310, Gentoo

albertn ()

RSS подписка на новые темы