LINUX.ORG.RU

Не работает Canon LBP6000 на Gentoo

 , ,


1

2

Нашел кучу мануалов по установке, но ничего не заработало. Опишу последовательность действий:

Скачиваю с https://bugs.gentoo.org/show_bug.cgi?id=130612 3 файла

  • init file for ccpd
  • cndrvcups-capt-2.20.ebuild
  • cndrvcups-common-2.20.ebuild

К двум последним добавляю к имени _p1 (вышла уже новая версия) и кидаю все в /usr/local/portage (подправив версию в зависимостях).

Скачиваю с официального сайта дрова, и кидаю их в distfiles.

Ставлю cndrvcups-capt.

emerge cndrvcups-capt

Добавляю в /etc/conf.d/modules модуль usblp.

Добавляю принтер

# /usr/sbin/lpadmin -p CanonLBP6000 -m CNCUPSLBP6018CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E
# /usr/sbin/ccpdadmin -p CanonLBP6000 -o /dev/usb/lp0

 CUPS_ConfigPath = /etc/cups/
 LOG Path        = None
 UI Port         = 59787

 Entry Num  : Spooler   : Backend       : FIFO path             : Device Path   : Status 
 ----------------------------------------------------------------------------
     [0]    : CanonLBP6000      : ccp           : /var/ccpd/fifo0       : /dev/usb/lp0  :

Добавляю ccpd в автозагрузку

rc-update add ccpd default

После перезагрузки машины и принтера не заработало. Может я что-то не так делаю?

PS. после запуска ccpd создает 250 процессов, которые можно убить только через killall -9 ccpd, это нормально?

Выкиньте capt принтер и купите нормальный. У меня аналогично не получилось настроить lbp3010 к тому же, вроде, на 64-битной системе у capt драйвера большие проблемы, может «заработать» только на 32 битной системе. К тому же новый cups (>=1.4) использует libusb, а не ядерный модуль, так что могут быть проблемы и с этим.

kostik87 ★★★★★ ()
Ответ на: комментарий от ymuv

Пробовал, не получилось, captuimonitor или как-то так, не помню точного названия, пишет об ошибке соединения с принтером.

kostik87 ★★★★★ ()
Ответ на: комментарий от ymuv

Можно, это стандартная функция, только нужно предварительно модуль usblp выгрузить на хостовой системе.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Выкиньте capt принтер и купите нормальный.

Этот принтер я выиграл, а трофеи нельзя выкидывать.

У меня аналогично не получилось настроить lbp3010 к тому же, вроде, на 64-битной системе у capt драйвера большие проблемы, может «заработать» только на 32 битной системе.

У меня система 32 бита.

К тому же новый cups (>=1.4) использует libusb, а не ядерный модуль, так что могут быть проблемы и с этим.

Попробую сделать даунгрейд, хотя не уверен что поможет.

albertn ()

На будущее: тег «canon» лучше заменять на «кактус».

segfault ★★★★★ ()
Ответ на: комментарий от albertn

Попробую сделать даунгрейд, хотя не уверен что поможет.

А как сделать даунгрейд, если в портеже нет старых версий?

И что можно еще попробовать? Есть вариант поставить виртуалку с виндой, но это не есть хорошо.

albertn ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.