LINUX.ORG.RU

Сообщения Alex_Saf

 

Внутрисетевой аналог севрера Skype или Gizmo

Доброго времени суток, коллеги!

Появилась потребность в неком сервере для внутриофисных звонков посредством локалной сети. Думаю, что-то типа Skype или Gizmo. Желательно опенсооурсное. Если еще будет возможность гейта на офисную АТС - цены б не было!
Кто-нибудь сталкивался с подобной проблемой? Прошу помочь

Alex_Saf ()

Проблема с iptables - слишком долго добавляются правила

Доброго времени суток, коллеги!

Есть серверок на FC1, который раздает инет пользователем следующим способом: пользователь поднимает VPN соединение с этим сервером (на сервере работаете pptpd). В момент соединения после поъема pppd на сервере срабатывает скрипт (/etc/ppp/auth-up), добавляющий правила iptables на конткретного пользователя. При завершении соединения - правила убираются. Такая схема работала практически 2 года без проблем.
В настоящее время клиент соединяется по VPN, но появляется ошибка "kernel: application bug", хотя само соединение происходит, шифрование включается :
Oct 10 15:05:43 proxy1 pptpd[12630]: CTRL: Client 192.168.0.198 control connection started
Oct 10 15:05:43 proxy1 pptpd[12630]: CTRL: Starting call (launching pppd, opening GRE)
Oct 10 15:05:43 proxy1 kernel: application bug: pppd(12631) has SIGCHLD set to SIG_IGN but calls wait().
Oct 10 15:05:43 proxy1 kernel: (see the NOTES section of 'man 2 wait'). Workaround activated.
Oct 10 15:05:43 proxy1 pppd[12631]: pppd 2.4.3 started by root, uid 0
Oct 10 15:05:43 proxy1 pppd[12631]: Using interface ppp3
Oct 10 15:05:43 proxy1 pppd[12631]: Connect: ppp3 <--> /dev/pts/10
Oct 10 15:05:43 proxy1 pptpd[12630]: GRE: Discarding duplicate packet
Oct 10 15:05:46 proxy1 pptpd[12630]: CTRL: Ignored a SET LINK INFO packet with real ACCMs!
Oct 10 15:05:46 proxy1 pppd[12631]: MPPE 128-bit stateless compression enabled
Oct 10 15:05:48 proxy1 pppd[12631]: Cannot determine ethernet address for proxy ARP
Oct 10 15:05:48 proxy1 pppd[12631]: local IP address 192.168.10.254
Oct 10 15:05:48 proxy1 pppd[12631]: remote IP address 192.168.10.14

Я поствил последние версии ppp-2.4.3, dkms-2.0.5, kernel_ppp_mppe-0.0.5, но ошибка не ушла.
Далее еще смешнее. Между клиентом и сервером не ходят пакеты. Причем не ходят около 7-10 минут. Потом, как я понимаю, все-таки добавляются правила iptables и пакеты начинают бегать. Так или иначе но существут некий тайм-аут после которого прохождение пакетов разрешается. (все политики по умолчанию - DROP) Хотя до сего дня все было нормально, измений/обновлений не производилось. Кроме того, по iptables -L, вывод правил наверное 200 идет довольно долго - около 10 минут. Кто-нибудь сталкивался с подобной проблемой? Как решить не подскажите?
Спасибо.

Alex_Saf ()

Линукс и двукорные оптероны

Доброго времени суток, коллеги!
Есть проблема с сервером на двукорных оптеронах. Сервер на четырехголовой матери TYAN S4882-D. Соответственно воткнуто четыре 875-х Opteron'а. Частота этих оптеронов ~2200. А вот что выводит /proc/cpuinfo:
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 33
model name : AMD Opteron(tm) Processor 875
stepping : 0
cpu MHz : 1002.434
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm cmp_legacy
bogomips : 2003.31
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp

processor : 1
vendor_id : AuthenticAMD
cpu family : 15
model : 33
model name : AMD Opteron(tm) Processor 875
stepping : 0
cpu MHz : 1002.434
cache size : 1024 KB
physical id : 0
....
processor : 7
vendor_id : AuthenticAMD
cpu family : 15
model : 33
model name : AMD Opteron(tm) Processor 875
stepping : 0
cpu MHz : 1002.434
cache size : 1024 KB
....
т.е. процы линукс считает всего лишь гигагерцовыми. Собственно почему?
Еще интереснее вывод dmesg:
powernow-k8: Found 8 AMD Athlon 64 / Opteron processors (version 1.50.3)
powernow-k8: 0 : fid 0xe (2200 MHz), vid 0x8 (1350 mV)
powernow-k8: 1 : fid 0xc (2000 MHz), vid 0xa (1300 mV)
powernow-k8: 2 : fid 0xa (1800 MHz), vid 0xc (1250 mV)
powernow-k8: 3 : fid 0x2 (1000 MHz), vid 0x12 (1100 mV)
cpu_init done, current fid 0xe, vid 0x8

Теряюсь в догадках. Может нет поддержки двукорных процов?
Прошу совета.

P.S. Дистрибутив Fedora Core 4 на 2.6.12-1.1450_FC4smp

Alex_Saf ()

Организация видеоконференций

Коллеги!

Есть тема организовать для начальства видеоконференциии (типа селектора на 6-10) человек. Основы вреде бы изучил, но не хватает опыта в таком деле. Есть пару вопросов
1) По железу, какие посоветуете веб-камеры (до 150-180$), чтобы уверенно работали по линукс (только федора и ред хат)
2) Можно ли использовать в качестве медиа сервера OpenMCU из проекта OpenH323. Или есть свободные проекты получше?
3) Доступны ли методики по организации подобного рода вещей на свободных продуктах?
Прошу помочь

Alex_Saf ()

Мультимедийные возможности барбон-системы MiniQ 868AV

Доброго времени суток!

На днях прриобрел барбон-систему MiniQ 868AV. Меня привлекла возможность смотреть/слушать фильмы/музыку без загрузки основной ОС, коей является WinXP.
Такие мультимедийные возможности обеспечивает дистр линукса, устанавливаемый в раздел порядка 100Мб. Устанавливаться он должен первым на неразмеченный диск. Раздел не активный и не загрузочный. Затем ставиться виндовс. При нажатии на кнопку д/у (напр. DVD) машина должна стартовать, далее грузиться линукс и затем возникать прога (в данном случае линуксовый порт WinDVD киберлинка) и, соответсвенно, показываться фильм. Так вот после старта машины ничего не происходит - черный экран и моргающий курсор. Обычно это происходит в случае если ядро не сумело распаковаться или с initrd какие-либо проблемы. Но может проблема гораздо глубже, типа некий загрузчик в биосе не может правильно передать управление. Линуксовый раздел форматирован как ext2. В /etc лежит lilo.conf, хотя сам загрузчик ни в mbr ни в зарг. секторе диска не стоит. Мне пришлось поставить lilo. После этого загрузка линукса идет, но обрывается при передаче управления init - не находится библиотека /lib/libc.so.6, хотя она там есть. Тем не менее если нажать на заветную кнопку д/у - ни черта не выходит.
Мож кто уже боролся с этим зверем? Прошу помощи.
P.S. биос обновил до последнего доступного с сайта http://www.jetway.com.tw/evisn/index.html

Alex_Saf ()

FC3 не желает нормально делать reboot

Коллеги!
Есть проблема с автоматическим выключением и перезагрузкой сервера под Fedora Core 3 с последним ядром (из rpm) и всеми обновлениями.
Сервер так себе - на матери ASUS P4SP-MX. В биосе все что можно просмотрел на предмет управлением питанием.
Ситуция такова, что при перезарузки (напр. после команды reboot) машина начнает нормально завершать работу и готовиться перегрузиться. Так вот физически перезагрузка не осуществляется, все останавливается на последнем шаге, система говорит, что готова к перезагрузке и все. Не реагирует на ctrl-alt-del, ни на что - только кнопкой reseta. Меня это очень напрягает, т.к. сервер будет стоять достаточно далеко от меня и соответственно некому будет reset дергать при необходимости.
Прошу помочь

Alex_Saf ()

FC3 и RAID-контроллер (SATA) Adaptec 2410SA

Коллеги!
Есть проблемка с RAID-контроллером (SATA) Adaptec 2410SA (Это ревльный рейд и с последнве прошивкой биоса). Ранее на нем стояли диски по 150 G (в зеркало). Решили заменить на 300 G. Рейд нормально создается, но при установке Fedora Core 3 вылазит предупреждение, что разметка на диске не может быть найдена, и соответственно ничего не получается. При этом рейд начинает издавать звуки, как будто он в состоянии "degradet".
Интересно, что на мамке сервера есть сата-контроллер. И если просто подключить на работающей системе диск на 300G - все нормально, размечается и работает. Но хотелось бы зеркало поиметь.
Кто встречался с этой проблемой? Что делать? Менять контроллер?
Спасибо.

Alex_Saf ()

Linux и LSI 53C1030 U320 SCSI контроллер

Скоро придет сервер на оптеронах с LSI 53C1030 U320 SCSI контроллером на борту. Кто-нить подскажет - это полноценный райд, или нет? Что-то мне говорит, что это фейк-раид. Наверное придется ставить что-то типа LSI MegaRAID 320-1.

Alex_Saf ()

Встроенный Линукс в модуль цифровых обработки сигналов

Коллеги!
Недавно столкнулся с такой проблемой: существует модуль цифровых обработки сигналов на ПЛИС Virtex-II PRO XDSP-PC/104-V2P со встроенными процессорными ядрами PowerPC. Управляется эта железяка какой-то версией Линукса. Так вот вопрос: каким образом этот Линукс туда заливается. На сайте производителя ничего толкового не нашел. Можно ли залить предварительно скомпиленное свое ядро? Кто-нибудь встречался с подобной железякой? Прошу помочь.

Alex_Saf ()

Можно ли из системы на базе LInux сделать внешний дисковый массив?

Доброго времни суток!

Собственно сабж. Хотелось бы не загонятся (по крайней мере сейчас) с внешними дисковыми массивами от известных производителей от 7 килобаксов.
Может можно соорудить что-нибудь на базе доступных шасси. Меня интересует внешний массив для двухузлового кластера. Очевидно это будет устройство с двумя сказевыми хост-каналами, дисковыми корзинами и неким софтом. так вот о софте: кто-нибудь знает о свободном проекте для создания внешних дисковых массивов?
Спасибо

Alex_Saf ()

Медленная скорость копирования файлов в FC3

Коллеги!
Есть у меня вопрос по скоростным характеристикам FC3 при копировании файлов. У работает серверок на двух 250-х оптеронах под управлением Fedora Core 3 (ядро - 2.6.10-1.770_FC3smp) на базе платы TYAN S2882 (биос последний). Памяти 4 Гб. Дисковая подсистема представляет собой зеркало из двух 150 Гб SATA-дисков на базе хардварного раид-контроллера Adaptec 2410sa. Так вот, при копировании файлов 2-6 Гб просто в другой каталог на одном разделе скорость примерно 3-5 Мб/с. У меня по сети быстрее файлы перемещаются. В начале копирования рывок скорости до 120 Мб/с - затем скорость падает до вышеназванных 3-5 Мб/с и более не растет. На тойже машине под FC1 - скорость не делает никаких рывков - стабильно копирование идет где-то на уровне 20-30 Мб/с.
Что у меня может быть не так? Как мне поднять скорость при копировании?
Прошу помочь

Alex_Saf ()

Отваливается мышь на FC3

Коллеги!

У меня есть серверок на двух оптеронах. Управляется FC3 (с последними апдейтами и kernel'ом 2.6.10-1.770_FC3). На нем вращается VMware c кучей вируальных машин. А посему в данном случае нужны на сервере X-сы. Так вот, нерез несколько часов работы отваливается мышь. Т.е. не совсем чтоб не двигалась (хотя бывает и такое), а при перемещении начинает деспорядочно метаться по экрану, открывая и закрывая приложения. Спасает только перезагрузка. Сервер стоит в стойке и своих клавы с мышой не имеет. Есть стек переключателей KVM, который и подключает видео, клаву и мышь к серверу. Может дело в нем. Но на остальных серваках (виндовых, нетварных и линуксовых) такого не наблюдаю. Правда на части из них нет графики.
Прошу помочь.

Alex_Saf ()

RSS подписка на новые темы