LINUX.ORG.RU

Поддержка HAL в PulseAudio объявлена устаревшей

 ,


0

0

Lennart Poettering, автор современного звукового сервера PulseAudio, объявил о том, что версия PulseAudio из GIT может использовать libudev вместо HAL для перечисления аудиоустройств в системе. Это часть общего плана по упразднению HAL путем его замены на libudev и DeviceKit. Для работы требуется linux >= 2.6.30, udev >= 141 и udev-extras из GIT.

Поддержка HAL никуда не выброшена, чтобы у пользователей старых версий ядра все работало по-старому, но дистрибутивам рекомендовано при сборке PulseAudio передавать опцию --disable-hal.

>>> Подробности

★★★★★

Проверено: Shaman007 ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

DeviceKit это сборище шеллскриптов, я правильно понял?

Да и кому "бздя" на десктопе нужна? Мне нужна. Еще многим нужна. С таким же успехом можно сказать кому это ваш линакс на десктопе нужен? 1% поользователей компютеров?

Julio_Petrovich ()
Ответ на: Re: Поддержка HAL в PulseAudio объявлена устаревшей от Julio_Petrovich

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> DeviceKit это сборище шеллскриптов, я правильно понял?

не угадал

> Да и кому "бздя" на десктопе нужна? Мне нужна. Еще многим нужна.


извращенцы :)

JB ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

c PulseAudio у меня и на десктопе, и на ноуте отваливается звук в произвольный момент, так что, как пользовался alsa, так и буду, с ней никаких проблем

а что касается HAL, то он очень даже удобен, девайсы ловит на лету, не вынуждает ковыряться в xorg.conf и после этого ещё и рестартить иксы, к тому же он, благодаря своей базе оборудования, избавил от использования кучи костылей для прикручивания мультимедиа клавиш

PayableOnDeath ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

Мда... Загребли в корень. Сколько народ трахался с хэлом. То тут не работает, то там отвалилось... И вот, когда хэл сделали слегка стабильных, отдельные разрабы с шилом в жопе уже объявляют его устаревшим.

cache ★★ ()
Ответ на: Re: Поддержка HAL в PulseAudio объявлена устаревшей от Erik_der_Zweite

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Кому не нужно, а у кого и синезубая гарнитура есть, с PA зело удобно, не то что раньше.

Так PA и для программиста в сто тыщ раз удобнее, чем голая ALSA.

mv ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Базовая система Lenny, без всяких допиливаний (но с localepurge) ~80 метров.

А xulrunner, который firefox^Wiceweasel хочет, вагон ненужного говна за собой хочет. Или, вот, взять OO.org... В итоге, что Федора, что Дебиан, что даже Генту одинаково весят. С Гентой даже больше места на винте по понятным причинам улетает, не говоря уж о времени.

mv ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> xulrunner, который firefox^Wiceweasel хочет, вагон ненужного говна за собой хочет. Или, вот, взять OO.org... В итоге, что Федора, что Дебиан, что даже Генту одинаково весят

В итоге, если поставить весь мусор, Debian задавит федору, как сумоист пигмея. Но кого это интересует? :) Речь о минимальной системе, и в Debian она меньше (раза в 2, ЕМНИП).

tailgunner ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Поддержка HAL в PulseAudio объявлена устаревшей

Иии?.. :) HAL уже давно объявлен устаревшим в связи с принятием DeviceKit.

cruxish ★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> В итоге, если поставить весь мусор, Debian задавит федору, как сумоист пигмея. Но кого это интересует? :)

Речь не о всём мусоре из репозитория, а об обычной системе (без гномокедов): иксы, компилятор, ff, ooo, gimp.

> Речь о минимальной системе, и в Debian она меньше (раза в 2, ЕМНИП).


Ну да, Дебиан где-то на 450 ставится, Федора - за гигабайт.

mv ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

>> Речь о минимальной системе, и в Debian она меньше (раза в 2, ЕМНИП).

> Ну да, Дебиан где-то на 450 ставится, Федора - за гигабайт.

Ну нихрена себе нынче понятия о "минимальной системе".

tailgunner ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Ну нихрена себе нынче понятия о "минимальной системе".

Не говори. Установленная система кое-как целиком в память влазит... ;)

mv ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

>>На убунтушных сайтах исчезнут топики - "ПАМАГИТЕ, пропал звук!!!". Не?

>естественно. в новых версиях убунты звука не будет. чтобы не пугать пользователей.

макось way?

pulseaudio неплохая вещь, но как оно работает - лучше не надо.

NowhereMan ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Ну нихрена себе нынче понятия о "минимальной системе".

ты тоже помнишь времена, когда минимальная система влезала на дискету 1.44 метра? )

isden ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> помнишь времена, когда минимальная система влезала на дискету 1.44 метра? )

Ну она была уж очень минимальной :) А вот в ДОС на 1.44 умещался еще и nc/vc, и можно было работать :)

tailgunner ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> +1, PA ненужно.

-2, Буду смеятся над вашими терзаниями, когда возникнет надобность взмахом руки перекинуть потоки со всех возможных программ-звукогенераторов, например, на bluetooth-гарнитуру; не говорю уж об иных манипуляциях...

shahid ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> pulseaudio неплохая вещь, но как оно работает - лучше не надо.

Отлично работает, 0.9.15. Нагрузка на проц в пределах нескольких %. Про убунту и федору не вспоминаем.

shahid ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> А мне что на FreeBSD впиливать libudev и линуксовый udev, чтобы поставить новую версию PulseAudio?

Спрашиваешь традиционно в целях провокации или же ожидаешь осмысленных ответов?

shahid ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

>Теперь оно более-менее пашет...

Окг-СОкг-БЕНкгхх-НОхх-НАкгрд-HDггххх-КАРТОЧКАХ, оно пашет заме.......... (тут включили флеш со звуком, или несколько раз быстро нажали стоп-плей).

r ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

>и что, с ним реально нормально работает? а профили управления есть? или только A2DP? btw, просто A2DP можно и через alsa выводить.

Можно, но до ужаса геморройно возится с альсой в сравнении с настройкой РА. Из плюсов РА + bt: через Pavu-control и D-Bus интерфейс можно на лету переключатся между a2dp, sco и off. При отсутствии playback'a, гарнитура переходит в режим ожидания (как и с голой альсой). Удобносте)

shahid ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

охлол...
Они deprec'ируют то что еще не везде толком было внедрено 0_o
HAL ждет судьба devfs?

Stiletto ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

>Есть. Еще PulseAudio умеет такие клевые штуки как одновременный вывод звука, например со Skype, на блютус гарнитуру, звук видеоплеера по hdmi, а системные звуки через обычную звуковуху. И настраивается это все несколькими кликами мышкой

Запустил плей шауткаста чераз амарок - слышу звук. Запустил плей кино через каффеин - звука не слышу. Остановил амарок - перезапстил фильму - звука не слышу. Из опыта яснго что спасет только перезапуск кафеина.

Убейте тех гадов которые поломали звук в opensuse включив туда пульсаудитк и все заввернув через него.

r ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Они deprec'ируют то что еще не везде толком было внедрено 0_o

Это Вы про Slackware? Так это не дистрибутив, а кунсткамера и музей исторического прошлого.

Nastishka ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

>Отлично работает, 0.9.15. Нагрузка на проц в пределах нескольких %. Про убунту и федору не вспоминаем

А где тогда хорошо? В демьяне оно древнее, в генте - не собирается, что в слаке - не знаю.

NowhereMan ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Запустил плей шауткаста чераз амарок - слышу звук. Запустил плей кино через каффеин - звука не слышу. Остановил амарок - перезапстил фильму - звука не слышу. Из опыта яснго что спасет только перезапуск кафеина.

Дай угадаю... openSUSE?

tailgunner ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Или PulseAudio :)

Да по ходу оба они RIP ;)

> По крайней мере Hal у меня есть, а PulseAudio - нет ;)


Зачем вам HAL? Я вот без него живу, чувствую себя хорошо.

andreyu ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> -2, Буду смеятся над вашими терзаниями, когда возникнет надобность взмахом руки перекинуть потоки со всех возможных программ-звукогенераторов, например, на bluetooth-гарнитуру; не говорю уж об иных манипуляциях...

Буду смеяться над вашими терзаниями, когда возникнет необходимость сменить DE/WM на более правильный (речь не о GNOME).

andreyu ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

А чем вообще не угодил HAL? Каковы объективные причины опять плодить зоопарк =(?

raystlin ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Буду смеятся над вашими терзаниями, когда возникнет надобность взмахом руки перекинуть потоки со всех возможных программ-звукогенераторов, например, на bluetooth-гарнитуру; не говорю уж об иных манипуляциях...

jack ?

isden ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Просвяти, а какой ДЕ/ВМ "более правильный"?

Не знаю, что значит слово "Просвяти", но попытаюсь ответить - для каждого свой. Со временем и вы поймете, что привязка к конкретному DE не есть хорошо и гибко. "Стандарт" существующий в рамках определенного DE есть рабство.

andreyu ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> busybox, наверняка mdev и uclibc. То есть система узкого назначения.

А кому нужна "система широкого назначения" в 11, да даже и в 110 мегабайтах?

AlexM ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> Доставил туда ppp, пару необходимейших вещей вроде w3m и vim, теперь 277mb

А-а-а, но как, Поручик?! У меня OVZ-виртуалки для разных "настоящих дистров" начинаются от 80Mb, кажется. Без ядра, ясен пень, и без ppp, но с vim'ом и ssh'ой, разумеется. При этом установка/доставление софта идёт не через "from scratch", а обычным мета-пакетным менеджером, по вкусу.

AlexM ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> отдельные разрабы с шилом в жопе уже объявляют его устаревшим

Почитайте таки Зойтена (David Zeuthen). Вся это *Kit бодяга - это не что иное, как hal версии 2, попиленный на модули и c уточнёнными зонами ответственности. Рефакторинг после версии 1 :)

AlexM ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> А вот в ДОС на 1.44 умещался еще и nc/vc, и можно было работать :)

Начинается... Байки из склепа... Столько не живут... И вообще, самый популярный вариант в те времена - не 1.44 (3.5"), а пятидюймовые _флоппи_ диски. С размерами 360Kb, 720 или 1.2Mb соответственно. Ну, или чуть большим, если удавалось подружить конкретную дискету, конкретный дисковод и hdformat. А на стене в общаге висели 8", упёртые... Впрочем, не скажу откуда, преступления такого рода срока давности не имеют :)

AlexM ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

> "Стандарт" существующий в рамках определенного DE есть рабство.

Нда, с таким подходом я бы остерегался подходить не только к розетке переменного электрического тока, но и к зубной щётке и мыльнице - они-то тоже все более-менее стандартные.

AlexM ★★★★★ ()

Re: Поддержка HAL в PulseAudio объявлена устаревшей

Большинству народа этот РА нафиг не нужен. Только извращенцам с несколькими звукодевайсами, и то - малую часть времени работы за машиной. Лучше бы alsa пилили.

pekmop1024 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.