LINUX.ORG.RU

Elive, выпуск 3.8.18 beta

 , ,


4

1

Периодически, волнами всплывают темы «что использовать на старом железе» и среди советов очень редко встретишь рекомендацию Elive.

Дистрибутив с историей, релизами радует нечасто, 7 января представили очередной beta-выпуск.

Кратко, об Elive:

  • некоммерческий, бесплатный дистрибутив, расчитанный на использование с железом 15-летней давности
  • не требует установки
  • пользовательский интерфейс на E16
  • «полный» набор приложений
  • подробнее здесь

Минимальные требования:

  • 256 MB RAM
  • 500 Mhz CPU

Лично опробован на Eee PC 701, условно комфортно, можно на ЛОРе зависать и офис запустить.

Отличительные особенности нового выпуска, многое непонятно, но в оригинале без подробностей:

  • Debian Buster 10.7
  • E16
  • для тачпадов, возможность отключить реакцию на перемещение в нижней части
  • непосредственная поддержка AppImage
  • улучшение поддержки клавиатуры для MAC при использовании bootsplash, исправление поиска EFI-разделов
  • поддержка графики SIS (Sillicon Integrated Systems 771/671)
  • установщик: ускорение процесса, улучшение в поддержке шрифтов и языков
  • совместимость gnome-terminal с приложениями его использующими
  • улучшение поддержки учётных записей gmail, непонятно из новости, где это используется, но раз отметили в фичах, это наверное что-то полезное

Варианты загрузки beta-версии:

  • 32-bit, бесплатная загрузка в обмен на оставленный e-mail
  • 64-bit, за донат от 5$
  • 64-bit, бесплатно за ревью
  • используя 32-bit версию, обновить до 64-bit через установщик

Так же, можно загрузить стабильную 32-bit версию 3.0.6:

  • бесплатно в обмен на оставленный e-mail
  • за донат от 5$

Ссылки:

Предупреждая комментарии Ъ «так это же дебиан с нескушными обоями», сразу оставлю ответ разработчков:

Over 2500 own packages with detailed customizations, tons of customizations and integrations between parts to communicate and work together, own designs, special and unique features, and the gigantic list of characteristics listed here... definitively this is not just a Debian with enlightenment.

Do not waste your time doing your own customizations which already took 14 years of polished work here.

P.S. Новость написана абсолютно безвозмездно в просветительских целях, без намерения получить экономию в 5$ за ревью.

>>> Подробности

★★★★★

Проверено: Shaman007 ()

Ответ на: комментарий от utanho

тю! вот я помню собирал 8го постгреса на 386SX2-50 и 20 мб. и идешник гига на 4, всё под слакой (больше ничего не заводилось на этой древности). вот это был секас! сделай make -j 3 или там 5 или там 25 (подобрать надо) - ускоришь больше чем при просто -j

mumpster ★★★★★ ()
Ответ на: комментарий от utanho

Мне кажется, твой опыт пользования виндуз неуместен на форуме линукс-пользователей.

Впрочем, я уверен что ты насочиняешь тонну оправданий в ответ на это сообщение.

trynoval ()
Ответ на: комментарий от mumpster

для много -j не хватит оперативы и проца. Колом встанет. На этом старом пеньке максимум -j=3

utanho ★★ ()
Ответ на: комментарий от mumpster

Точный год выпуска не назову, документацию на те компьютеры уже не найти, поэтому очень приблизительно.

ShiningRiver ()

Gentoo для слабых машин хорошо подходит - минималистично и компилируется для целевой архитектуры.

vitaly-zdanevich ()

непосредственная поддержка AppImage

Да объясните уже наконец! Для его работы только fuse в ядре нужен. Который нужен и для других целей. В чём заключается поддержка эта???

hatred ()
Ответ на: комментарий от hatred

В ядре-то оно есть, но без юзерспейсных либ из пакета fuse/fuse3, без которого AppImage’ы работать не будут (будут, но с оговорками) вполне могло быть и не предустановлено.

Singularity ★★★★★ ()
Ответ на: комментарий от Singularity

Так там как раз утилиты типа fusermount. От libfuse оно и не зависит:

$ LANG=C ldd KvmApp-1.0.1-20200807-x86_64.AppImage
	not a dynamic executable

Да оно и понятно: внутри AppImage просто образ сквишфс, который монтируется при помощи loop/fuse.

(будут, но с оговорками)

Это ты про ./foo.AppImage --appimage-extract?

hatred ()
Последнее исправление: hatred (всего исправлений: 2)
Ответ на: комментарий от Singularity

Но оставляет возможность. С другой стороны:

hatred@gaz-laptop:[~]
$ pacman -Qo fusermount
/usr/bin/fusermount принадлежит fuse2 2.9.9-4
hatred@gaz-laptop:[~]
$ pacman -Qi fuse2
Название             : fuse2
Версия               : 2.9.9-4
Описание             : A library that makes it possible to implement a filesystem in a userspace program.
Архитектура          : x86_64
URL                  : https://github.com/libfuse/libfuse
Лицензии             : GPL2
Группы               : Нет
Предоставляет        : fuse=2.9.9
Зависит от           : glibc  fuse-common
Доп. зависимости     : Нет
Требуется            : compiz-easy-patch  exfat-utils  glusterfs  grub  ntfs-3g  xdg-desktop-portal
Опционально для      : libewf  nnn
Конфликтует с        : fuse
Заменяет             : fuse
Установленный размер : 458,21 KiB
Сборщик              : Felix Yan <felixonmars@archlinux.org>
Дата сборки          : Сб 16 мая 2020 20:21:51
Дата установки       : Вт 02 июн 2020 15:39:21
Причина установки    : Установлен как зависимость другого пакета
Установочный скрипт  : No
Проверен             : Подпись

Я думаю, что и на большинстве других консьюмерских машин, типа той же Убунты или Минта оно уже будет стоять, потому как требуется для чего-то ещё. Для всяких продвинутых юзверей, которые знают, что им нужно, распаковка не будет проблемой. В большинстве же случаев, целевая аудитория запустит его без предварительной подготовки.

Тот же snapd нужен только для снапа и весит 63 метра (я думаю, оно ещё что-то подтянет) Flatpak «всего» 8 метров, но снова, нужен только для поддержки своих пакетов.

hatred ()
Ответ на: комментарий от hatred

В чём заключается поддержка эта???

Вот и меня смущает зачем это нужно было выделять в новости о релизе. Как и ряд других моментов.

Ну и чем Elive лучше установки той же Gentoo. Нескучными обоями?

trynoval ()
Ответ на: комментарий от trynoval

Ну я бы не рискнул на своём бывшем EeePC 1001HA собирать генту. Только если кросс-сборкой с чего-то ощутимо более мощного. Но я ленивый и таким бы не стал заморачиваться.

hatred ()
Ответ на: комментарий от tigris

e16 дружит с русским если его самостоятельно собрать из свежих сорцов, я e16 пользуюсь, мне норм

anonymous ()
Ответ на: комментарий от kostyarin_

Вроде уже E20 есть.

Если имеется виду сам Энлайт как оконный менеджер, то уже 24 (0.24.2) https://www.enlightenment.org/download https://phab.enlightenment.org/w/packaging_status/

Разработчики сами называют текущее поделие Е24:

E16 is predecessor of the current E24 Enlightenment Window Manager, which is rather complete rewrite than incremental update of E16. 

https://www.enlightenment.org/e16

Guix ()
Ответ на: комментарий от anonymous

собери из свежих сорцов, проблем не будет

anonymous ()
Ответ на: комментарий от karton1

Я думаю вменяемые люди просто оставят одноразовую почту, благо сервисов полно

Вменямые люди пройдут мимо этого претенциозного болгеноса.

anonymous ()
Ответ на: комментарий от hateyoufeel

Прекрасно! E16 офигенен.

Ничо так. Особенно анимация сворачивания-разворачивания окон чотенькая, в Е24 она поскучнее.

Дистр для старых машин вполне годен, рекомендую.

Guix ()
Ответ на: комментарий от Landgraf

Попробовав с десяток дистрибутивов «для старых пк» понял, что таких просто не существует, ибо отжирать по 700 мб при двух запущенных приложениях - это не для старых пк, а «легковесные DE», которые экономят при это 50-100 мб, это просто смех.

Попробовав с десяток дистрибутивов «для старых пк»

Каких?

Guix ()
Ответ на: комментарий от tigris

В первом мире большинство разработчиков не в курсе о существовании русского языка и того, что у оного языка другой алфавит. И потом, аборигены должны страдать! Вот если бы мы были авторами интерента и кодовых таблиц, все они вынуждены были бы знать, сколько будет 'ю'-'ъ'!

Vudod ★★★★★ ()
Ответ на: комментарий от Landgraf

Это верно отчасти. Если не брать совсем древние компы, что что-то 10-14 летней давности с 64 бит и 2-4 Гб ОЗУ, то грамотный выбор дистрибутива и ДЕ делает такие компьютеры ограниченно работоспособными и пригодными для реальных задач: можно печатать и сканировать, набирать в офисе и ТеХе тексты и читать pdf, программировать (большие проекты на Си++, естественно, не предлагать, а вот писать скрипты на Питоне или клепать формы в Лазарусе вполне сойдёт). Хотя браузер, конечно, это боль.

Vudod ★★★★★ ()
Ответ на: комментарий от hatred

Вопрос в том, что именно этот дистрибутив даёт в сравнении с тем что уже было сделано в своё время по оптимизации в линуксе. К примеру на EEEPC у меня в своё время отлично летало. Только если некоторый свежий софт собрать, вроде видео-кодеков.

trynoval ()

E16

Он все такой же кривой? Помню юзал лет 6 назад, вроде норм но постоянно где-то что-то отваливалось

upcFrost ★★★★★ ()
Ответ на: комментарий от hatred

я в курсе! но PIII был хорош и сбалансирован и справлялся. в отличие от AMD Athlon и PIV, особенно огрызков типа Celeron 1.7.

mumpster ★★★★★ ()
Ответ на: комментарий от Vudod

64 бита и 4 гига ОЗУ в 2007? да вы барствовали как я погляжу!

mumpster ★★★★★ ()
Ответ на: комментарий от hatred

два чая этому господину! но я уже писал, вынужденно собирал в середине 2000-х постгрес на 386sx о 20 мб ОЗУ. вангую что на еепц сборка ядра примерно также бы выглядела.

mumpster ★★★★★ ()
Ответ на: комментарий от Landgraf

список выглядит как начало какой-то сишной проги, особенно объявление puppy как void )))

mumpster ★★★★★ ()

А по нормальному его можно скачать? Нормально это без регистраций и донатов,если что

d09 ()
Ответ на: комментарий от koshmar

Тогда понятно, они дебиан за 5 баксов продают

там можно 10000 выбрать

xowis ()

Чем это сделанное ради доната поделие лучше чем бесплатная Bodhi?

anonymous ()

Этот дистр в том числе не взлетел, из за того, что всегда требовал донат и его нельзя было попробовать нормально

Лет за 10 ничего не изменилось.

koshmar ★★★ ()
Ответ на: комментарий от koshmar

Со слов того, кто им занимается, на донаты имеет возможность делать это fulltime.

Может, конечно, лукавит или это устаревшая информация, но я бы не был так категоричен в определении нужности или ненужности.

vvn_black ★★★★★ ()
Ответ на: комментарий от koshmar

я наврал кстати про 386, 486sx на самом деле.

а сейчас сколько?

mumpster ★★★★★ ()
Последнее исправление: mumpster (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.