LINUX.ORG.RU
Даже не написали - будет ли поддерживаться только клиент или клиент и сервер одновременно?
Впрочем это уже всё равно. NFS RIP независимо от версии.
geekkoo ★
()
Кто-нибудь может в кратце рассказать об основных отличиях(улучшениях) nfsv4 от nfsv3? А то гугл про идни игушки ссылки пихает.
Killy ★
()
а смысл???

когда это до десктопов доберется?

cleg ★
()
Ответ на: комментарий от gr_buza
>>ну да, "настаящие гентушнеги йузайут самбу"

Пуркуа бы и не па? Самба кроссплатформенная, с сильной аутентификацией хрен знает с какого времени в отличии от NFS. А с NFS даже из этой новости не понятно - будет ли поддерживаться только клиент (патчи довольно давно были готовы) или сервер тоже? А то может быть, чтобы попользоваться этой NFSv4, придётся санками затариваться.
Это в том случае, если не брать в рассчёт более экзотические сетевые ФС.
geekkoo ★
()
Ответ на: комментарий от geekkoo
самба (в существующем виде, AFAICR) не держит ни аклей, ни посиксовых расширений.

я уже не говорю про экзотику типа MAC (да, она почти никому не нужна, и фсе такое :))

gr_buza ★★★★
()
Ответ на: комментарий от anonymous
>>на каждом компе в локалке фтп-сервак поднимать или sshfs рулит миром?

Сам же все знаешь, что спрашивать тогда? На каждом компе nfs сервак поднимать тебе, значит, не влом.
Про самбу уже сказали.
geekkoo ★
()
Ответ на: комментарий от anonymous
А оно разве небыло в ядре уже год как а то и больше? Или чтоб попробовать надо ждать несколько лет пока Red Hat соберет ядро с его поддержкой?
DuSoft ★
()
Ответ на: комментарий от geekkoo
>Основное - добавлено strong authentication.
И это все? Не верю (с)

ладно... пойду почитаю доки...
Killy ★
()
Ответ на: комментарий от gr_buza
> самба (в существующем виде, AFAICR) не держит ни аклей, ни посиксовых расширений.

Наглая ложь! Самба уже сто лет как поддерживает posix extention и acl:
man mount.cifs

man smb.conf
Default: unix extensions = yes
anonymous
()
Ответ на: комментарий от gr_buza
>>самба (в существующем виде, AFAICR) не держит ни аклей
ACL при отсутствии сильной аутентификации бессмысленны. Авторизация всегда идет вслед за аутентификацией, а не наоборот.
geekkoo ★
()
Ответ на: комментарий от anonymous
гм, собсно, указывает на основную приятную фичу, указывая fsid=0 на серваке для корня расшаренной ветки, избавляем клиента от необходимости знать, как называется расшаренный ресурс, достаточно ip, только в нфс4 ли это появилось?
anonymous
()
Ответ на: комментарий от anonymous
>>>указывает на основную приятную фичу, указывая fsid=0 на серваке для корня расшаренной ветки,

Только эта фича предполагает, что каждый сервер экспортирует только одну директорию. Тогда действительно - указывать название расшаренной директории становится излишеством.
geekkoo ★
()
Ответ на: комментарий от geekkoo
да, директория экспортируется одна, но на поддиректории устанавливаются отдельные правила доступа: фактически тоже самое, что и при использование фтп
anonymous
()
Ответ на: комментарий от geekkoo
> Пуркуа бы и не па? Самба кроссплатформенная, с сильной аутентификацией хрен знает с какого времени в отличии от NFS.

а то что она тормозит как хрен знает что никто в расчет не берет чтоли (ядерный cifs имею ввиду)? у меня nfs выдает 11MB/s, а самба с mount -t cifs дает всего 5-7...

//baz

anonymous
()
Ответ на: комментарий от anonymous
>>у меня nfs выдает 11MB/s, а самба с mount -t cifs дает всего 5-7

Ну и что? Для каких задач такая разница в скорости будет существенна?
geekkoo ★
()
Ответ на: комментарий от geekkoo
А самому подумать? Скопируй рекурсивно распакованные сорцы ядер 2.6.* c smb-шары, много нового узнаешь.
e
()
Ответ на: комментарий от geekkoo
>NFS RIP независимо от версии.

Посмеемся с идиотов?

NFS Maestro Server 2006 Enterprise Edition

Поддержка NFS

* Поддерживает NFS v 2, 3 и 4 (RFC1094, RFC1813, RFC3530)
* Kernel Mode
* Поддерживает Microsoft Volume Shadow Copy Service (VSS)
* Microsoft Cluster Aware
* Поддерживает неограниченное количество клиентов и экспортируемых файловых систем
* Поддерживает WebNFS (RFC2054) и NFS поверх TCP
* PCNFSD v1.0 для аутентификации NFS-клиентов
* Поддерживает NTFS и FAT32
* Поддерживает 32-bit File locking
* Показывает статистику сервера (Read/Write и Mount/Lock/PCNFSD Requests)
* Поддерживает 64-bit Cookies

Поддержка службы каталогов

* Поддерживает NIS, NIS+ и LDAP
* Поддерживает Microsoft Active Directory
* Поддерживает RFC2307, RFC2307AIX, AD4UNIX и Vintela VAS
* Поддерживает NETGROUP

Name Mapping Server

* Автономный сервер, который отображает Windows пользователя или группу в UNIX UID и GID.
* Интеграция со службой каталогов.
* Поддерживает Auto mapping.

Sun-ch ☆
()
Ответ на: комментарий от e
Тем не менее, находятся идиоты, которые предлагают между юниксовыми машинами использовать самбу, они наверное бездисковые воркстейшены, тоже через самбу подключают.
Sun-ch ☆
()
Ответ на: комментарий от Sun-ch
>>бездисковые воркстейшены, тоже через самбу подключают.

бездисковые воркстейшены тоже RIP. Диск 100 баксов стоит. Или контора это себе не может позволить?
geekkoo ★
()
Ответ на: комментарий от e
400 баксов что клиент, что сервер. Красиво жить не запретишь, понятное дело, но преимущества по сравнению с самбой не очевидны. За что деньги платить?
geekkoo ★
()
Ответ на: комментарий от geekkoo
> бездисковые воркстейшены тоже RIP. Диск 100 баксов стоит.

1. диски - это таки излишний шум и хранение инфы в одном месте (либо система бекапа и все что она за собой тянет)
2. бездисковые решения подразумевают что я могу начать работать за _любой_ станцией в оффисе, имея _свое_ окружение, домик, етц и настройки WM, сразу после ввода логина-пароля.
isden ★★★★★
()
Ответ на: комментарий от Sun-ch
> Тем не менее, находятся идиоты, которые предлагают между юниксовыми машинами использовать самбу, они наверное бездисковые воркстейшены, тоже через самбу подключают.

Ааа, ну-ну... у нас вот тоже какой то придурок из бехопасников предлагал для защищенных коммуникаций M$ messenger пользовать... не лечится.

e
()
Ответ на: комментарий от geekkoo
> 400 баксов что клиент, что сервер. Красиво жить не запретишь, понятное дело, но преимущества по сравнению с самбой не очевидны. За что деньги платить?

Поди почитай: http://wiki.linux-nfs.org/index.php/Comparison_of_NFS_vs._others, http://www.citi.umich.edu/projects/nfsv4/linux, тоже мне, четырехбаксовик нашелся. За coreutils небось платишь в обязательном порядке?

e
()
Ответ на: комментарий от isden
>>бездисковые решения подразумевают что я могу начать работать за _любой_ станцией в оффисе, имея _свое_ окружение, домик, етц и настройки WM, сразу после ввода логина-пароля.

Или не сможет работать никто, если сеть или сервер заглючит. По-моему сейчас большинство склоняется к мысли, чтобы пользовательские настройки держать в LDAP, а не на диске. Поэтому (пока что) это еще как-то оправдывает существование NFS, но долго так продолжаться не будет.
geekkoo ★
()
Ответ на: комментарий от isden
я бы даже дополнил пункт2: они обязывают начинать работу со своими документами, только имея свое окружение пароль и т.д. Сервер может быть недоступен для большинства физически, то есть варианты пришел вставил установочный диск лины, подмонтировал жесткий и слил на флэшку не проходят
anonymous
()
Ответ на: комментарий от geekkoo
> бездисковые воркстейшены тоже RIP. Диск 100 баксов стоит. Или контора это себе не может позволить?

Дык понятно, у нас студенческие поделки скоро на энтерпрайз-левел выйдут, магистрали будут строить на телефонной лапше, а срорейджи подключать по VPN-у. Проснись, дорогой, 100 баксов - стоит хороший терминал от тех же Санок ;)

e
()
Ответ на: комментарий от geekkoo
> Или не сможет работать никто, если сеть или сервер заглючит. По-моему сейчас большинство склоняется к мысли, чтобы пользовательские настройки держать в LDAP, а не на диске. Поэтому (пока что) это еще как-то оправдывает существование NFS, но долго так продолжаться не будет.

Вот-вот, простейшего резервирования моск труЪ-бородатого админа-самбиста ни разу ниасиливает, а также не видит разницы между службой каталогов (не в виндавозном понимании - даю подсказку) и сетевой ФС, а также возможности работать с тем и тем полностью независимо друг от друга.

e
()
Ответ на: комментарий от geekkoo
> бездисковые воркстейшены тоже RIP

Ну незнаю. Мне проще управлять одним серваком где все файлы храняться (в том числе и системные). Чем на куче машин файлопомойки разгребать.

BigKAA ★
()
Ответ на: комментарий от Sun-ch
> А причем тут студенты? Контора заплатит.

Она и платит. За Солярку с железом.

e
()
Ответ на: комментарий от e
>>простейшего резервирования моск труЪ-бородатого админа-самбиста ни разу ниасиливает

Резервирования чего? NFS не поддерживает fail-over кластеры. NFS сервер грохнулся, после чего бездисковые NFS-клиенты нервно курят в сторонке и ждут, когда он подымется.

>>не видит разницы между службой каталогов (не в виндавозном понимании - даю подсказку) и сетевой ФС, а также возможности работать с тем и тем полностью независимо друг от друга.

И продолжать упорно хранить пользовательские настройки на расшаренном диске.
geekkoo ★
()
Ответ на: комментарий от geekkoo
Вы весь $HOME запихивать в LDAP собираетесь? Если сеть или сервер заглючит - да, вилы. Но они в любом случае вилы, если не применять хитрого кеширования профилей и файловых систем (кажется, у санок на эту тему было что-то, называлось Solstice - если я ничего не путаю).
svu ★★★★★
()
Ответ на: комментарий от e
Предположим, мне их нужно 10 штук. И по 100 баксов. Предлагаешь рыться на e-bay в поисках подходящего предложения?
geekkoo ★
()
Ответ на: комментарий от svu
>>Вы весь $HOME запихивать в LDAP собираетесь?

Не весь, понятное дело, а только dot файлы. Вы же и рассказывали, как можно будет замечательно хранить настройки из gconf в LDAP. Или я чего-то не так понял?
geekkoo ★
()
Ответ на: комментарий от geekkoo
gconf в ldap - это самое оно! Просто пользователи (гады такие) еще и документы у себя на диске хранят, всякие файлики-шмайлики. Я уж не говорю о том, что еще есть пережитки тяжелого прошлого - программы, не использующие gconf...
svu ★★★★★
()
Ответ на: комментарий от geekkoo
>Резервирования чего? NFS не поддерживает fail-over кластеры. NFS сервер грохнулся.

Sun Cluster Hign Availability для службы данных NFS.
Sun-ch ☆
()
Ответ на: комментарий от geekkoo
> Резервирования чего? NFS не поддерживает fail-over кластеры. NFS сервер грохнулся, после чего бездисковые NFS-клиенты нервно курят в сторонке и ждут, когда он подымется.

Не обязательно, можно монтировать с разных серверов и задавать поведение с таймаутами - выйдет не "нервно курят", а "укуренно ждут" кого-то отвалившегося.

> И продолжать упорно хранить пользовательские настройки на расшаренном диске.

Нафиг? Хотя да, для самбистов иначе никак...

e
()
Ответ на: комментарий от geekkoo
> Резервирования чего? NFS не поддерживает fail-over кластеры. NFS сервер грохнулся, после чего бездисковые NFS-клиенты нервно курят в сторонке и ждут, когда он подымется.

за 2+ года работы не было возможности работать с бездисковой станции только 1 раз, когда отрубилось электричество на весь день. UPSки на рабочих станциях сдохли через несколько часов, и серваки были заглушены. после этого случая установили автономный генератор (год назад почти), с тех пор проблем вообще никаких. вывод - нормальное железо + бэкапы + паралельный NFS сервак + прямые руки сотрудников отдела IT admin рулят. ибо NFS сервер при грамотном подходе может грохнутся только по причине отказа хардвари.
isden ★★★★★
()
Вы не можете добавлять комментарии в эту тему: топик перемещен в архив.