LINUX.ORG.RU

Mesa 7.10

 , , ,


0

1

Вышла новая версия свободной реализации OpenGL от freedesktop.org — mesa 7.10. Одновременно выпущен корректирующий релиз 7.9.1, содержащий исправления ошибок.

По традиции, данная версия является нестабильной. Пользователям рекомендуется дождаться 7.10.1, либо использовать 7.9.1.

Новые расширения:

  • GL_ARB_explicit_attrib_location (Intel, software)
  • GL_ARB_texture_rg (Intel, software, gallium)
  • GL_EXT_separate_shader_objects (Intel , software)
  • GL_NV_primitive_restart (Gallium softpipe, llvmpipe)

Новые возможности:

  • Новый fragment shader back-end для карт Intel i965
  • Поддержка Intel Sandybridge в драйвере i965
  • Поддержка AMD Fusion и Nothern Islands в драйверах r600 и r600g

Также 7.9.1 и 7.10 содержат многочисленные исправления ошибок и оптимизации (в 7.10 значительно ускорены gallium-based драйверы).

Скачать архивы с исходным кодом можно здесь: 7.9.1, 7.10

Сайт проекта пока не обновлен, поэтому ссылка «Подробности» ведет на html-страничку, отдаваемую в plain text.

>>> Подробности

★★★★★

Проверено: Shaman007 ()

Ответ на: комментарий от Behem0th

вот из spec файла,

configure --prefix=/usr --with-dri-drivers=i810,mach64,r128,r200,radeon,tdfx,sis,savage,mga,unichrome \  
--enable-gallium-radeon \  
--enable-gallium-r600 \  
--enable-gallium-swrast \  
--enable-gallium-i965 \  
--enable-gallium-i915 \  
--enable-gallium-egl \  
--enable-gallium-nouveau \  
--enable-xcb \  
--enable-openvg \  
--enable-gles2 \  
--enable-gles1 \  
--disable-glw \  
--disable-glut  

Novell-ch ★★★★★ ()
Ответ на: комментарий от devl547

какие ещё нервы?
у меня и скролл плавные и с 2D проблем вообще нет - что не так-то?
может я просто пользуюсь не гавном мамонтов? я про не использование композита

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>гавном мамонтов

gt240m + дрова 256.x.x и 260.x.x
К сожалению ничего из этого таковым не является.

//И да, под виндой все летает.

devl547 ★★★★★ ()
Ответ на: комментарий от Novell-ch

Странно, у меня вот так:

--prefix=/usr \
--with-dri-driverdir=/usr/lib/xorg/modules/dri \
--with-dri-drivers= \
--enable-glx-tls \
--with-driver=dri \
--enable-xcb \
--disable-egl \
--disable-glut \
--enable-gallium-r600 \
--with-state-trackers=dri,xorg

И гдето пол года назд это работало.

Behem0th ★★★★★ ()
Ответ на: комментарий от megabaks

включение-отключение композита ничего не дает.
И да, это уже костыль.

devl547 ★★★★★ ()
Ответ на: комментарий от devl547

>включение-отключение композита ничего не дает.
4.2!

megabaks ★★★★ ()
Ответ на: комментарий от Behem0th

ну без --enable-gallium-radeon оно и не будет работать, это state tracker для r300. и я никогда --with-state-trackers не указываю, меса сама выбирает какие нужны.

Novell-ch ★★★★★ ()
Ответ на: комментарий от megabaks

>4.2!

могу повторить - у тебя может что-то и есть. У себя я долбался с блобом полгода. В итоге оказалось проще перейти на nouveau.

devl547 ★★★★★ ()
Ответ на: комментарий от Novell-ch

Тоесть на r600 работать и не должно? Я указываю чтоб лишние не собирать).

Behem0th ★★★★★ ()

Ну когда же наконец замутят OpenGL 3.0 там.

Marisa ()
Ответ на: комментарий от Behem0th

Но там есть еще вроде проблема что какоето расширение запатентовано и как с ним быть хз решили или нет.

Behem0th ★★★★★ ()
Ответ на: комментарий от Dragomir

Пробовал, не помогает. И не должен (это не проблема vblank)

devl547 ★★★★★ ()

Нафига вам OpenGL >=3 в linux? Из всех фич тут по-моему самая бесполезная.

anonymous ()

видекарты - это сама большая проблема для линуксов.

ipeacocks ★★★★★ ()
Ответ на: комментарий от KroArtem

когда-то ставил галлиум дрова на 10.10 - так после того при удалении их же по зависимостях аптитуд предлагал удалить все GUI-программы системы.

ipeacocks ★★★★★ ()
Ответ на: комментарий от ipeacocks

>когда-то ставил галлиум дрова на 10.10 - так после того при удалении их же по зависимостях аптитуд предлагал удалить все GUI-программы системы.

убанта, такая убанта. может стоит одуматься и выбрать норм дистр? дебиан например.

SimonPhoenix ()

Kwin потянет с графическими эфектами?

или тормозить будет?

zibert ★★★ ()
Ответ на: комментарий от zibert

На р600г сижу как раз с включенным эффектами в квин.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

S3TC S3TC support has been partially implemented in Mesa. We cannot integrate and enable S3TC code by default due to the patents on the algorithm. Because of this, to be cautious, code was integrated to only attempt to open an external library, libtxc_dxtn.so, and use a small number of functions from that to implement S3TC if available.

KroArtem ★★ ()
Ответ на: комментарий от KroArtem

Есть еще какоето расширение вроде, значит их там 2 про S3TC я чет забыл.

Behem0th ★★★★★ ()
Ответ на: комментарий от ipeacocks

>при чем тут убунта?

ну в дебиане аптитюд не предлагает полсистемы снести есличо при удалении дров

SimonPhoenix ()
Ответ на: комментарий от Pinkbyte

Это вы говорите ересь и ерунду. Как пользователь gf9400gt и последнего nvdidia-драйвера говорю, что НИКОГДА не нужно было перезагружать иксы после изменения конфига.

А на gf4 440mx нужно было. У вас просто старые дрова, да.

skvitek ★★ ()
Ответ на: комментарий от skvitek

>У вас просто старые дрова, да.

Так я ничего и не говорил про драйвера для новых видеокарт. Только про nvidia-legacy(173 серия), которые у меня собственно на Geforce FX 5500 и работают...

Pinkbyte ★★★★★ ()
Ответ на: комментарий от seed_stil

>грац)

не с чем, я на нуво уже год сижу

kwin с композитом заводится?


заводится, работает. Не тормозит.

devl547 ★★★★★ ()
Ответ на: комментарий от devl547

и еще 2 вопроса плз: какой дистрибутив и собирал сам или из реп?

seed_stil ★★ ()
Ответ на: комментарий от seed_stil

>какой дистрибутив и собирал сам или из реп?

gentoo, оверлей x11

media-libs/mesa-9999 (плюс я себе еще openvg добавлял в сборку)

devl547 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.