LINUX.ORG.RU

Вышел Catalyst 10.5

 , ,


0

0

Основные изменения:

  • Исправлены ошибки, связанные с Hybrid CrossFire
  • Исправлены ошибки, из-за которых не запускались некоторые игры в Wine
  • Реализована начальная поддержка SUSE Linux Enterprise Desktop / SUSE Linux Enterprise Server 11 Service Pack 1
  • Устранены проблемы, вызывающие панику ядра при переходе в ждущий или спящий режим

К сожалению, X-сервер 1.8 в текущий момент не поддерживается и скорее всего не будет поддерживаться в ближайшем будущем.

>>> Подробности

★★★★★

Проверено: maxcom ()

Ответ на: комментарий от anonymous

В gentoo есть варианты:
http://packages.gentoo.org/package/x11-base/xorg-server

арч - это несчастный случай

А собственно ,почему я работая в конторе за деньги, должен отрабатывать
постоянно очередные диверсии (под соусом развития) ваятелей свободно ПО с 2...4 % присутствия на рынке ? Ась ?
А бы тока они на форумах не гавкали, да ?


elipse ★★★ ()
Ответ на: комментарий от elipse

> А собственно ,почему я работая в конторе за деньги, должен отрабатывать постоянно очередные диверсии (под соусом развития) ваятелей свободно ПО с 2...4 % присутствия на рынке ? Ась ?

Да кто говорит, что должен? Засуньте своё бинарное говнецо туда, откуда оно вылезло, да и всё тут.

anonymous ()

> К сожалению, X-сервер 1.8 в текущий момент не поддерживается и скорее всего не будет поддерживаться в ближайшем будущем.

Сильно.

andreyu ★★★★★ ()

С 1.8 работают и 10.4 дрова. Патчик ставите - вот и все дела.

Только смысл какой? Типа, «всегда идем в ногу со временем»? Или «смерть халу!»? Однохренственно - что 1.6, что 1.7, что 1.8. Пока жирный пИнгвин не включит бОльшую часть часть функционала в ядро, тормоза будут оставаться такие, какие и в Вин3.1 не наблюдались. Но ядропилителям на десктопников накакать (хорошо, что пИнгвины не летают!).

GluckMan ★★★ ()
Ответ на: комментарий от GluckMan

> Пока жирный пИнгвин не включит бОльшую часть часть функционала в ядро

Иксы, *kit'ы и прочее в ядре точно не нужны. Хватает сотни драйверов, которые там есть сейчас (и которые неплохо б было тоже наружу вынести, нефиг ядро утолщат).

pevzi ★★★★★ ()
Ответ на: комментарий от GluckMan

>С 1.8 работают и 10.4 дрова. Патчик ставите - вот и все дела.

Вот меня удивляет такой простодушие. А разрабы каталиста дураки или вредные, ну влом им влючить xorg-server-1.8 в список поддерживаемых? Так? Ну пропатчили, обманули каталист и кучу другого софта сказав что у вас xorg-server-1.7 а не 1.8, но несовместимости то остались(глючки, тормоза)

TheMixa ★★★ ()
Ответ на: комментарий от pevzi

А какая разница уже десктопе ? ))
Все равно уже версии ядра, xorg, libdrm, mesa ,видеодрайвера
для свободных решений прибиты гвоздями. Шаг влево, шаг в право - сразу регресс. У любого закрытого видеоблоба диапазон рабочих вариантов версий софта значительно выше.

elipse ★★★ ()
Ответ на: комментарий от pevzi

> Я прям слышу, как юзеры нвидии хихикают в сторонке (:

да это не хихиканье, а дикий гогот уже :D

/me довольный обладатель карты от nvidia

anonymous ()
Ответ на: комментарий от no-dashi

>Уже нет. Компиз на nouveau в федоре бегает как наскипидаренный, при этом ноут практически не греется.

Nouveu _никогда_ не будет лучше проприетарного драйвера, если NVidia не откроют спеки, а они этого не сделают.

Yareg ★★★ ()
Ответ на: комментарий от pevzi

>и которые неплохо б было тоже наружу вынести, нефиг ядро утолщат

Не надо так беспокоиться за зеркала kernel.org, места у них пока хватит.

anonymous ()
Ответ на: комментарий от GluckMan

> Пока жирный пИнгвин не включит бОльшую часть часть функционала в ядро

угу, и кеды с гномом тоже айда в ядро пихать, чтобы хрюшку-gluckman'а не расстраивать ))

капча advocates unaware какбе намекает...

anonymous ()
Ответ на: комментарий от Yareg

> Nouveu _никогда_ не будет лучше проприетарного драйвера

По мне, так оно уже сейчас лучше. В общем зачёте (удобство установки, обновления, возможности).

anonymous ()
Ответ на: комментарий от anonymous

удобство установки - идет по умолчанию в дистрибутивах? обновления - не чаще официальных возможности - ну да, kms есть. Можно быстро попереключаться между графикой и консолью

note173 ★★★★★ ()

Мало того, что ATI/AMD карточки фиговые делает, так оно еще и дрова нормальное сделать не способно. Фтопку!
//счастливый пользователь nvidia

PS. ATI/AMD всегда будут применятся только мазохистами - для не особо производительной графики есть Intel с отличнейшими свободными дровами, для производительной графики - NVIDIA с отличными, но проприетарными драйверами.

Deleted ()
Ответ на: комментарий от note173

> удобство установки - идет по умолчанию в дистрибутивах, обновления - не чаще официальных

Включил один раз в ядре и не надо модули пересобирать и париться. Обновляешь ядро — обновляется и DRM. Иксовые дрова обновляются вместе с системой. Никаких «ай, блять, забыл перебрать nvidia-drivers под новое ядро». Никаких «ай, блять, я обновил nvidia-drivers, и теперь не могу открыть новую сессию иксов, потому что загружен старый ядрёный модуль, а новые дрова хотят новую версию». Как-то я от этого подустал.

Возможности — KMS и Xrandr, быстрое 2D. Мне хватает. Желаете гробить свою жизнь на игрушки — пожалуйста, но без меня. Хвалёное vdpau разгружает проц не так сильно, чтоб как-то о нём сожалеть. Ну не компиляет никто во время просмотра ч0ткого видео, не смешите меня.

anonymous ()
Ответ на: комментарий от Deleted

>PS. ATI/AMD всегда будут применятся только мазохистами - для не особо производительной графики есть Intel с отличнейшими свободными дровами, для производительной графики - NVIDIA с отличными, но проприетарными драйверами.

Из поддерживаемых ос проблемы возникают только на линупсе. Это как бы показатель того что из себя предстовляет линупс

anonymous ()

Сволочи выкинули мою 9600ХТ из поддержки еще черт знает когда. Закопать их.

upcFrost ★★★★★ ()
Ответ на: комментарий от anonymous

ЛОЛ!

testing/nvidia 195.36.24-2 [installed]
NVIDIA drivers for kernel26.
testing/nvidia-utils 195.36.24-2 [installed]
NVIDIA drivers utilities and libraries.


testing/xorg-server 1.8.1-1 [installed] (xorg)
X.Org X servers

pztrn ★★★★ ()
Ответ на: комментарий от TheMixa

>Вот меня удивляет такой простодушие. А разрабы каталиста дураки или вредные, ну влом им влючить xorg-server-1.8 в список поддерживаемых? Так? Ну пропатчили, обманули каталист и кучу другого софта сказав что у вас xorg-server-1.7 а не 1.8, но несовместимости то остались(глючки, тормоза)

Разрабы каталиса, быть может, и дураки. Но, скорее всего, их просто мало и у них ограничены ресурсы, а все основные силы бедных индо-китайцев брошены на виндовые дрова, что весьма логично и правильно в нынешнем подзаборном положении гну-шной оси. Капитализьм, однако.

По поводу глюков и тормозов. Чушь полнейшая. Где? Явки, пароли, назовите, пожалуйста. Или сорока на хвосте начирикала?

Никаких глюков и тормозов. Более того, никакой разницы при переходе между 1.6, 1.7, 1.8 пользователь (лично в моем лице) не ощущает вообще! Ну нет никакой разницы - ни в скорости, ни в устойчивости. Ни в чем. И багов в багзилле генту тоже нет, связанных именно с бедами от fgrlx и 1.8. Есть парочка веток в форуме для владельцев экзотики, и всё.

Все глюки и тормоза - от убогой архетектуры линюкс в поле системы графического вывода.

Хотя, я понимаю: внутренний голос сказал, что за окном - миллион.

GluckMan ★★★ ()
Ответ на: ЛОЛ! от pztrn

Re: ЛОЛ!

> ЛОЛ!

Что ты лолкаешь, дебилушка? Перечитай повнимательнее, если плохо с первой попытки получается.

anonymous ()
Ответ на: ЛОЛ! от pztrn

Ах да, забыл:
core/kernel26 2.6.33.4-1 [2.6.34-1 installed] (base)
The Linux Kernel and modules

pztrn ★★★★ ()
Ответ на: Re: ЛОЛ! от anonymous

Где отставание нвидии от ядра? Где глюки с xorg 1.8? Почему compiz standalone не жалуется? Почему я спокойно играю во второй сессии иксов?

А ведь ваша АТИ этого не может (все равно с какими дровами), а если и может - то через жопу и очень медленно - найух надо?

pztrn ★★★★ ()

> X-сервер 1.8 в текущий момент не поддерживается и скорее всего не будет поддерживаться в ближайшем будущем.


Мда. Открытые дрова то у ATI хоть приемлемые? Относительно нуво, например.

Deleted ()
Ответ на: комментарий от pztrn

>Где глюки с xorg 1.8?

вот на фига непременно свежая версия капризной прокладки под закрытый драйвер ?
Смысл ?
Отпонтоваться тут и все ?
Или дистр такой «для продвинутых катусоедов»

elipse ★★★ ()
Ответ на: комментарий от pztrn

> Где отставание нвидии от ядра?

На .33-м было. Собственно, тогда я и свалил на nouveau на работе. Тупо не собирались дрова. Теперь уже не в курсе, что там и как.

Почему я спокойно играю во второй сессии иксов?

А почему не должен?

anonymous ()
Ответ на: комментарий от no-dashi

Уже нет. Компиз на nouveau в федоре бегает как наскипидаренный, при этом ноут практически не греется.

Думал вновь перейти на него с блоба, но увидев это передумал :(

Deleted ()
Ответ на: комментарий от Deleted

Что «мда»
Ты спроси лучше у кого нормально 3D работает на свободных дровах
под ATI c xorg 1.8 ...1.8.1 .
Правда, будут сразу доказывать, что 3D серьезным людям под Linux совсем не к чему.

elipse ★★★ ()
Ответ на: комментарий от Deleted

ололо, они лучше чем нуво, на нуво дум3 и HON хоть запустится? плюс уже есть рабочее управление питанием, а нуво только и может что раскочегаривать видеокарту.

Novell-ch ★★★★★ ()
Ответ на: комментарий от elipse

> В gentoo есть варианты: http://packages.gentoo.org/package/x11-base/xorg-server

арч - это несчастный случай


Согласен, но честно скажу, откатываться на что то старее ~amd64 мне ещё не приходилось :). Что у вас там всё глючит - одному богу известно.

Deleted ()
Ответ на: комментарий от elipse

> Правда, будут сразу доказывать, что 3D серьезным людям под Linux совсем не к чему.

Именно. То, что работает, то хорошо, но главное, чтобы и 2D было нормальным.

Deleted ()
Ответ на: комментарий от alius-miles

>При включенном KMS при загрузке зависает на полминуты, ищет firmware.. (2.6.34, mesa, xf86-video-ati, libdrm из гит).
А ты kernel26-firmware (или как оно в твоём дистрибутиве) ставил?

x3al ★★★★★ ()
Ответ на: комментарий от Deleted

fglrx & xorg 7.7 - все работает нормально
тут же карнавал у неосиляторов какой-то. хз какие у них проблемы

elipse ★★★ ()
Ответ на: комментарий от Novell-ch

> на нуво дум3 и HON хоть запустится?

Да. Но меня 3D ни коим образом не интересует, если бы его не было вообще - не умер бы.

ололо, они лучше чем нуво, на нуво дум3 и HON хоть запустится? плюс уже есть рабочее управление питанием, а нуво только и может что раскочегаривать видеокарту.


А с libre-kernel они работают? Не подумай ничего плохого - я просто интересуюсь :)

Deleted ()
Ответ на: комментарий от elipse

> А «Нормально» слово такое знакомо ?

и да, и не ублюдочных 15 ..20 % от блоба.

«Вот в прошлом году случай был…»: один человек обнаружил внезапно, что у него glxgears выдают на свободных дровах больше FPS, чем на закрытых.

А ты kernel26-firmware (или как оно в твоём дистрибутиве) ставил?

В Gentoo это radeon-ucode

anonymous ()
Ответ на: комментарий от anonymous

>«Вот в прошлом году случай был…»: один человек обнаружил внезапно, что у него glxgears выдают на свободных дровах больше FPS, чем на закрытых.

Ха ха ха, Я это хоть сейчас могу обнружить
И что ? Реально то 3D-апликухи толком и не пашут, а шестерни fglgears бодренько вертятся.

elipse ★★★ ()
Ответ на: комментарий от elipse

> Ха ха ха, Я это хоть сейчас могу обнружить

И что ? Реально то 3D-апликухи толком и не пашут, а шестерни fglgears бодренько вертятся.

А чего ты тогда лезешь со своими процентиками, шут гороховый, если их и подсчитать нельзя?

anonymous ()
Ответ на: комментарий от anonymous

Ога правда на свободных для 3ххх, 4ххх там 2д только...

4.2

у меня интеграшка 4200

[yr@dream matrix]$ glxinfo 
...
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: Mesa DRI R600 (RS880 9710) 20090101  TCL
OpenGL version string: 2.0 Mesa 7.8.1
OpenGL shading language version string: 1.10
...

подглючивает конечно, но в urbanterror вполне можно побегать.

vyv ★★ ()
Ответ на: комментарий от elipse

Хе-хе-хе, то есть меня как-то должны урезонить твои необоснованные словоизвержения? Ну-ну.

Да сиди ты на своих fglrx, жалко мне, что ли? Я с ними завязал с тех пор, как понял, что из-за них ноут заснуть не может. И обнаружил себя в волшебном царстве быстрого 2D, и отсутствия необходимости тянуть по 80 Мб сомнительного бинарного фуфла и 32-битных библиотек. А потом, знаете ли, как-то и 3D подтянулось, и KMS вот работает, и вообще…

anonymous ()

В общем сделал ебилд 10.5 с патчем для 34 ядра, теперь xvba+vaapi можно пользоваться, а то на предыдущей версии с цветами был полный пипец при воспроизведении видео.

daemonpnz ★★★★★ ()
Ответ на: комментарий от anonymous

Та и так ясно , что кроме переходов на личности у тебя технических аргументов нет.

3D на свободных дровах тоже еще с приколами:
Просто обновляю ведро с 32 на 34 - бац и fps падает nexuiz c 45 до 8.
Не не, это все нормально и в пределах погрешности прогресса ))

elipse ★★★ ()
Ответ на: комментарий от elipse

> Та и так ясно , что кроме переходов на личности у тебя технических аргументов нет

Ой, ну хватит уже. Не позорь Пратчета. Можно подумать, ты меня завалил «техническими аргументами», а не написал какие-то процентики от балды, причём сам и признался в том, что не знаешь, как их померить.

anonymous ()
Ответ на: комментарий от anonymous

> отсутствия необходимости тянуть по 80 Мб сомнительного бинарного фуфла и 32-битных библиотек.

Вряд ли , упражнения с ведром, xorg, mesa & etc обходятся в меньший обьем суммарно.

elipse ★★★ ()
Ответ на: комментарий от Yareg

>Nouveu _никогда_ не будет лучше

Да, но если его функционала будет хватать, им будут пользоваться.

Viglim ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.