LINUX.ORG.RU

MATE 1.12

 


0

2

После 5 месяцев разработки вышла новая версия рабочего окружения MATE 1.12.

Основные изменения в новой версии:

  • Исправления и улучшения поддержки GTK3, включающие поддержку GTK 3.18.
  • Значительные улучшения поддержки тачпадов, включающие поддержку мультитач и естественной прокрутки.
  • Улучшена поддержка нескольких мониторов, изменен интерфейс выбора основного монитора в настройках дисплеев.
  • В аплете питания теперь отображается информация о модели и поставщике, по которым можно различить батареи в устройствах снабжённых несколькими аккумуляторами.
  • Улучшен менеджер сеансов, обеспечено отключение хранителя экрана во время воспроизведения видео.
    • Теперь отслеживается пространство имен org.gnome.SessionManager.
  • Улучшена поддержка systemd.
  • Исправления присутствующих длительное время недостатков.
    • Например, порядок размещения апплетов больше не изменяется при смене разрешения экрана.
  • Обновлены переводы, часть компонентов теперь использует строки из gschema.
  • Исключена поддержка платформ win32 и osx.

Скриншоты

>>> Подробности

Ответ на: комментарий от pro100fed

Только собрали его по старым PKGBUILD'ам. Зависимости, которые уже не нужны в этом релизе тянет.

APPLE_OS_XX_OS_XY ()
Ответ на: комментарий от kirill_rrr

Это что, они включение скринсейвера при воспроизведении видио пофиксили. Та фича за которую мне во втором гноме было стыдно перед виндузятниками.

APPLE_OS_XX_OS_XY ()
Ответ на: комментарий от SysoevDV

Сабж у меня стартует мгновенно. (И это на хдд)

invy ★★★★★ ()
Ответ на: комментарий от Oxdeadbeef

Нифига себе скоро. Через пол года аж.

invy ★★★★★ ()
Ответ на: комментарий от Gonzo

как правильно в Слаке установить сие дело?

смотри, как в слаке: ты можешь сам все компилить и ставить, либо если люди выкладывают, то они делятся способом , как все ставить, пример KDE от alien'а: http://alien.slackbook.org/ktown/14.1/latest/ там в README описано, как все ставить по порядку и что удалять и даже затронут способ как самому скомпилить и поставить, вернемся к MATE...

Основной сайт по MATE от Willy http://mateslackbuilds.github.io/
вот его блог здесь он (не только по мате) описывает состояние дел http://slackblogs.blogspot.ru/

Вот репозиторий msb (MATE SlackBuilds) этого самого http://slackware.org.uk/msb/
а вот и так сказать ReadMe для установки контента из него http://slackware.org.uk/msb/MSB_SLACKPKG

Т.е. задача сводится к тому, что бы, давай в общих чертах, если вопросы будут в дальнейшем отвечу:
1.1 Поставить Slackware (релизную, сейчас 14.1, если что когда 14.2 или другая выйдет я честно не знаю)
1.2. Обновиться через slackpkg (не +)
2. Поставить slackpkg+ http://slakfinder.org/slackpkg .html
3. Подключить репозиторий c msb-пакетами и обновиться, н-р для 32 и mate-1.10:

REPOPLUS=( msb32 )
MIRRORPLUS['msb32']=http://slackware.org.uk/msb/14.1/1.10/x86/
... в принципе и так далее, как описано в http://slackware.org.uk/msb/MSB_SLACKPKG

Так же, 1.12 пока он не выложил, но вот для 1.10 различные файлы имеются для чтения http://slackware.org.uk/msb/14.1/1.10/x86/
то же на них обрати внимание, в частности: KNOWN_ISSUES.TXT, MATE-1.10-CHANGES.TXT, UPGRADE.TXT

По MSB у меня с ним досадная вещь то же есть(
виджет погоды не пашет в часах, отдельно он работает, смотрел в slackware-14.1 и mate-1.10 mateweather рядом с часами

Но зато, вот было дело компилил даже topmenu, все ставилось и работало
я про http://www.webupd8.org/2014/12/get-global-menu-in-mate-18-with-topmenu.html

Еще, есть дистрибутив базируюшийся на slackware с менеджером пакетов slapt-get и уже собранным образом с mate: Salix http://www.salixos.org/
Ничего плохого постараюсь не говорить, но он как-то в обще перестал обновляться, компоненты слаки, да обновляются, но мате в нем на данный момент старенький (1.8.1).

NK ★★★★★ ()
Последнее исправление: NK (всего исправлений: 4)
Ответ на: комментарий от NK

А вот еще по MSB различные доп.компоненты, которые авторы по той-иной причине не выключил в состав пакетов:
https://github.com/mateslackbuilds/msb/tree/14.1-mate-1.12/testing
в принципе можно самому собрать и поставить, если сильно уж нужны, там он вроде поясняет про каждый

NK ★★★★★ ()
Ответ на: комментарий от vladimir_putin

Затрудняюсь ответить, но Е класс поставил обдуманно

Promusik ★★★★★ ()

Cinnamon, Mate... во их прёт работать :)

Stalin ★★★★★ ()

Похоже, что пора уходить с Gentoo: там до сих пор 1.8. MATE 1.10 даже в ~ нет.

anonymous ()

Хотел задонатить Mate-Desktop, а мне PayPal: «Введенная карта не может быть использована для данного платежа. Введите номер другой банковской карты.»

Погуглил - нужно зарегистрироваться и ввести паспортные данные + СНИЛС или другие документы. Какого хера я должен указывать эти данные в PayPal?

Deleted ()

Улучшена поддержка systemd.

Исключена поддержка платформ win32 и osx.

Не, ну а чо! Там же нету анальной блоатвари говнодэ!

Верной дорогой идете, товарищи подтерингопидоры! Хотели говна - получайте сполна, хлебайте полной ложкой! То ли еще будет... У Красной Дырки на вас большие планы...

Вот и возвращаются темные смутные времена засилья и диктата быдла и их непортируемого и аллергически непереносимого хардкожного говна. А если быть точнее, то они, оседлав волну энтерпрайза, для которого говно не пахнет, перекочевали из своей пустоши оффтопика 90-х со своими зверевцд и прочими улучшаторами-декораторами окон и ускоряторами интернетов на делфях, визжал бейсиках и 1с в райские угодья онтопика наших дней и прикидываясь своими стали агрессивно насаждать свою веру в говно через подкупы, насилие и расправы с неугодными...

Ты пришел в мир линукс, дабы познать радость свободы и почувствовать себя белым? Ты хотел беспрепятственно пересекать границы и колесить по миру платформам со своим чемоданом любимым софтом? Ты надеялся, что перед тобой откроются все двери? Оставь надежды, всяк сюда входящий! Линукс умер, да здравствует говно!

Indexator ★★★ ()
Ответ на: комментарий от Deleted

Возможно, сумма слишком большая, вроде есть какие-то лимиты по закону для анонимных переводов... Хотя хз, мож дело не в этом.. В последнее время столько всякого говна и запретов понапринимали, что уже не уследишь...

Indexator ★★★ ()
Последнее исправление: Indexator (всего исправлений: 2)
Ответ на: комментарий от Indexator

Популярные ОС вроде Linux, Windows и OS X используют те, кто отказался от свободы ради удобства.

APPLE_OS_XX_OS_XY ()
Ответ на: комментарий от anonymous

Ну и да, для неугомонных любителей «свежачка» есть 9999.

batekman ★★★ ()
Ответ на: комментарий от Indexator

Хм, сумма меньше 500 получилась (я ж студент). Фигня какая то.

Deleted ()
Ответ на: комментарий от Indexator

Не сказал бы, что анонимный: указан мой адрес, имя+фамилия+отчество.

Deleted ()
Ответ на: комментарий от Deleted

будет и в дебиан

Прекрасно, что баг поправили. Хорошо бы релиз 1.12 включили в Debian 9.

Не волнуйтесь, до выхода Debian 9 еще полтора года минимум))) еще много чего добавить вкусного захочется

maslakovvi ()
Ответ на: комментарий от NK

Спасибо большое, бро!

А что вот это такое значит в Слаке? (из его блога):

NOTE for -current Users:
As always, -current users are advised to build MATE from source to link against correct libraries installed on their machines. There are some differences between master and 14.1-mate-1.12 branch.

Starting today, master branch will be used for building latest MATE packages using slackware-current.

А то я нубоват.

Gonzo ★★★★★ ()
Ответ на: комментарий от NK

Еще, есть дистрибутив базируюшийся на slackware с менеджером пакетов slapt-get и уже собранным образом с mate

Вот за это вообще отдельное спасибо! Буду ковырять и изучать!

Gonzo ★★★★★ ()
Ответ на: комментарий от Gonzo

NOTE for -current Users:

заметка/примечание для пользователей slackware-current, кто захочет поднять mate у себя

NK ★★★★★ ()
Ответ на: комментарий от anonymous

Гента умирает. Сам частично переполз на Arch. Нет той гибкости, конечно, но зато свежий софт и обновляется почти мгновенно, если сравнивать с гентой.

anonymous ()
Ответ на: комментарий от batekman

любителей «свежачка»

В генте mate с марта (!) не обновлялся. Год скоро будет.

anonymous ()

Например, порядок размещения апплетов больше не изменяется при смене разрешения экрана.

Охренеть. Не прошло и десяти лет. А, нет, прошло.

Kaschenko ()

Улучшена поддержка платформ win32 и osx.

Исключена поддержка systemd.

Смотри не перепутай, Кутузов.

deity ★★★ ()
Ответ на: комментарий от Deleted

Хоп-хей! Оказывается программисты PayPal настолько кривожопые, что можно всего лишь «дозаполнить» данные аккаунта (всего лишь поменяв адрес проживания - это в десктопной версии справа-снизу на главной странице, там где PayPal жалуется, что он хочет «больше зол^w данных»), получить ошибку на то, что паспорт введён неверно и при этом же разблокировать платежи за границу от аккаунта. 5EUR Mate-Desktop отправить сумел :)

Дошли бы ещё деньги.

Deleted ()
Последнее исправление: merhalak (всего исправлений: 4)
Ответ на: комментарий от Deleted

Тоже самое, PayPal теперь требует эти данные, в соответствии с какими-то новыми российскими законами. Поэтому пользоваться PayPal перестал.

free_serj ★★ ()
Ответ на: комментарий от anonymous

Гента умирает.

Есть оверлеи. Если чего-то не хватает - я сам пишу себе ебилды, все ок.

Meyer ★★★★ ()
Ответ на: комментарий от anonymous

Официальным деревом конечно сыт не будешь. Но я как раз-таки про 9999, что в оверлее mate.

batekman ★★★ ()
Ответ на: комментарий от batekman

Даже с ~arch иногда бывают проблемы в процессе и после обновлений. С оверлеями и 9999 будет вообще ад. С обновлением GNOME судя по этому: gentoo где gnome 3.18 ? , тоже есть проблемы. GNOME 3.18 так и нет даже в ~arch, хотя вышло оно аж 23 сентября. Похоже, что в проекте Gentoo остается все меньше и меньше разработчиков и тестеров. По крайней мере для «desktop-ных» пакетов.

anonymous ()
Ответ на: комментарий от APPLE_OS_XX_OS_XY

Честно, даже не знал о этом баге. Потому что уже тогда использовал xscreensaver. Как более страшную, лёгкую и настраиваемую альтернативу.

kirill_rrr ★★★★★ ()
Ответ на: комментарий от Deleted

а юзеры дебиана не могут подключить какой-нибудь ppa, в котором лежит свежая версия мате?

stevejobs ★★★☆☆ ()
Ответ на: комментарий от NK

а каким образом она относится к логам? O_o

Чел дал картинку и спросил, что это за прога. Но каким боком Baobab относится к логам — понятия не имею. Возможно он спрашивал совсем про другую программу и залудил не тот скрин.

vold ★★★★★ ()
Ответ на: комментарий от Deleted

Какого хера я должен указывать эти данные в PayPal?

Вопрос не к PayPal, а к ГД ФС РФ, законы принимают там, а PayPal просто их выполняет.

ergil ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.