LINUX.ORG.RU

Вышел Calculate Linux 10.2

 , ,


0

0

Calculate Linux — семейство дистрибутивов, созданных на основе проекта Gentoo GNU/Linux и полностью с ним совместимые. Calculate Linux делится на три направления, это Calculate Directory Server (CDS), Calculate Linux Desktop (CLD, CLDX) и Calculate Linux Scratch (CLS).

Основные изменения:

  • Добавлена поддержка записи дистрибутива на Live USB при помощи утилиты UNetbootin.
  • Переход на calculate-sources с возможностью сборки бинарного пакета ядра.
  • Добавлены новые опции установки - выбор планировщика (--set-scheduler) и использование UUID меток дисков (--set-uuid).
  • Снижены требования к оперативной памяти при установке системы.
  • Интерфейс браузера Firefox стилизован под Oxygen KDE4, добавлены словари проверки орфографии.
  • В CLD/CLDX добавлена программа чтения книг FBReader.
  • В CLD добавлен OpenOffice Thumbnail плагин для отображения содержимого документов.
  • Ускорена работа samba сервера в CDS, снято ограничение 2Тб шары.
  • Добавлена новая утилита cl-kernel для компиляции ядра.
  • Добавлена поддержка принтеров Canon.

Сайт проекта: http://www.calculate-linux.org/ru

Скачать

>>> Подробности



Проверено: boombick ()

Откуда такое внимание этому дистрибутиву???

User2X ()
Ответ на: комментарий от User2X

Есть такая категория систем, называется «бесплатная винда»

amd ()
Ответ на: комментарий от User2X

В толксах недавно была тема с отзывами пользовавших.
Отзывы исключительно положительные.

Так что, просто очень качественно собранный Русский дистрибутив, со своими наработками, основанный и полностью совместимый с Gentoo.

Ещё у них интересный подход к обновлению.
По умолчанию выделяется 2 одинаковых по размеру раздела под корень.
Обновляется в формате:
1. Установил, корень на первом разделе.
2. Обновил, корень переместился на второй раздел, конфиги сохранились (скопированы на второй раздел). Первый раздел со старым корнем.
3. Обновил ещё раз. Затёрся корень на первом разделе, туда распаковалось обновление, ну и так далее.

CyberTribe ★★ ()
Ответ на: комментарий от CyberTribe

Надо ввести патенты на темы новостей (платные, конечно) и банить нарушителей патентов :-)

ip1981 ☆☆ ()

Новость не может не радовать))

nevar ★★ ()
Ответ на: комментарий от CyberTribe

> По умолчанию выделяется 2 одинаковых по размеру раздела под корень.

Обновляется в формате:


Ничё не понял, можно как-то внятнее разъяснить?
Это просто своп двух разделов или резервный раздел с работающими конфигами?

matumba ★★★★★ ()
Ответ на: комментарий от matumba

Подробнее на сайте разработчиков.
Вообще это два полноценных раздела под корневую систему.
При установке грузиться с первого раздела, куда и была установлена система.
После первого обновления грузиться со второго раздела, куда было установлено обновление и скопированы необходимые конфиги.
После второго обновления опять активен первый раздел.

CyberTribe ★★ ()
Ответ на: комментарий от CyberTribe

Всмысле один раздел для обновлений, второй для текущего корня системы. Т.е. мы просираем один раздел на диске равный разделу корня? П-Ц.

anonymous ()
Ответ на: комментарий от anonymous

>Всмысле один раздел для обновлений, второй для текущего корня системы. Т.е. мы просираем один раздел на диске равный разделу корня? П-Ц.

Старенький комп, да?

Lautre ★★★★★ ()

Очень кстати!!! Как раз вчера скачал и сегодня знакомому установил! Отличный дистрибутив!!!

andrey-x ()
Ответ на: комментарий от anonymous

10 гиг жалко? Корень не больше будет, по любому. Например, на нетбуке сейчас занятое место выглядит у меня так:

/dev/root              20G  6,8G   12G  37% /
/dev/sda4             126G  2,6G  117G   3% /home
/dev/sda1              99M   11M   84M  12% /boot
Так что, потери незначиетльны.

CyberTribe ★★ ()

я обнюхал этот колькулейт и выбрал старый добрый проверенный генту

hizel ★★★★★ ()
Ответ на: комментарий от hizel

я обнюхал этот колькулейт и выбрал старый добрый проверенный генту


Выбери профиль Gentoo 10.0 и будет тебе Gentoo :)
см. `eselect profile list`

Lautre ★★★★★ ()
Ответ на: комментарий от CyberTribe

> Вообще это два полноценных раздела под корневую систему.

А зачем это нужно? Чтобы бекап не делать? Или в этом дистрибутиве при каждом обновлении есть реальная опасность вообще не загрузиться?

ntp ()
Ответ на: комментарий от ntp

Нет, просто выбран такой механизм обновления.
Минусы уже выше названы, плюсы - обновление происходит очень быстро. (времени нужно ровно столько, сколько нужно на распаковку образа системы на диск + немного на копирование конфигов)

CyberTribe ★★ ()
Ответ на: комментарий от Lautre

Старенький комп, да?

не виже связи.

Я к тому, что это не рациональное использование ресурсов.

Нужно более красиво сделать, пока хорошо, но не профессионально.

anonymous ()
Ответ на: комментарий от ntp

>А зачем это нужно? Чтобы бекап не делать? Или в этом дистрибутиве при каждом обновлении есть реальная опасность вообще не загрузиться?

Я слышал много историй про «удачные» обновления бинарных дистрибутивов. Чтобы предотвратить эти 0.5%, а также чтобы время установки не занимало более 5 минут, мы выбрали схему обновления через отдельный раздел. Кстати нечто подобное в гуглоос применяют сейчас.

Lautre ★★★★★ ()
Ответ на: комментарий от anonymous

>Я к тому, что это не рациональное использование ресурсов.

Нужно более красиво сделать, пока хорошо, но не профессионально.

В офисе у нас на каждом компе стоит минимум 80 Гб винт. Куда девать столько ресурсов ума не приложу. Но вот если вдруг дровишки intel в новом дистрибутиве не понравятся, проще не бегать к каждому юзеру, а загрузить старую систему. Благо Grub показывает версии всех доступных систем.

Lautre ★★★★★ ()
Ответ на: комментарий от Lautre

Спасибо за годный русский дистрибутив (:

pevzi ★★★★★ ()
Ответ на: комментарий от Lautre

2Lautre

прислушайтесь к тому, что Вам люди говорят. Сделайте. Выйдите на более профессиональный уровень. Пока интересно, но слабо. Чисто касательно обновлений.

anonymous ()
Ответ на: комментарий от pevzi

Вот чем не ынтырпрайз дистр? Клиент, сервер варианты есть, софт необходимый есть, развертывать сеть можно быстро. В общем, респекты (:

pevzi ★★★★★ ()
Ответ на: комментарий от anonymous

>прислушайтесь к тому, что Вам люди говорят. Сделайте. Выйдите на более профессиональный уровень. Пока интересно, но слабо. Чисто касательно обновлений.

Но есть же Gentoo-way, обновление через emerge, Вас уже не устраивает?

Lautre ★★★★★ ()
Ответ на: комментарий от Lautre

Единственное, что я бы добавил - это binhost.
Для обновления через emerge, но с использованием бинарных пакетов.
Если интересно подробней как это сделать - джаббер в профиле.

CyberTribe ★★ ()
Ответ на: комментарий от CyberTribe

Calculate Linux 10.0 поддерживает обновление из бинарного репозитория. Другое дело что тут ещё очень много вопросов, которые нужно решить. Боюсь они не такие простые как кажется.

Lautre ★★★★★ ()
Ответ на: комментарий от CyberTribe

А эту замечательную фишку с двумя корнями возможно отключить?
Обычную генту возможно «обновить» до Calculate?

madcore ★★★★★ ()
Ответ на: комментарий от Lautre

Я имею в виду «официальный» binhost для обновления.
Поскольку вы всё равно собираете эти пакеты.
Если написать правильные usage policy проблем с высокой нагрузкой на канал быть не должно (в формате - если вам нужно обновить несколько компьютеров - создайте локальное зеркало binhost-а и обновляйтесь через него).

А какие вопросы есть?
Лично для себя использую, в каком-то смысле, похожую инфраструктуру. Есть «большой брат», который компилит пакеты, и они лежат по на nfs-ной шаре. 2 нетбука обновляются с этой шары. С binhost в классическом варианте пока не заморачивался, но не вижу там сеерьёзных проблем.

CyberTribe ★★ ()
Ответ на: комментарий от Lautre

> В офисе у нас на каждом компе стоит минимум 80 Гб винт.

В офисе - это понятно, но вот я хотел попробовать ваш дистрибутив на нетбуке, а у него (у данной модели) винт всего 8 гигов, установленный арч с кедами там занимает где-то 5 гигов, а вашу систему выходит я уже не могу поставить? или данный механизм обновления не обязателен к использованию?

Vark ()
Ответ на: комментарий от madcore

1. Да. Можете вручную разбивать диск.
2. Да. layman -a calculate - в этом оверлее все их собственные наработки. Ставьте то что вам нравится. Остальное из portage.

CyberTribe ★★ ()

Не понял назначение этого дистриба. Даже после похода на сайт. Они ориентируются на компы в локальных сетях в среде офисного планктона?

Stalin ★★★★★ ()
Ответ на: комментарий от Vark

Вы можете разбить жёсткий диск вручную и сделать соотственно один раздел на 8 гиг.
Проблема будет с обновлением.

CyberTribe ★★ ()
Ответ на: комментарий от Lautre

>мы выбрали схему обновления через отдельный раздел.

Lautre, я до сих пор немножко не вкуриваю по поводу размера. Поясню: мой раздел с CLDX (/home находится там же) - 33 Гб. Из них занято 14.8 Гб.
Значит ли это, что для обновления мне понадобится создать пустой размер как минимум 15 Гб? Или 33?

Steplton ★★★★★ ()
Ответ на: комментарий от CyberTribe

А как это сделать в calculate? Пробовал у меня не получилось никак...

anonymous ()
Ответ на: комментарий от anonymous

Отгрызть раздел, скопировать на него содержимое хомяка и прописать его в fstab, чтобы монтировалсо как /home. вроде так.

nevar ★★ ()
Ответ на: комментарий от Steplton

Ты можешь его обновить в стиле дженты, через emerge -u world

Lumi ★★★★★ ()
Ответ на: комментарий от anonymous

В калькулейте это делается также, как и в любом другом дистре. Или ты хочешь мышой поелозить?

Lumi ★★★★★ ()
Ответ на: комментарий от Lumi

На самом деле обновление в тот же раздел мы реализуем возможно даже в следующей версии. Как раз для таких случаев, как нетбук с ограниченным размером винта.

Lautre ★★★★★ ()

Lautre, скажи, пожалуйста, что подразумевается под «была добавлена поддержка принтеров Canon»? Canon MF3110 уже поддерживается?

Не троллинга ради, а проблема насущная. Даже официально поддерживаемый LBP2900 я не могу заставить работать стабильно - долбаный capt и ccpd работают через раз, нестабильно. Исходники, предоставленные Canon, похоже, собираются только под i686 и только определёнными версиями gcc

Пожалуйста, расскажи подробно, что было сделано для поддержки этих вшивых принтеров?

hc ()
Ответ на: комментарий от hc

О, тоже столкнулся с LBP2900.. :( собирал под Ubuntu 9.10, отправляет на печать но не печатает....

UnnamedUA ()
Ответ на: комментарий от UnnamedUA

Оно у меня когда-то работало под слакой на 1.60 и потом под арчем на 1.80, но после каждого задания надо было проверять, не вылетел ли ccpd. После включения/выключения принтера надо было перезапускать ccpd. 1.60 очень любили сыпать сегфолтами в dmesg. Но оно работало. На x86_64 оно не работает никак. И не собирается. На arm тоже.

Решил проблему переходом на HP P1005. Cups 1.4.* вызывает у меня лютую ненависть. foo2zjs требует псевдоустройства /dev/usblp, чтобы записать прошивку, а Cups 1.4 конфликтует с модулем usblp. Поэтому приходится использовать HPLIP.

Но так как бывший мой принтер предполагается ещё использовать, хочется узнать, что же сделали авторы CL для поддержки этих говнопринтеров

hc ()
Ответ на: комментарий от hc

А к MF3110 у меня вообще особая ненависть. На linuxprinting.org написано, что драйвер есть только под WinXP 32-bit, а это значит, что в случае перехода моего предприятия на новые компы один из принтеров придётся выкинуть нахрен

hc ()
Ответ на: комментарий от hc

Вообще, как выясняется, с принтерами, обладающими низкой ССВ (нет анального прошивания картриджей, как у клятого Samsung ML2245, да ещё и тонер к нему нигде не найдёшь, низкая цена самого печатника и недорогая перезаправка), в линуксе (а, точнее, в cups) всё ещё хуже, чем с видеокартами. Насчёт сканеров не знаю, пока, слава богу, не сталкивался, но с принтерами воевал долго и мучительно

Lautre, ну не томи же душу, расскажи на милость, как вы кенонов побороли

hc ()
Ответ на: комментарий от hc

В свое время мы полностью перешли на HP. Поэтому потестировать возможности практически нет. Добавили пакет net-print/cnijfilter. Появилась поддержка ip1800 ip1900 ip2500 ip3300 ip3600 ip4300 ip4600 ip90 mp160 mp190 mp240 mp510 mp540 mp600 mp630. Насколько я знаю есть еще один пакет с драйверами других моделей. Как только будет информация о том что работает - добавим и его.

Lautre ★★★★★ ()
Ответ на: комментарий от Lautre

А, принтеры серии ip и mp... С ними всё ясно, устаревшие и ненужные струйники. Вот лазерники со сраным capt-ом если бы - другой вопрос

Спасибо за уточнение

hc ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.