LINUX.ORG.RU

Вышел Calculate Linux 15

 , , ,


1

3

Мы рады сообщить о выходе нового релиза Calculate Linux 15 !

Доступны для загрузки следующие редакции дистрибутива: Calculate Linux Desktop с рабочим столом KDE (CLD), Mate (CLDM) и Xfce (CLDX), Calculate Directory Server (CDS), Calculate Linux Scratch (CLS), Calculate Scratch Server (CSS) и Calculate Media Center (CMC).

Основные изменения

  1. Новый метод обновления пакетов
    • Повышенная надежность
      Каждое зеркало бинарных пакетов теперь хранит информацию о версии модификации, что позволяет использовать для обновления любое из доступных зеркал, а так же создавать зеркало обновлений в локальной сети.
    • Увеличена скорость обновлений
      Утилита обновления оценивает скорость канала каждого зеркала, выбирая наиболее быстрое зеркало. Установка пакетов теперь по умолчанию выполняется параллельно. По умолчанию в cl-update отключен вызов revdep-rebuild
    • Выше уровень тестирования
      Подготовленные бинарные пакеты до выгрузки на master-зеркало проходят дополнительную проверку в тестовом зеркале.
    • Снижен трафик
      При отсутствии обновлений убраны запросы для синхронизации портежей.
  2. Общие репозитории бинарных пакетов
    • Профили дистрибутивов теперь унифицированы. Для сборки бинарных пакетов создано три новых дистрибутива с USE-флагами под различные конфигурации. Репозитории насчитывают более 2500 популярных бинарных пакетов.
  3. Новая версия утилит Calculate 3.4
    • Полностью переписаны утилиты сборки системы.
      • Добавлена поддержка графического интерфейса в Calculate Console.
      • Добавлена поддержка overlayfs для мгновенного разворачивания системы.
      • Добавлена поддержка использования списка бинарных зеркал для обновления.
      Изменён алгоритм загрузки обновлений Добавлена поддержка создания мультизагрузочной Flash.
  4. Репозиторий бинарных пакетов включает, помимо стабильной, всегда свежую версию ядра.
  5. Добавлена поддержка голландского языка.

Состав версий и потребление памяти

  1. CLD (KDE desktop):
    • KDE 4.14.12, LibreOffice 4.4.5.2, Chromium 45.0.2454.101, Gimp 2.8.14, Amarok 2.8.0
    • i686 — 2.03 G, x86_64 — 2.22 G
  2. CLDM (MATE desktop):
    • MATE 1.8, LibreOffice 4.4.5.2, Chromium 45.0.2454.101, Claws Mail 3.11.1, Gimp 2.8.14, Clementine 1.2.3
    • i686 — 1.66 G, x86_64 — 1.84 G
  3. CLDX (Xfce desktop):
    • Xfce 4.12, LibreOffice 4.4.5.2, Chromium 45.0.2454.101, Claws Mail 3.11.1, Gimp 2.8.14, Clementine 1.2.3
    • i686 — 1.65 G, x86_64 — 1.83 G
  4. CDS (Directory Server):
    • OpenLDAP 2.4.38, Samba 3.6.25, Postfix 3.0.2, ProFTPD 1.3.5, Bind 9.10.2
    • i686 — 720 M, x86_64 — 748 M
  5. CLS (Linux Scratch):
    • Xorg-server 1.16.4, Openbox 3.6.1, Kernel 3.18.20
    • i686 — 800 M, x86_64 — 905 M
  6. CSS (Scratch Server):
    • Kernel 3.18.20, Calculate Utilities 3.4.0.2
    • i686 — 512 M, x86_64 — 539 M
  7. CMC (Media Center):
    • Kodi 15.1, Xorg-server 1.16.4
    • i686 — 1.10 G, x86_64 — 1.27 G

>>> Анонс

★★★★★

Проверено: leave ()

вы не думали над тем, чтобы привести дефолтный облик кед в нормальный вид?

anonymous ()

Хорошая новость! Обновляюсь.
Самый адекватный дистр в плане соотношения автоматизация-понятность в настройке.

fractaler ★★★★★ ()

Богомерзкий Flash-player так же в составе приезжает?

dv76 ★★ ()
Ответ на: комментарий от kernelgood

Альпийская свежесть!

Какая же тут свежесть? Mate старый.

camac ()

да что же это такое? чуть ли не каждый день кто-то выпускает обновление дистрибутива :)

grem ★★★★★ ()

Так, мне вот что не понятно: по идее же, он сам ко мне приедет, когда cl-update запустися?

И да, отличная новость про отлтчный дистрибутив!

anonymous ()
Ответ на: комментарий от zippo

потому, что по умолчанию официальным считается поставка с KDE? тебя не удивляет, что Fedora Workstation идёт с GNOME?

camac, Альпы тоже не новые, да и XFCE не новее

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)

Летом ставил его, когда Минт сдох из-за ндостатка места в корне. Очень тормозил и жёг батарейку. Перешёл на Дебиан.

Vudod ★★★★★ ()
Ответ на: комментарий от Vudod

жёг батарейку

Основная проблема кальки - это гента и не-гента одновременно. Всякие утилитки «развращают» юзера и не приучают искать решение. В данном случае, решение - tlp или конфиг laptop-tools + м.б. подкрутка ядра.

Очень тормозил

Это тоже решаемо если установить причину.

fang90 ★★★★★ ()
Последнее исправление: fang90 (всего исправлений: 1)
Ответ на: комментарий от fang90

Сброс в своп, скорее всего, если на компе памяти мало. Было такое.

anonymous ()

Ктонить может сказать: версия ТеХЖизни полного комплекта там 2015-ый?

bookman900 ★★★★★ ()
Ответ на: комментарий от zippo

Почему не CLDK?

Потому что дефолт в кальке это KDE. С gnome3 нет сборок.

ggrn ★★★★★ ()

Зачем оно нужно, когда есть Ubuntu?

капча 282

anonymous ()
Ответ на: комментарий от ggrn

То есть, пользоваться дефолтом нормально нельзя?

zippo ()

Спасибо разработчикам за этот дистрибутив. Использую больше пяти лет, нравится. До этого использовал Mandrake, ASPLinux, Mandriva, openSusi, немного Debian и Sidux. Тут дело привычки, но в Calculate мне нравится то, что при установке пакета можно выбрать конкретную версию. Радует скорость установки и обновления системы. В дистрибутиве много новаторских решений. Пару дней назад обновился, прилетела космическая заставка на вкл/выкл, красиво :)

arm-skif ()

Всё задаюсь вопросом: Чем кроме возможности компиляции из сорсов может похвастать дженту?

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

портежом, на фоне которого все остальные линуксовые ПМ выглядят неюзабельным говном

anonymous ()
Ответ на: комментарий от anonymous

Хорошо, как я понял по опыту, во FreeBSDб если установить из портов что либо, то например это легко обновится пакетом в следующем обновлении это также и тут?

sniper21 ★★★★★ ()
Ответ на: комментарий от zippo

То есть, пользоваться дефолтом нормально нельзя?

Видимо ребятки из кальки не котируют гнум3

ggrn ★★★★★ ()

Чем меня радуют релизы кальки и КДЕ - как обычно, это реальные изменения эволюционные, а не просто увеличение версий пакетов ради циферок, а это редкость.

LightDiver ★★★★★ ()
Последнее исправление: LightDiver (всего исправлений: 1)
Ответ на: комментарий от anonymous

ну вот вчера я слелал

# cd /usr/ports/x11/lumia
# make install clean

Сегодня кто-то собрал пакет с Lumia и положил в официальные репы. Я сделал # pkg upgrade и всё, весь мой скопилированный мной пакет заменился на собраный официально. Т.е нет никакого флага, что «не обновлять этот пакет бинарно так как он был скомпилирован» А вот как с этим в Gentoo?

P.s да я знаю что есть некий «hold package» предотвращающий такое обновление, но это же не дело так расставлять эти hold кучами.

sniper21 ★★★★★ ()
Последнее исправление: sniper21 (всего исправлений: 1)

Разрабы Кальки по-прежнему против мейнстрима?

Sunderland93 ★★★★★ ()
Ответ на: комментарий от sniper21

по дефолту portage вообще игнорирует бинарные пакеты, поэтому чтобы он начал _по_возможности_ брать бинарные пакеты для обновления или установки, нужно указать опцию -g, а чтобы он брал _только_ бинарные пакеты - опцию -G

anonymous ()
Ответ на: комментарий от anonymous

Хм, интересно. Попробуем кальку на выходных.

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

А вот как с этим в Gentoo?

Маскируешь пакет из всех оверлеев кроме твоего(или официального дерева) = профит. За обновлениями только тоже самому следить тогда придется, но я так понял именно это тебе и надо

P.S. Анонимус выше правильно уточнил, что в Gentoo(не в Calculate) бинарные пакеты по умолчанию не используются. В Calculate же - наоборот, из исходников идет сборка, только если по-другому никак.

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)
Ответ на: комментарий от sniper21

Если ты в gentoo сделаешь «# make install clean» для чего-то из исходников, то portage ничего знать не будет о таком «пакете» и соответственно ничего обновить, удалить, переустановить не сможет для данного «пакета», за исключением зависимостей, если ты их ставил через emerge.

grem ★★★★★ ()
Ответ на: комментарий от grem

нет я говорил про FreeBSD. Вот и спрашивал как будет в Gentoo в таком случае, если ставить из исходников «по гентушному»

sniper21 ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Мне нужно так:

Я поставил из пакетов всё что мне хотелось. Потом то что мне хотелось поставил из исходников.

А при обновлении, то что я поставил из исходников никак не затиралось бинарным пакетом. Это первое. И второе. Мне бы сообщалось что вот этот, этот и этот пакет у тебя из исходников, хочешь пересоберем новые версии?

sniper21 ★★★★★ ()
Ответ на: комментарий от anonymous

В кальке-то? Игнорирует бинарные пакеты?

anonymous ()
Ответ на: комментарий от sniper21

насчёт кальки я ничего сказать не могу, ибо не пользовался, но если там в качестве основных используются бинарные репы, то чтобы бинарные пакеты не затирали собранные из сорсов, придётся, наверное, кидать их в локальный репозиторий

anonymous ()
Ответ на: комментарий от sniper21

Если пакет установлен и более новые версии тобой не замаскированы, то при появлении в дереве более новой незамаскированной версии он обновился на неё. Чтобы оно затёрлось чем-то при наличии маскировки пакета, нужно постараться, мне такие случаи неизвестны. У бинарных пакетов из дерева обычно есть суффикс -bin и они считаются отдельным пакетом, замещающим тот, что из исходников. Сами они не ставятся.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от grem

Интересно, почему оно вообще обновляет собранное из исходников пакетом без спроса?

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

Так в Gentoo из коробки не получится. Но заюзав /etc/portage/bashrc можно запретить определенным пакетам ставится из бинарей. Правда это будет выглядеть некрасиво(тянуть по зависимостям он их будет, а вот при установке будет облом), так что так делать не стоит.

Pinkbyte ★★★★★ ()
Ответ на: комментарий от sniper21

В смысле? Там (в gentoo) и так почти всё пакеты из исходников, за очень малым исключением. И команда обновить все пакеты в системе предполагает, что ты ей это разрешаешь в соответствии с установленными, в том числе тобой, правилами.

grem ★★★★★ ()
Ответ на: комментарий от sniper21

В Gentoo для определения индивидуальных предпочтений для сборки пакетов есть специальный механизм.
В файле /etc/portage/package.use описываются «правила сборки пакетов»
Вот пример:

app-admin/conky X ncurses portmon truetype vim-syntax apcupsd -audacious -curl -debug -eve hddtemp imlib iostats lua lua-cairo lua-imlib -math -moc -mpd -nano-syntax nvidia -rss -thinkpad -weather-metar -weather-xoap -wifi -xmms2
app-admin/syslog-ng json
app-admin/testdisk ntfs reiserfs



В файле /etc/portage/package.mask можно указать какие пакеты ты ни в коем случае не желаешь видеть в свой системе
Вот пример:

=app-office/libreoffice-4.4.5.2
>=net-fs/samba-4.0.0_alpha1

Ну и ещё с десяток различных «вкусностей» :)
При обновлении системы portage учитывает все твои «документированные капризы»...

Pronin ★★★★ ()
Последнее исправление: Pronin (всего исправлений: 1)

Очередной дистрибутив для побаловаться в VirtualBox....очередное не нужно.

Odalist ★★★★★ ()
Ответ на: комментарий от Pinkbyte

/etc/portage/make.conf/cusom FEATURES="-getbinpkg" канпеляй на здоровье :)

anonymous ()
Ответ на: комментарий от anonymous

make.conf можно по отдельным файлам разносить, как package.use?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.